how to install AutoCAD 2016 using play on linux

Автор Replies
yashwant Monday 15 February 2016 at 13:50

i want to install autocad 2016 in linux OS but the play on linux not to install autocad on linux.so please give a detail how to install autocad 2016.

booman Friday 19 February 2016 at 22:53

I've been wanting to try AutoCAD in PlayOnLinux for a long time.  The only version I have is an old AC2006.  I don't even think there are trial versions of AutoCAD anymore. sad

Do you have a legal copy of AutoCAD 2016?

Looks like AutoCAD still has Direct X 9 support but also requires Dot NET Framework 4.5 (specs) so there is a chance it might work.  You will be on-your-own to test it.  It can get a bit repetative when having to re-install over and over if it doesn't work right away.

I can walk you through a manual installation for testint puproses.

† Booman †
Mint 21 64-bit | Nvidia 515| GeForce GTX 1650
Linux for Beginners | PlayOnLinux Guides | PlayOnLinux Explained
phil_n Saturday 25 November 2017 at 4:29

Hi all. My first post here.

Any action on this? I'm trying to install 2006. It gets as far as the AutoCAD 'Install' dialog then says it needs to install 'extra components' and when it tries to install dotnet 1.1 throws the error "Failed to delay load library mscorlib.dll (Win32 error:)." I have tried pre-installing dotnet 1.1 from the POL components into the wineprefix I gave the POL virtual drive (acad2006) but the autocad installer didn't seem to recognize it. Maybe I should have tried putting it in 'general'?

I'm thinking of starting from the bottom and working my way up through the various windows versions (works fine in native 95 and win7) and wine versions through POL.

Any help would be greatly appreciated.

BTW I'm using MX16 - without systemd - it's real good so far.


ImperatorS79 Saturday 25 November 2017 at 9:21

it should work flawlessly ->https://appdb.winehq.org/objectManager.php?sClass=version&iId=6035

POL5 is here ! -> https://github.com/PhoenicisOrg/phoenicis
booman Sunday 26 November 2017 at 13:42

AppDB says that AutoCAD 2006 only needs dotnet20 which "should" install just fine during the packages step in PlayOnLinux.  If not, just find it online, download it and install it manually.

† Booman †
Mint 21 64-bit | Nvidia 515| GeForce GTX 1650
Linux for Beginners | PlayOnLinux Guides | PlayOnLinux Explained
phil_n Saturday 2 December 2017 at 1:58

Thanks for the replies - I'll be trying it again soon. But, should dotnet20 be installed to the wineprefix or to  default?

ps. Just noticed the 'subscribe' button at the bottom of the thread - duh. Lucky I still had this open in a tab in PaleMoon which is working great in MX16 (without auto-load videos - not sure what it does if you actually want to see them).

phil_n Saturday 2 December 2017 at 6:45

So far it seems to be working. Wine 1.4.1 - dotnet20 installed to the prefix (I called it acad2006). Had a little trouble at first with acad coughing and spluttering errors and wine shutting down once but I just clicked 'ok' on whatever and now it looks good.

Thanks again.

ps. I think you should change the project name to RunOnWine - covers a lot more first-impression ground than Play. But, you guys have come along way - Wine included. Whoever would have thought you could run something like AutoCAD on linux without a VM and a copy of Windows? Amazing. (and wihout systemd)

ImperatorS79 Saturday 2 December 2017 at 8:51

Did it work with wine 2.0 ?

POL5 is here ! -> https://github.com/PhoenicisOrg/phoenicis
phil_n Saturday 2 December 2017 at 9:53

Not sure I even tried 2.0. I might have on my first attempt but kept getting stuck at that 'load library' error. This time I cleared out the whole wine and POL install (there was nothing else installed so I didn't lose anything). Then I first installed POL from the MX repos (IIRC), then went straight to wine 1.4.1 (in POL) as in the link in the 4th post here, then installed dotnet20 and after that it worked. (We have a full moon here tonight - that might have had something to do with it surprise)

Sorry I couldn't be of more help there.

Aund1981 Tuesday 5 December 2017 at 19:39

so, do we have an exact answer, is it possible to install it? i've been wondering that for a while now... any help appreciated

phil_n Friday 8 December 2017 at 4:28

See my reply above (post 7 if I can still count). It's working - loaded a dxf created in the windows install and everything looks ok. I have yet to actually try to do anything with it but it looks good. I'm going to try printing (plotting) later on and see what happens.

I'm no guru at any of this so....YMMV

booman Tuesday 10 September 2019 at 16:38

I'm glad its working.... creating your own prefix was a good idea.  I always create a new prefix for every game or application.  It helps to organize things in PlayOnLinux and keep those dependencies separated.

Keep us updated on performance and compatibilitiy.

As for AutoCAD 2019... here are the system requirements:

  • 3GHz CPU
  • 8 GB RAM
  • DirectX 11 1GB GPU
  • Dotnet 4.7
  • d3dcompiler_47

Winetricks can install dotnet47 in your wineprefix


† Booman †
Mint 21 64-bit | Nvidia 515| GeForce GTX 1650
Linux for Beginners | PlayOnLinux Guides | PlayOnLinux Explained
Moulton84 Wednesday 25 September 2019 at 12:45

AutoCAD doesn’t run on Linux. But there is a really great CAD software that does run on Linux, called DraftSight. It’s a high quality, commercial (but free) CAD package available for both Linux and Windows WalgreensListens

Edited by Moulton84

Вы находитесь здесь: Index > PlayOnLinux > how to install AutoCAD 2016 using play on linux