Вы находитесь здесь

Форум

winiget winhttp MD5 sum mismatch

Автор Replies
Diogovmm Saturday 30 July 2016 at 15:18
DiogovmmAnonymous

When I try to run heroes of the storm or hearthstone or battlenet I get this:

[07/30/16 13:58:16] - Running wine-1.9.3-HeroesOfStorm-40083bugfix Battle.net Launcher.exe (Working directory : /home/xut/.PlayOnLinux/wineprefix/heroes_of_the_storm/drive_c/Program Files/Battle.net)
fixme:heap:RtlSetHeapInformation (nil) 1 (nil) 0 stub
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:WinHttpDetectAutoProxyConfigUrl discovery via DHCP not supported
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:ver:GetCurrentPackageId (0x456e9f8 (nil)): stub
fixme:wininet:InternetSetOptionW Option 77 STUB
err:wininet:open_http_connection create_netconn failed: 12029
fixme:wininet:InternetSetOptionW Option 77 STUB
err:wininet:open_http_connection create_netconn failed: 12029
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:wininet:InternetSetOptionW Option 77 STUB
err:wininet:open_http_connection create_netconn failed: 12029
fixme:wininet:InternetSetOptionW Option 77 STUB
err:wininet:open_http_connection create_netconn failed: 12029
fixme:ver:GetCurrentPackageId (0x49be9f8 (nil)): stub
fixme:wininet:InternetSetOptionW Option 77 STUB
err:wininet:open_http_connection create_netconn failed: 12029
fixme:wininet:InternetSetOptionW Option 77 STUB
err:wininet:open_http_connection create_netconn failed: 12029
fixme:wininet:InternetSetOptionW Option 77 STUB
err:wininet:open_http_connection create_netconn failed: 12029
fixme:wininet:InternetSetOptionW Option 77 STUB
err:wininet:open_http_connection create_netconn failed: 12029
fixme:wininet:InternetSetOptionW Option 77 STUB
err:wininet:open_http_connection create_netconn failed: 12029
fixme:win:EnumDisplayDevicesW ((null),0,0x33f578,0x00000000), stub!
fixme:wbemprox:wbem_locator_ConnectServer unsupported flags
fixme:wbemprox:client_security_SetBlanket 0x7dcffba8, 0x16a170, 10, 0, (null), 3, 3, (nil), 0x00000000
fixme:wbemprox:client_security_Release 0x7dcffba8
fixme:wininet:InternetSetOptionW Option 77 STUB
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:WinHttpDetectAutoProxyConfigUrl discovery via DHCP not supported
fixme:wbemprox:enum_class_object_Next timeout not supported
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:ver:GetCurrentPackageId (0x456e9f8 (nil)): stub
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
<html><head><title>Object moved</title></head><body>  
<h2>Object moved to <a href="http://www.blizzard.com/404">here</a>.</h2>  
</body></html>  
<html><head><title>Object moved</title></head><body>  
<h2>Object moved to <a href="http://www.blizzard.com/404">here</a>.</h2>  
</body></html>  
<html><head><title>Object moved</title></head><body>  
<h2>Object moved to <a href="http://www.blizzard.com/404">here</a>.</h2>  
</body></html>  
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
wine: Call from 0x7b83eba2 to unimplemented function api-ms-win-crt-runtime-l1-1-0.dll._initialize_onexit_table, aborting
err:module:attach_process_dlls "MSVCP140.dll" failed to initialize, aborting
err:module:LdrInitializeThunk Main exe initialization for L"C:\\Program Files\\Battle.net\\Battle.net.7730\\Battle.net.exe" failed, status 80000100
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform

Thinking that it is a winhttp and wininet problem, I try to go to configurations and install both. When I do that I get:

I can click retry as many times as I want, then I click no and get:

"Error in POL_Download_Resource
MD5 sum mismatch ! (2 attempt)"

If I try to install with winetricks I get:

"sha1sum mismatch! Rename /home/xut/.cache/winetricks/win2ksp4/W2KSP4_EN.EXE and try again."

-------------------------------------------------------------------------------------------------------------------------------------

I have tried many things nothing works! I have this problem for a week now.

At https://github.com/Winetricks/winetricks/issues/600#issuecomment-236248854

 
 

Thanks for the suggestion about --version, of course you're absolutely right.

To clarify. Winetricks did fall back on archive.org, but archive.org wouldn't respond, either through wget or via the browser (from the browser, it would say to try again). I waited half an hour, tried again multiple times, and still nothing.
To be absolutely clear, the link suggested above in this thread - http://web.archive.org/web/20160129053851/http://download.microsoft.com/download/E/6/A/E6A04295-D2A8-40D0-A0C5-241BFECD095E/W2KSP4_EN.EXE - wouldn't start a download.

As a workaround, I downloaded the file from one of the other mirrors (http://www.filewatcher.com/m/W2KSP4_EN.EXE.135477136-0.html) and copied the .exe file into /home/USER/.cache/winetricks/win2ksp4, then run again the script and all went smoothly.

Tried again now (10 hours later) and all works fine, i.e. the link above on archive.org works just fine from both wget and browser.

In brief, this is an archive.org issue. Perhaps adding a second fallback option may be of help.

 

 

 
 

 

I am new to linux, and either I don't know how to proprely reproduce what this person did to solve the problem, or it doesnt work with me.

I was using xubuntu, but I tried too to reinstall and now have Intel® Core™ i5 CPU M 480 @ 2.67GHz × 4 ||| ubuntu 14.04 LTS trusty.

Thank you for any help.

booman Sunday 31 July 2016 at 17:14
booman

Ah, the Battle.net Visual C 2015 problem.  Battle.net recently upgraded to that 2015 version and broke Wine.  I noticed some posts on reddit about it and some solutions.  Looks like you are on the right track, but I haven't had a chance to test it.

Try the steps like this....

  1. Open PlayOnLinux
  2. Click Configure
  3. Select Battle.net virtual drive (left side)
  4. Click Miscellaneous Tab
  5. Click "Open a Shell"
  6. Copy/paste this command:
    wget https://raw.githubusercontent.com/Winetricks/winetricks/master/src/winetricks
  7. Type this command:
    chmod +x winetricks
  8. Copy/paste this command:
    WINEPREFIX=/home/username/.PlayOnLinux/wineprefix/virtualdrive ./winetricks -q vcrun2015

This totally worked for Battle.net and I can now launch and login.  Make sure your Wine Windows version is set to Windows XP

 

Edited by booman


† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Diogovmm Sunday 31 July 2016 at 20:35
DiogovmmAnonymous

After I use the command you proposed I got (At the first time I think wine did update something after I issued the command):

Unknown arg vcrun2015
Usage: /usr/bin/winetricks [options] [command|verb|path-to-verb] ...
Executes given verbs.  Each verb installs an application or changes a setting.

Options:
    --force           Don't check whether packages were already installed
    --gui             Show gui diagnostics even when driven by commandline
-k, --keep_isos       Cache isos (allows later installation without disc)
    --no-clean        Don't delete temp directories (useful during debugging)
    --no-isolate      Don't install each app or game in its own bottle
-q, --unattended      Don't ask any questions, just install automatically
-r, --ddrescue        Retry hard when caching scratched discs
    --showbroken      Even show verbs that are currently broken in wine
-v, --verbose         Echo all commands as they are executed
-h, --help            Display this message and exit
-V, --version         Display version and exit

Commands:
list                  list categories
list-all              list all categories and their verbs
apps list             list verbs in category 'applications'
benchmarks list       list verbs in category 'benchmarks'
dlls list             list verbs in category 'dlls'
games list            list verbs in category 'games'
settings list         list verbs in category 'settings'
list-cached           list cached-and-ready-to-install verbs
list-download         list verbs which download automatically
list-manual-download  list verbs which download with some help from the user
list-installed        list already-installed verbs
prefix=foobar         select WINEPREFIX=/home/xut/.local/share/wineprefixes/foobar

Afterwards I tried to load the game but got:

[07/31/16 19:16:39] - Running wine-1.9.3-HeroesOfStorm-40083bugfix Battle.net Launcher.exe (Working directory : /home/xut/.PlayOnLinux/wineprefix/heroes_of_the_storm/drive_c/Program Files/Battle.net)
fixme:heap:RtlSetHeapInformation (nil) 1 (nil) 0 stub
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:WinHttpDetectAutoProxyConfigUrl discovery via DHCP not supported
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:ver:GetCurrentPackageId (0x456e9f8 (nil)): stub
fixme:wininet:InternetSetOptionW Option 77 STUB
err:wininet:open_http_connection create_netconn failed: 12029
fixme:wininet:InternetSetOptionW Option 77 STUB
err:wininet:open_http_connection create_netconn failed: 12029
fixme:wininet:InternetSetOptionW Option 77 STUB
err:wininet:open_http_connection create_netconn failed: 12029
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:ver:GetCurrentPackageId (0x49be9f8 (nil)): stub
fixme:wininet:InternetSetOptionW Option 77 STUB
err:wininet:open_http_connection create_netconn failed: 12029
fixme:wininet:InternetSetOptionW Option 77 STUB
err:wininet:open_http_connection create_netconn failed: 12029
fixme:win:EnumDisplayDevicesW ((null),0,0x33f578,0x00000000), stub!
fixme:wbemprox:wbem_locator_ConnectServer unsupported flags
fixme:wbemprox:client_security_SetBlanket 0x7dcffba8, 0x16a0c8, 10, 0, (null), 3, 3, (nil), 0x00000000
fixme:wbemprox:client_security_Release 0x7dcffba8
fixme:wininet:InternetSetOptionW Option 77 STUB
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:WinHttpDetectAutoProxyConfigUrl discovery via DHCP not supported
fixme:wbemprox:enum_class_object_Next timeout not supported
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:ver:GetCurrentPackageId (0x456e9f8 (nil)): stub
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
wine: Call from 0x7b83eba2 to unimplemented function api-ms-win-crt-runtime-l1-1-0.dll._initialize_onexit_table, aborting
err:module:attach_process_dlls "MSVCP140.dll" failed to initialize, aborting
err:module:LdrInitializeThunk Main exe initialization for L"C:\\Program Files\\Battle.net\\Battle.net.7730\\Battle.net.exe" failed, status 80000100
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
<html><head><title>Object moved</title></head><body>  
<h2>Object moved to <a href="http://www.blizzard.com/404">here</a>.</h2>  
</body></html>  
<html><head><title>Object moved</title></head><body>  
<h2>Object moved to <a href="http://www.blizzard.com/404">here</a>.</h2>  
</body></html>  
<html><head><title>Object moved</title></head><body>  
<h2>Object moved to <a href="http://www.blizzard.com/404">here</a>.</h2>  
</body></html>  
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
[07/31/16 19:17:00] - ----- Starting function POL_Install_wininet -----
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform

Using "WINEPREFIX=/home/username/.PlayOnLinux/wineprefix/virtualdrive ./winetricks -q vcrun2015"I get bash: ./winetricks: No such file or directory I used my username and heroes_of_the_storm instead of virtualdrive.

 

After these steps I still can't install neither winhttp or winiget at POL->configurations->install components

Today I think I yet have the time to uninstall both wine and POL and retry these steps, hope never dies!

Thank you for your help untill now.

 


 

Diogovmm Monday 1 August 2016 at 0:49
DiogovmmAnonymous

I reinstalled and still the same,

Unknown arg vcrun2015

Isn't there a way to change the scrip of POL in the part that it leads to the wrong site of w2ksp4.exe and redirect to a right one, avoiding the wininet and winhttp installation problem?

Or this has nothing to do with it and I got it wrong?

Thank you for the help.

booman Monday 1 August 2016 at 0:56
booman

Yes, you can submit a bug here:  POL Bugs

Or you can do a manual installation, but it requires a lot more steps.  Otherwise, just wait and the script will eventually be fixed so Battle.net installs properly since there is a lot of high demand for it.

 

There is also a lot of recent information here on WineHQ's

Edited by booman


† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
booman Monday 1 August 2016 at 1:50
booman

  1. Open PlayOnLinux
  2. Click Configure
  3. Select Battle.net virtual drive (left side)
  4. Click Miscellaneous Tab
  5. Click "Open a Shell"
  6. Copy/paste this command:
    wget https://raw.githubusercontent.com/Winetricks/winetricks/master/src/winetricks
  7. Type this command:
    chmod +x winetricks
  8. Copy/paste this command:
    WINEPREFIX=/home/username/.PlayOnLinux/wineprefix/virtualdrive ./winetricks -q vcrun2015

This totally worked for Battle.net and I can now launch and login.  Make sure your Wine Windows version is set to Windows XP

Edited by booman


† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Diogovmm Monday 1 August 2016 at 2:28
DiogovmmAnonymous

I get this at the end of step 8:

Using winetricks 20160724 - sha1sum: 0b90bc6f5475176b827ae55f646913c3b053ce05 with wine-1.6.2
Executing w_do_call vcrun2015
Executing load_vcrun2015
------------------------------------------------------
Working around wine bug 37781
------------------------------------------------------
------------------------------------------------------
This may fail in non-XP mode, see https://bugs.winehq.org/show_bug.cgi?id=37781
------------------------------------------------------
Using native,builtin override for following DLLs: api-ms-win-crt-conio-l1-1-0 api-ms-win-crt-heap-l1-1-0 api-ms-win-crt-locale-l1-1-0 api-ms-win-crt-math-l1-1-0.dll api-ms-win-crt-runtime-l1-1-0 api-ms-win-crt-stdio-l1-1-0 atl140 msvcp140 msvcr140 ucrtbase vcomp140 vcruntime140
Executing winetricks_early_wine regedit /S C:\windows\Temp\_vcrun2015\override-dll.reg
Executing wine vc_redist.x86.exe /q
fixme:heap:HeapSetInformation (nil) 1 (nil) 0
fixme:heap:HeapSetInformation (nil) 1 (nil) 0
fixme:ntdll:NtQueryInformationToken QueryInformationToken( ..., TokenElevation, ...) semi-stub
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded
fixme:heap:HeapSetInformation (nil) 1 (nil) 0
fixme:heap:HeapSetInformation (nil) 1 (nil) 0
fixme:ntdll:NtQueryInformationToken QueryInformationToken( ..., TokenElevation, ...) semi-stub
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded
fixme:advapi:DecryptFileW (L"C:\\users\\xut\\Temp\\{74d0e5db-b326-4dae-a6b2-445b9de1836e}\\", 00000000): stub

The other steps seemed to be ok.

Maybe I am doing something wrong before this? In this time I started by installing heroes of the storm in POL, after it finished or incomplete I did what you wrote in this post. Should I do something different?

 

 

booman Monday 1 August 2016 at 15:05
booman

I don't see any serious errors... strange.  Battle.net still won't allow you to login?

Maybe the main difference between your install and my install is that I'm doing a "manual installation".  I'm going to try it again this morning.


† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Diogovmm Monday 1 August 2016 at 15:15
DiogovmmAnonymous

Now I was trying to do as https://www.youtube.com/watch?v=-uB6ACRWA1s again.

at the end of the battlenet applications it crashes, as well as the installing component "microsoft core fonts" always crashes and can't install.

then I did your commands and retried, for the first time, it installed the battle net and I could log in. It seems to be insatalling heroes of the storm alright.

I will post what results and workarounds I get, but meanwhile just wanted to ask what the uninstalled microsoft core fonts could cause and why would it not be installed too.

Thank you again.

booman Monday 1 August 2016 at 15:19
booman

Great!  I tried again this morning and Battle.net launched for me.  Not sure why you are getting "core fonts" problems...

I use "manual installation" for every game in PlayOnLinux


† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Diogovmm Monday 1 August 2016 at 17:59
DiogovmmAnonymous

It installed and goes to the loading screen of hots but in crashes there and says unexpected fatal error.

What do you mean manual install? of games or about the windows fonts?

Diogovmm Monday 1 August 2016 at 18:00
DiogovmmAnonymous

This is what happens now:

 

08/01/16 16:46:26] - Running wine-1.9.15 Battle.net Launcher.exe (Working directory : /home/xut/.PlayOnLinux/wineprefix/hots/drive_c/Program Files/Battle.net)
fixme:heap:RtlSetHeapInformation (nil) 1 (nil) 0 stub
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:WinHttpDetectAutoProxyConfigUrl discovery via DHCP not supported
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:ver:GetCurrentPackageId (0x456e9f8 (nil)): stub
fixme:wininet:InternetSetOptionW Option 77 STUB
err:wininet:open_http_connection create_netconn failed: 12029
fixme:wininet:InternetSetOptionW Option 77 STUB
err:wininet:open_http_connection create_netconn failed: 12029
fixme:wininet:InternetSetOptionW Option 77 STUB
err:wininet:open_http_connection create_netconn failed: 12029
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:ver:GetCurrentPackageId (0x49be9f8 (nil)): stub
fixme:wininet:InternetSetOptionW Option 77 STUB
err:wininet:open_http_connection create_netconn failed: 12029
fixme:wininet:InternetSetOptionW Option 77 STUB
err:wininet:open_http_connection create_netconn failed: 12029
fixme:win:EnumDisplayDevicesW ((null),0,0x33f578,0x00000000), stub!
fixme:wbemprox:wbem_locator_ConnectServer unsupported flags
fixme:wbemprox:client_security_SetBlanket 0x7dcffba8, 0x16a6c0, 10, 0, (null), 3, 3, (nil), 0x00000000
fixme:wbemprox:client_security_Release 0x7dcffba8
fixme:wininet:InternetSetOptionW Option 77 STUB
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:WinHttpDetectAutoProxyConfigUrl discovery via DHCP not supported
fixme:wbemprox:enum_class_object_Next timeout not supported
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:ver:GetCurrentPackageId (0x456e9f8 (nil)): stub
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:ntdll:NtQuerySection (0x104,0,0x33f3b4,0x00000010,(nil)) stub!
fixme:ntdll:NtQuerySection (0x104,0,0x33f3b4,0x00000010,(nil)) stub!
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
<html><head><title>Object moved</title></head><body>  
<h2>Object moved to <a href="http://www.blizzard.com/404">here</a>.</h2>  
</body></html>  
<html><head><title>Object moved</title></head><body>  
<h2>Object moved to <a href="http://www.blizzard.com/404">here</a>.</h2>  
</body></html>  
<html><head><title>Object moved</title></head><body>  
<h2>Object moved to <a href="http://www.blizzard.com/404">here</a>.</h2>  
</body></html>  
fixme:font:RemoveFontMemResourceEx (0x8272fa09) stub
fixme:font:RemoveFontMemResourceEx (0x827a2599) stub
fixme:font:RemoveFontMemResourceEx (0x82434341) stub
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:process:SetProcessDEPPolicy (3): stub
fixme:heap:RtlSetHeapInformation (nil) 1 (nil) 0 stub
fixme:imm:ImmDisableTextFrameService Stub
fixme:nls:GetThreadPreferredUILanguages 00000038, 0x33f48c, (nil) 0x33f490
fixme:nls:get_dummy_preferred_ui_language (0x38 0x33f48c (nil) 0x33f490) returning a dummy value (current locale)
fixme:nls:GetThreadPreferredUILanguages 00000038, 0x33f48c, 0x4730a70 0x33f490
fixme:nls:get_dummy_preferred_ui_language (0x38 0x33f48c 0x4730a70 0x33f490) returning a dummy value (current locale)
fixme:winsock:WSALookupServiceBeginW (0x33f360 0x00000ff0 0x33f39c) Stub!
fixme:iphlpapi:NotifyAddrChange (Handle 0x33f4c8, overlapped 0x4741d6c): stub
fixme:win:RegisterDeviceNotificationW (hwnd=0x1009a, filter=0x33f4d4,flags=0x00000000) returns a fake device notification handle!
fixme:win:RegisterDeviceNotificationW (hwnd=0x1009a, filter=0x33f4d4,flags=0x00000000) returns a fake device notification handle!
fixme:ver:GetCurrentPackageId (0x782e9f8 (nil)): stub
fixme:win:EnumDisplayDevicesW ((null),0,0x33edf8,0x00000000), stub!
fixme:toolhelp:CreateToolhelp32Snapshot Unimplemented: heap list snapshot
fixme:toolhelp:Heap32ListFirst : stub
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:shell:SetCurrentProcessExplicitAppUserModelID L"BlizzardEntertainment.Battlenet.beta": stub
err:ole:CoGetClassObject class {77f10cf0-3db5-4966-b520-b7c54fd35ed6} not registered
err:ole:CoGetClassObject no class object {77f10cf0-3db5-4966-b520-b7c54fd35ed6} could be created for context 0x1
fixme:msg:ChangeWindowMessageFilterEx 0x100a8 c05c 1 (nil)
fixme:systray:handle_incoming unhandled tray message: 4
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:WinHttpDetectAutoProxyConfigUrl discovery via DHCP not supported
fixme:heap:RtlSetHeapInformation (nil) 1 (nil) 0 stub
fixme:ole:CoInitializeSecurity ((nil),-1,(nil),(nil),0,3,(nil),0,(nil)) - stub!
fixme:wbemprox:wbem_locator_QueryInterface interface {00000126-0000-0000-c000-000000000046} not implemented
fixme:console:AttachConsole stub ffffffff
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:win:FlashWindowEx 0x33c174 - semi-stub
fixme:win:FlashWindowEx 0x33d610 - semi-stub
fixme:ntdll:EtwRegisterTraceGuidsW (0x1ed7440, 0x3fc0d00, {3dada31d-19ef-4dc1-b345-037927193422}, 1, 0x3f89430, (null), (null), 0x3fc0d18): stub
fixme:ntdll:EtwRegisterTraceGuidsW   register trace class {00000000-0000-0000-0000-000000000000}
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:process:SetProcessDEPPolicy (3): stub
fixme:heap:RtlSetHeapInformation (nil) 1 (nil) 0 stub
fixme:ntdll:EtwRegisterTraceGuidsW (0x10157440, 0x12240d00, {3dada31d-19ef-4dc1-b345-037927193422}, 1, 0x12209430, (null), (null), 0x12240d18): stub
fixme:ntdll:EtwRegisterTraceGuidsW   register trace class {00000000-0000-0000-0000-000000000000}
fixme:gdi:GdiInitializeLanguagePack stub
fixme:ver:GetCurrentPackageId (0x230e9f8 (nil)): stub
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:crypt:CRYPT_CheckUsages unimplemented for RequestedIssuancePolicy
fixme:crypt:CRYPT_CheckUsages unimplemented for RequestedIssuancePolicy
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:mpr:WNetGetUniversalNameW (L"C:\\Program Files\\Heroes of the Storm\\HeroesData\\data", 0x00000001, 0x64dcc7c, 0x64dcc78): stub
fixme:toolhelp:CreateToolhelp32Snapshot Unimplemented: heap list snapshot
fixme:toolhelp:Heap32ListFirst : stub
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
err:ole:CoGetClassObject class {77f10cf0-3db5-4966-b520-b7c54fd35ed6} not registered
err:ole:CoGetClassObject no class object {77f10cf0-3db5-4966-b520-b7c54fd35ed6} could be created for context 0x1
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:win:EnumDisplayDevicesW ((null),0,0x33c438,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x33c4b8,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x33c3b8,0x00000000), stub!
fixme:wtsapi:WTSRegisterSessionNotification Stub 0x500e8 0x00000000
fixme:wgl:X11DRV_wglGetPixelFormatAttribivARB unsupported 2008 WGL Attribute
fixme:advapi:UnregisterTraceGuids deadbeef: stub
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
err:ole:CoGetClassObject class {77f10cf0-3db5-4966-b520-b7c54fd35ed6} not registered
err:ole:CoGetClassObject no class object {77f10cf0-3db5-4966-b520-b7c54fd35ed6} could be created for context 0x1
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:process:SetProcessDEPPolicy (3): stub
fixme:heap:RtlSetHeapInformation (nil) 1 (nil) 0 stub
fixme:ntdll:EtwRegisterTraceGuidsW (0x10157440, 0x12240d00, {3dada31d-19ef-4dc1-b345-037927193422}, 1, 0x12209430, (null), (null), 0x12240d18): stub
fixme:ntdll:EtwRegisterTraceGuidsW   register trace class {00000000-0000-0000-0000-000000000000}
fixme:gdi:GdiInitializeLanguagePack stub
fixme:ver:GetCurrentPackageId (0x240e9f8 (nil)): stub
fixme:system:SystemParametersInfoW Unknown action: 116
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:heap:RtlSetHeapInformation (nil) 1 (nil) 0 stub
fixme:shell:SetCurrentProcessExplicitAppUserModelID L"BlizzardEntertainment.HeroesOfTheStorm.HeroesOfTheStorm": stub
fixme:heap:RtlSetHeapInformation (nil) 1 (nil) 0 stub
fixme:ntdll:server_ioctl_file Unsupported ioctl 900c0 (device=9 access=0 func=30 method=0)
fixme:process:SetProcessDEPPolicy (1): stub
fixme:hnetcfg:fw_profile_get_FirewallEnabled 0x154f78, 0x6e7e9dc
fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION
fixme:mpr:WNetGetUniversalNameW (L"C:\\Program Files\\Heroes of the Storm\\HeroesData\\data", 0x00000001, 0x764d840, 0x764d830): stub
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:WinHttpDetectAutoProxyConfigUrl discovery via DHCP not supported
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:progress:ProgressWindowProc state 0003 not yet handled
fixme:wevtapi:EvtSubscribe ((nil) (nil) L"System" L"*[System[(EventID=4101)]]" (nil) (nil) 0xb8b280 1) stub
fixme:wevtapi:EvtClose ((nil)) stub
fixme:wevtapi:EvtSubscribe ((nil) (nil) L"System" L"*[System[(EventID=4101)]]" (nil) (nil) 0xb8b280 1) stub
fixme:win:EnumDisplayDevicesW ((null),0,0x6e7eef8,0x00000000), stub!
fixme:shell:SHGetPropertyStoreForWindow (0x50102 0x19458bc 0x6e7f098) stub!
fixme:shell:SHGetPropertyStoreForWindow (0x50102 0x19458bc 0x6e7f090) stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x6e7a6b8,0x00000000), stub!
fixme:d3d:debug_d3dformat Unrecognized 0x36314644 (as fourcc: DF16) WINED3DFORMAT!
fixme:d3d:wined3d_get_format Can't find format unrecognized (0x36314644) in the format lookup table
fixme:d3d:debug_d3dformat Unrecognized 0x36314644 (as fourcc: DF16) WINED3DFORMAT!
fixme:d3d:wined3d_get_format Can't find format unrecognized (0x36314644) in the format lookup table
fixme:d3d:debug_d3dformat Unrecognized 0x34324644 (as fourcc: DF24) WINED3DFORMAT!
fixme:d3d:wined3d_get_format Can't find format unrecognized (0x34324644) in the format lookup table
fixme:d3d:debug_d3dformat Unrecognized 0x34324644 (as fourcc: DF24) WINED3DFORMAT!
fixme:d3d:wined3d_get_format Can't find format unrecognized (0x34324644) in the format lookup table
fixme:win:EnumDisplayDevicesW ((null),0,0x6e7a138,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x6e7a668,0x00000000), stub!
fixme:winsock:WSAIoctl WS_SIO_UDP_CONNRESET stub
fixme:msvcrt:type_info_name_internal_method type_info_node parameter ignored
fixme:avrt:AvSetMmThreadCharacteristicsW (L"Audio",0xb84e9dc): stub
fixme:avrt:AvSetMmThreadCharacteristicsW (L"Audio",0xb84e9dc): stub
fixme:avrt:AvSetMmThreadCharacteristicsW (L"Audio",0xb84e9dc): stub
fixme:dbghelp:elf_search_auxv can't find symbol in module
fixme:heap:RtlSetHeapInformation (nil) 1 (nil) 0 stub
fixme:heap:GetPhysicallyInstalledSystemMemory stub: 0x33f1c8
fixme:heap:GetPhysicallyInstalledSystemMemory stub: 0x33f1c8
fixme:ntdll:NtQuerySystemInformationEx Relationship filtering not implemented: 0x3
fixme:ntdll:NtQuerySystemInformationEx Relationship filtering not implemented: 0x3
fixme:win:FlashWindowEx 0x33cb30 - semi-stub
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:process:SetProcessDEPPolicy (3): stub
fixme:heap:RtlSetHeapInformation (nil) 1 (nil) 0 stub
fixme:ntdll:EtwRegisterTraceGuidsW (0x10157440, 0x12240d00, {3dada31d-19ef-4dc1-b345-037927193422}, 1, 0x12209430, (null), (null), 0x12240d18): stub
fixme:ntdll:EtwRegisterTraceGuidsW   register trace class {00000000-0000-0000-0000-000000000000}
fixme:gdi:GdiInitializeLanguagePack stub
fixme:ver:GetCurrentPackageId (0x230e9f8 (nil)): stub
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:WinHttpDetectAutoProxyConfigUrl discovery via DHCP not supported

 

Diogovmm Monday 1 August 2016 at 18:42
DiogovmmAnonymous

I set the me video memory size and changed the library d3dll from "disabled" to native-builtin/builtin-native(trying both and seems builtin-native goes best).

I get past loading having a message from blizzard saying I am entering from a new pc and theysent an email to be able to load here but I dont get any email.

Then I get a crash again, sometimes I cant even get to read the message from blizzard. Here's what I am getting now:

 

[08/01/16 17:30:56] - Running wine-1.9.15 Battle.net Launcher.exe (Working directory : /home/xut/.PlayOnLinux/wineprefix/hots/drive_c/Program Files/Battle.net)
<html><head><title>Object moved</title></head><body>  
<h2>Object moved to <a href="http://www.blizzard.com/404">here</a>.</h2>  
</body></html>  
<html><head><title>Object moved</title></head><body>  
<h2>Object moved to <a href="http://www.blizzard.com/404">here</a>.</h2>  
</body></html>  
<html><head><title>Object moved</title></head><body>  
<h2>Object moved to <a href="http://www.blizzard.com/404">here</a>.</h2>  
</body></html>  
radeon: mmap failed, errno: 12
radeon: mmap failed, errno: 12
radeon: mmap failed, errno: 12
radeon: mmap failed, errno: 12
Diogovmm Tuesday 2 August 2016 at 4:21
DiogovmmAnonymous

Ok so as it was a performance problem I reinstalled xubunto and redid everything, now it works! Thank you for your help!

Now I only have one problem. I want the mouse to lock onto the window, and the only option at configurations is to lock WHEN on fullscreen window. If I use the fullscreen window I can't see the bottom part of the game and can't change it. If I use non fullscreen I can resize the window but can't have the mouse locked. is there a way to fix this?

My last question is if you have any tips to maximize performance. I am on laptop toshiba.

Thank you again for all the help provided.

booman Tuesday 2 August 2016 at 20:01
booman

Try using the Virtual Desktop option in Wine configuration.

That should help with most mouse issues.
No problem, I'm just glad you were able to figure it out.
Don't forget to mark this thread as "solved"


† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Вы находитесь здесь: Index > PlayOnLinux > winiget winhttp MD5 sum mismatch