Вы находитесь здесь

Форум

POL 5 Build Failure

Linux version: Ubuntu 16.04 POL Version: Version 5

Автор Replies
kolaracdn Wednesday 7 September 2016 at 11:26
kolaracdnAnonymous

Hello,

I am trying to build the jar for POL 5 which I need to use for the HighDPI support. When I try to build it as per the instructions, it fails. I don't know if it is because this is 16.04 and not 14.04 or if it is because the most current version of maven is 3.3.9 and one of the dependencies is maven2. Other than that dependency, the rest are installed and when I attempt to build the jar I get the following:

[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 01:28 min
[INFO] Finished at: 2016-09-07T05:02:48-04:00
[INFO] Final Memory: 47M/399M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal on project phoenicis-qt: Could not resolve dependencies for project com.playonlinux:phoenicis-qt:jar:5.0-SNAPSHOT: Could not find artifact com.trolltech:qtjambi:jar:4.8.7 in central (https://repo.maven.apache.org/maven2) -> [Help 1]
[ERROR] 
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] 
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/DependencyResolutionException
[ERROR] 
[ERROR] After correcting the problems, you can resume the build with the command
[ERROR]   mvn <goals> -rf :phoenicis-qt

I was wondering if anyone had any suggestions on what to try next? Thank you in advance for your assistance.

Quentin PÂRIS Thursday 8 September 2016 at 17:35
Quentin PÂRIS
Admin

Run maven clean before trying anything else 

Вы находитесь здесь: Index > PlayOnLinux > POL 5 Build Failure