GTA IV and Mafia II with mouse lag in the menus and when playing too

Автор Replies
phoenix_art Wednesday 29 November 2017 at 15:49

Dear People!

I need some help, I have got these games from Steam and when I run them mouse cursor movement lags, and when I pull the mouse left it goes opposite to right.

So the whole game is unplayable because of this mouse problem.

Computer information - I have this problem on two different computers too with the same operating system - Linux Mint 18.2 Xfce x64 - with GTA IV and Mafia II too:

- Intel(R) Core(TM) i7 CPU 870 @ 2.93GHz + 8 GByte DDR3 RAM + Gigabyte Nvidia GTX 750Ti 2 GByte Black Edition + Wireless Logitech S510 keyboard+mouse,

- AMD Athlon(tm) Dual Core Processor 4450e + 4 GByte DDR2 RAM + 2x Gigabyte Nvidia 8600 GT SLI + Wireless Logitech S510 keyboard+mouse.

Problem information:

After loading game menu the mouse cursor movement is laggy, and when I pull somewhere it will go to the opposite direction with my direction too, so the mouse cursor is jumping a bit on the screen too.

This problem is the same on any other resolution and game quality settings on both the two different computers too - I tried it in windowed and fullscreen modes too but the problem was there too. :(

The Debug output from PlayOnLinux when running GTA IV to the menu:




I've tried with 2.15-staging and newer too, but the problem exist.


What should I do?


Please help me!



Edited by phoenix_art

ImperatorS79 Friday 1 December 2017 at 21:30

Did you install it with the old POL4 script ? If so, try a fesh install with latest wine or wine-staging.

POL5 is here ! -> https://github.com/PhoenicisOrg/phoenicis
phoenix_art Friday 1 December 2017 at 21:37

Thanks for reply. I used a script built in the newest PlayOnLinux for steam install with x86 wine. I tried reinstall and fresh install on the another computer too with that. But the mouse movement problem stay there too. I think this is a problem about dinput, diput8 or xinput.dll dll-files. But I don't know any more information of the correct usages of these files. But I'm not sure about the problem is mainly these dll-s. It was my tip.

Did you install it with the old POL4 script ? If so, try a fesh install with latest wine or wine-staging.


Edited by phoenix_art

This site allows content generated by members, and we promptly remove any content that infringes copyright according to our Terms of Service. To report copyright infringement, please send a notice to dmca-notice@playonlinux.com