Вы находитесь здесь


Civilization 4

Sloooow, can you help speed it up?

Автор Replies
mastablasta Friday 2 October 2020 at 13:14

So i did a manual install (since scripts in POL in ubuntu are usually not working) of Civilization 4 - complete. i chose not to install Colonization.

It installed well and loads with no issues. i went to play Beyond the sword sicne it has a better tech tree. at first it was ok, but the more area i uncovered the slower it all became (scrolling animaitons...). i tried reducing the GPU settings but it has not effect. it defaulted to high. i went with lowest possible but game is still very slow.

i know the PC is old but so is the game and it works well on XP on the same PC. is there something else i could do? tweak? there are no issues in gfame so far, it's just very slow.

i used wine staging 3.2

installed what i could from this list:

d3dx9*, msxml3, msxml4, vcrun2003, quartz, devenum. corefonts, lucida, tahoma.
*d3dx9_26.dll, d3dx9_31.dll, d3dx9_32.dll, d3dx9_33.dll

'msxml3r' is set to native.

System (old but can still run some older games decently):

System:    Host: stari Kernel: 4.15.0-118-generic x86_64 bits: 64 Desktop: KDE Plasma 5.12.9 
          Distro: Ubuntu 18.04.5 LTS 
Machine:   Device: desktop System: Gigabyte product: M56S-S3 serial: N/A 
          Mobo: Gigabyte model: GA-M56S-S3 v: x.x serial: N/A BIOS: Award v: F3 date: 12/04/2007 
CPU:       Single core AMD Athlon 64 3800+ (-UP-) cache: 512 KB speed: 2400 MHz (max) 
Graphics:  Card: NVIDIA GF108 [GeForce GT 730] 
          Display Server: x11 (X.Org 1.19.6 ) drivers: nvidia (unloaded: modesetting,fbdev,vesa,nouveau) 
          Resolution: 1280x1024@60.02hz 
          OpenGL: renderer: GeForce GT 730/PCIe/SSE2 version: 4.6.0 NVIDIA 390.138 
Audio:     Card-1 NVIDIA MCP65 High Definition Audio driver: snd_hda_intel Sound: ALSA v: k4.15.0-118-generic 
          Card-2 NVIDIA GF108 High Definition Audio Controller driver: snd_hda_intel 
          Card-3 Logitech Webcam C270 driver: USB Audio 
Network:   Card: NVIDIA MCP65 Ethernet driver: forcedeth 
          IF: enp0s6 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:    HDD Total Size: 4000.8GB (15.5% used) 
          ID-1: /dev/sdb model: ST2000DM006 size: 2000.4GB 
          ID-2: /dev/sda model: ST1000DM003 size: 1000.2GB 
          ID-3: /dev/sdc model: WDC_WD10EARS size: 1000.2GB 
Partition: ID-1: / size: 1.8T used: 573G (34%) fs: ext4 dev: /dev/sdb1 
          ID-2: swap-1 size: 6.00GB used: 0.44GB (7%) fs: swap dev: /dev/sdb5 
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present 
Sensors:   System Temperatures: cpu: 29.0C mobo: N/A gpu: 33C 
          Fan Speeds (in rpm): cpu: N/A 
Info:      Processes: 161 Uptime: 1 day Memory: 1053.6/3944.1MB Client: Shell (bash) inxi: 2.3.56 


mastablasta Friday 2 October 2020 at 18:29

i did some more tests. and CPU goes to 100%, but ram is hardly utilised. it's starts with 450 MB and increases for 100 or 200 Mb and that's it. is the CPU doing the work of GPU? do i need to use a different setting for rednering and such? should i switch to built in dx libraries?

Dadu042 Saturday 3 October 2020 at 9:29

The latest Wine version = the best performance. I recommend at least v3.0.3 or v3.20 (non staging).


> is the CPU doing the work of GPU?



Often a lot of useful infos : https://appdb.winehq.org/objectManager.php?sClass=application&iId=2514

mastablasta Monday 5 October 2020 at 12:15

i guess i need to try the orignal one instead of staging. i just expected better result with that.

how can you see in wine/Pol if GPU is used or not? i suspect this is the case. Aside from CPU going upo to 100%, the reis not much other ersources being used. animation and all work well if i don't move. i fi move slowly they get slow as well (low fps). i don't see any artefacts or anything strange taht other reported (except font is not as nice as in windows but it's ok). others reported crashes and other problems with mouse. none of which i saw.

i did check wine appdb. in fact i succesfully installed plenty of PoL games using that information. i always read various posts on what went wrong before starting the install. many time info is older but might still work.

i installed d3dx9, should i also install directx9 ?


in the mean time i went to play GalCiv, which should be more GPU/CPU demanding but works flawlessly after some tweaks.

mastablasta Monday 5 October 2020 at 20:34

i installed direcx9 but that didn't help. numerous errors in log.


so i set it to system wine and it worked. loads fatser works normally. i will have to play it for a bit to see how far i can get, but at leats there is no lag.

Вы находитесь здесь: Index > Manual installations > Civilization 4