Вы находитесь здесь

Форум

lancement impossible de pol.

python ?

Автор Replies
ademar Saturday 12 February 2011 at 15:38
ademarAnonymous

Je suis récemment passé d'Ubuntu a Mandriva (free 64bit)

Des infos système:
Votre système : GNU/Linux
Votre noyau : Linux 2.6.33.7-desktop-2mnb
Langue système : fr_FR.utf8
Votre nom d'utilisateur : ademar
Nom de votre ordinateur : localhost
Votre carte graphique : GeForce 8400M G/PCI/SSE2
Votre distribution : MandrivaLinux
Version de votre distribution : 2010.2
Version Wine actuelle : wine-1.2
Version Wine utilisée par PlayOnLinux : wine-1.2
pol a été installé sur Mandriva free 2010.2 64bit via le gestionnaire de paquet, car il n'y était pas de base. La dernière version dans ces dépôts à ce jour est la 3.8.3

Aux début, ça marchait, mais il me mettait sens arrêt qu'une version plus récente, la 3.8.8 existe. mais maintenant quand je lance pol depuis le menu rien ne se passe, dans la console il me renvoi :

[ademar@localhost ~]$ playonlinux
PlayOnLinux v3.8.3

Vérification de l'extension : Advanced Wine Configuration...
Vérification de l'extension : Offline PlayOnLinux...
Vérification de l'extension : Capture...
Vérification de l'extension : Transgaming Cedega...
Vérification de l'extension : Wine Import...
Vérification de l'extension : Wine Look...
Vérification de l'extension : Detour...
Traceback (most recent call last):
File "/usr/share/playonlinux/python/mainwindow.py", line 471, in <module>
app = PlayOnLinuxApp()
File "/usr/lib64/python2.6/site-packages/wx-2.8-gtk2-unicode/wx/_core.py", line 7978, in __init__
self._BootstrapApp()
File "/usr/lib64/python2.6/site-packages/wx-2.8-gtk2-unicode/wx/_core.py", line 7552, in _BootstrapApp
return _core_.PyApp__BootstrapApp(*args, **kwargs)
File "/usr/share/playonlinux/python/mainwindow.py", line 462, in OnInit
self.frame = MainWindow(None, -1, "PlayOnLinux")
File "/usr/share/playonlinux/python/mainwindow.py", line 51, in __init__
self.texte_update = wx.StaticText(self.panel_update, -1, _("An updated version of PlayOnLinux is available.")+" ("+sys.argv[2]+")",pos=(35,0))
IndexError: list index out of range


j'ai essayer de résoudre le problème en réinstallant python 2.6 puis pol, mais sens sucset

enfin "/usr/share/playonlinux/python/mainwindow.py" existe, mais je n'est pas de dossier qui s'appelle "wx-2.8-gtk2-unicode" dans "/usr/lib64/python2.6/site-packages "

c'est pour ça que je pensse que ça vien de python mais que fair ?

Edited by ademar

SuperPlumus Saturday 12 February 2011 at 17:28
SuperPlumusAnonymous
Admin

Bonjour,

Ce bug est connu, et provient de PlayOnLinux et non de python.

Il empêche toute utilisation des versions 3.8.3 et 3.8.4 de PlayOnLinux.

Il te faut obligatoirement mettre à jour vers la version 3.8.8 de POL.

Pour utiliser la dernière version de POL en attendant la mise à jour du paquet, télécharge le paquet Generic sur http://www.playonlinux.com/fr/download.html, puis décompresse le fichier PlayOnLinux_3.8.8.tar.gz quelque part, puis ouvre une console et tape les commandes suivantes :
cd "/chemin/vers/le/dossier/"
./playonlinux


Pour plus d'informations sur ce bug, voir les liens suivants :
http://www.playonlinux.com/fr/commentaires-836.html
http://bugs.playonlinux.com/en/issue-58.html

Edited by SuperPlumus

ademar Sunday 13 February 2011 at 16:55
ademarAnonymous

merci !
Вы находитесь здесь: Index > PlayOnLinux > lancement impossible de pol.