Форум

pol générique 3.8.12 ne ce lance pas[resolu, mais faut le configurer]

ça marche pas

Автор Replies
ademar Wednesday 16 March 2011 at 21:08
ademarAnonymous

- mandriva vertion free 2010.2 64bits
- Version de PlayOnLinux: générique 3.8.12
- j'ai ces 2 erreurs au lancement de pol :
[ademar@localhost playonlinux]$ sh playonlinux
/home/ademar/playonlinux/lib/variables: line 93: .: gettext.sh : fichier introuvable
/home/ademar/playonlinux/lib/main: line 460: « /usr/bin/sudo » : identifiant non valable


- carte graphique radeon HD 5770 (1Gb) pilote, free au début, propriétaire en court d'installation.

contenue de "variables" de la ligne 90 à la ligne 93:
### Language
export TEXTDOMAINDIR="$PLAYONLINUX/lang/locale/"
export TEXTDOMAIN="pol"
. gettext.sh

il n'y a pas de "gettext.sh" dans "playonlinux/lang/locale/" mais j'ai l'impression de chercher dans la mauvaise direction.

contenue de "main" de la ligne 456 à la ligne 465
/usr/bin/sudo ()
{
     echo "$(eval_gettext "This function is disabled in the PlayOnlinux environment.")"
     return 1
}
/usr/bin/gksudo ()
{
     echo "$(eval_gettext "This function is disabled in the PlayOnlinux environment.")"
     return 1
}

comprend rien °_° il est pas sensser utiliser sudo pol ?! si ? parce que mandriva il préfère su et encore il faut le mettre seul.:incertain:


Edited by ademar

Quentin PÂRIS Wednesday 16 March 2011 at 21:32
Quentin PÂRIS
Admin

Essais ./playonlinux

PlayOnLinux ne supporte pas sh, il gère que bash
ademar Sunday 20 March 2011 at 2:10
ademarAnonymous

j'ai mi sh car ./playonlinux ne marchait pas.

[ademar@localhost ~]$ cd /home/ademar/playonlinux/
[ademar@localhost playonlinux]$ ./playonlinux
/home/ademar/playonlinux/lib/variables: line 93: gettext.sh: Aucun fichier ou dossier de ce type
PlayOnLinux v3.8.12

which: no wine in (/usr/local/bin:/usr/bin:/bin:/usr/games:/usr/lib/qt4/bin:/home/ademar/bin)
/home/ademar/playonlinux/lib/check_depend: line 30: eval_gettext : commande introuvable
/home/ademar/playonlinux/lib/check_depend: line 30: eval_gettext : commande introuvable
which: no xterm in (/usr/local/bin:/usr/bin:/bin:/usr/games:/usr/lib/qt4/bin:/home/ademar/bin)
/home/ademar/playonlinux/lib/check_depend: line 30: eval_gettext : commande introuvable
/home/ademar/playonlinux/lib/check_depend: line 30: eval_gettext : commande introuvable
which: no cabextract in (/usr/local/bin:/usr/bin:/bin:/usr/games:/usr/lib/qt4/bin:/home/ademar/bin)
/home/ademar/playonlinux/lib/check_depend: line 30: eval_gettext : commande introuvable
/home/ademar/playonlinux/lib/check_depend: line 30: eval_gettext : commande introuvable
which: no cabextract in (/usr/local/bin:/usr/bin:/bin:/usr/games:/usr/lib/qt4/bin:/home/ademar/bin)
/home/ademar/playonlinux/lib/check_depend: line 30: eval_gettext : commande introuvable
/home/ademar/playonlinux/lib/check_depend: line 30: eval_gettext : commande introuvable
/home/ademar/playonlinux/lib/check_depend: line 38: eval_gettext : commande introuvable
/home/ademar/playonlinux/lib/interface: line 137: eval_gettext : commande introuvable
Traceback (most recent call last):
File "/home/ademar/playonlinux/python/message.py", line 21, in <module>
import wxversion, os, getopt, sys, urllib, signal
ImportError: No module named wxversion
[ademar@localhost playonlinux]$

edit: faut il que j'installe qt4 ? si oui le paquet ruby-qt4 conviens t'il?

Edited by ademar

Quentin PÂRIS Sunday 20 March 2011 at 10:43
Quentin PÂRIS
Admin

Euh non on utilise pas qt4, ni ruby en fait ...

Il faut que tu installe getetxt, wxpython déjà
ademar Sunday 20 March 2011 at 13:20
ademarAnonymous


bon bien merci! je n'arrivait a comprendre les première dépendance !

ps:
c'est bizarre certain paquet n'apparaissent pas dans le gestionnaire de paquet graphique mais s'installe directe via console.

ci quelqu'un a le même problème sous mandriva:

[user@localhost ~]$ su
Mot de passe :
urpmi gettext

pour gettext par exemple

ademar Sunday 20 March 2011 at 14:47
ademarAnonymous

j'ai parler trops vite.

Could not load wine-gecko. HTML rendering will be disabled.
j'ai l'impression qu'il faut configuré un truck.

impossible d'installer guecko ou dx9...
donc pol marche mais ne peux lancé aucun jeux.
Quentin PÂRIS Sunday 20 March 2011 at 16:01
Quentin PÂRIS
Admin

Euh non le problème ne vient pas de gecko, essais avec un programme tout simple pour commencer, comme IZarc
ademar Monday 21 March 2011 at 20:43
ademarAnonymous

l'installation semble bien se passer mais il ne réussi pas a installer le gecko autant réclamé:
wine: created the configuration directory '/home/ademar/.PlayOnLinux/wineprefix/IZArc'
fixme:wininet:InternetLockRequestFile STUB
err:cabinet:FDICopy FDIIsCabinet failed.
err:mshtml:check_version Could not open VERSION file
Could not load wine-gecko. HTML rendering will be disabled.
wine: configuration in '/home/ademar/.PlayOnLinux/wineprefix/IZArc' has been updated.
fixme:win:DisableProcessWindowsGhosting : stub
err:richedit:ReadStyleSheet skipping optional destination
err:richedit:ReadStyleSheet skipping optional destination
fixme:sfc:SfcIsFileProtected ((nil), L"C:\\\\Program Files\\\\IZArc\\\\unins000.exe") stub
No iternet icon...
/home/ademar/playonlinux/lib/applications: line 130: wrestool : commande introuvable
ls: impossible d'accéder à *.ico: Aucun fichier ou dossier de ce type

il ne semble cependant pas en avoir besoins. puisque après test il semble très bien marcher.

ps: je ne penses pas que le problème vienne de guecko, mais d'une option (a cause du "HTML rendering will be disabled." mais se n'est qu'une théorie... :incertain: