Вы находитесь здесь

Форум

Lancement de POL, root or not root ?

Автор Replies
Ulrar Saturday 13 October 2007 at 21:22
UlrarAnonymous

Bonjour,
j'ai installer pour la premiere fois POL sur SuSe 10.3 (elle aussi fraichement installer de ce matin), j'ai l'acceleration 3D qui fonctionne puisque compiz fonctionne, mais deja, POL dis que non. Et ensuite quand je le lance a partir de menu, en utilisateur donc, je peux installer mais des que je lance un jeu, il ne peu pas ecrire sur ses fichiers ><. En root par contre ça marche, a par que steam plante a l'installation d'un jeu mais c'est un autre probleme ^^. Deja que Guild Wars marche ça serai bien xD.
Aymeric P. Saturday 13 October 2007 at 21:41
Aymeric P.
Admin

Salut,
Bon j'ai du mal a te lire (tu sais qu'il y a une touche 'entrée' sur un clavier ), mais je vais essayer de repondre au question :
Tu as une (Open?) Suse 10.3
=> OK donc tu passe par des paquets rpm/ par l'archive tar.gz

POL dit que l'accélération 3d n'est pas activer, d'après toi tu l'as ?
=>Que donne les résultats des tests de POL ? (il faudrait que l'on connaisse aussi ta carte graphique)

Tu peux installer un jeu, mais une fois le jeu installer impossible de le lancer sauf en root
=>La je ne vois pas vraiment ce que POL vient faire dedans
==>Peut être que la partition a été remonté en ro (ReadOnly) car le système a détecter des erreurs dessus (ça peut arriver)
==>Peut être que tu as un problème de droit

Steam plante quand tu install un jeu
=>A voir plus tard

GuildWars ne fonctionne pas
=>A voir avec l'accélération 3d (et puis "ça marche pas" c'est pas d'une précision remarquable ...)

Former member.
Ulrar Saturday 13 October 2007 at 22:14
UlrarAnonymous

Arg, j'avais fait une belle reponse et j'l'ai perdu :'(.

Enfin, desolé pour tout a l'heure, quelque petits probleme j'avais pas la tete a ce que j'ecrivais ^^.

J'ai une openSuSe 10.3, une CG : Nvidia 7600 GT. Je suis passer par les rpms.

Je pense que j'ai l'acceleration oui, puique Compiz marche niquel. Eau, feu, le cube qui tourne, tout ça en meme temps sans aucun ralentissement. donc il me semble que je l'ai oui ^^. Mais mon systeme est pas au courant, puisque glxinfo | grep rendering me repond no ...

---> Tests de POL : (jolis engrenage xD)
Resultat des tests

Test gears : 9425 FPS
Test glxmulx : FPS
Test glxmulx1.2 : FPS
Vitesse de 0% avec une résolution de 640x480 avec le test glxtinou : FPS
Vitesse de 20% avec une résolution de 640x480 avec le test glxtinou : FPS
Vitesse de 40% avec une résolution de 640x480 avec le test glxtinou : FPS
Vitesse de 60% avec une résolution de 640x480 avec le test glxtinou : FPS
Vitesse de 80% avec une résolution de 640x480 avec le test glxtinou : FPS
Vitesse de 100% avec une résolution de 640x480 avec le test glxtinou : FPS
Vitesse de 0% avec une résolution de 800x600 avec le test glxtinou : FPS
Vitesse de 20% avec une résolution de 800x600 avec le test glxtinou : FPS
Vitesse de 40% avec une résolution de 800x600 avec le test glxtinou : FPS
Vitesse de 60% avec une résolution de 800x600 avec le test glxtinou : FPS
Vitesse de 80% avec une résolution de 800x600 avec le test glxtinou : FPS
Vitesse de 100% avec une résolution de 800x600 avec le test glxtinou : FPS
Vitesse de 0% avec une résolution de 1024x768 avec le test glxtinou : FPS
Vitesse de 20% avec une résolution de 1024x768 avec le test glxtinou : FPS
Vitesse de 40% avec une résolution de 1024x768 avec le test glxtinou : FPS
Vitesse de 60% avec une résolution de 1024x768 avec le test glxtinou : FPS
Vitesse de 80% avec une résolution de 1024x768 avec le test glxtinou : FPS
Vitesse de 100% avec une résolution de 1024x768 avec le test glxtinou : FPS


---> Ma partition n'est pas en ro, j'ecrit dessus sans probleme. Mais le jeu une fois lancer n'a pas les droits pour ecrire. Pourtant j'ai mis tout les repertoires en 777. Et en root ça marche, enfin Guild Wars ne se lance pas mais ne me donne pas de message d'erreur non plus. Et steam fait sa mise a jour sans probleme, alors qu'en user il peu pas ecrire.


---> Guild Wars ne marche pas, j'voulais dire par la qu'il me donnait un message d'erreur ou il me dis qu'il ne peu pas ecrire dans C:\GW\GW.dat , qui est pourtant en 777 lui aussi. Il me demande de verifié si il n'est pas proteger en ecriture ou utiliser par un autre programme.

Voila, je crois que j'ai repondu a tout ^^. Merci !
Aymeric P. Saturday 13 October 2007 at 22:44
Aymeric P.
Admin

Bon alors on va commencer par la 3d

Pourrais tu nous donner les informations système & glxinfo (Option => Informations) que donne POL
Il est probable que ça soit le processeur qui fasse tout les calculs pour la carte graphique (ce qui est probablement le cas)
Bizarre les tests il manque la valeur pour tout les test sauf le premier :/



Guild Wars ne se lance pas mais ne me donne pas de message d'erreur non plus.

Quote

Guild Wars ne marche pas, j'voulais dire par la qu'il me donnait un message d'erreur

Quote

Faudrais savoir là !


Concernant les problèmes d'écritures là j'ai pas trop d'idée :/

PS : Guild Wars n'affiche plus la moindre fenêtre pendant l'installation, elles viennent après

Former member.
Ulrar Saturday 13 October 2007 at 23:48
UlrarAnonymous

Pour Guild Wars, il n'affiche aucune fenetre en root, et en user il peut pas ecrire ^^.

POL a pas l'air tres au courant, il manque plein de truc ... et ma CG est une PCI-E :

Informations systèmes

Votre système : GNU/Linux
Votre noyau : Linux 2.6.22.9-0.4-default
Langue de votre système : fr_FR.UTF-8
Votre nom d'utilisateur : ulrar
Nom de votre ordinateur : brave-bete
Votre carte vidéo : GeForce 7600 GT/PCI/SSE2
Votre distribution :
Version de votre distribution :
Version de wine installée : wine-0.9.44
Version de wine utilisée par PlayOnLinux : wine-0.9.44
Place restante sur vos disques :
Sys. de fich. Tail. Occ. Disp. %Occ. Monté sur


Et glxinfo :

name of display: :0.0
display: :0 screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_OML_swap_method,
GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_hyperpipe,
GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig
client glx vendor string: NVIDIA Corporation
client glx version string: 1.4
client glx extensions:
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_visual_info,
GLX_EXT_visual_rating, GLX_EXT_import_context, GLX_SGI_video_sync,
GLX_NV_swap_group, GLX_NV_video_out, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
GLX_SGI_swap_control, GLX_NV_float_buffer, GLX_ARB_fbconfig_float,
GLX_EXT_fbconfig_packed_float, GLX_EXT_texture_from_pixmap,
GLX_EXT_framebuffer_sRGB
GLX extensions:
GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_SGIX_fbconfig,
GLX_ARB_get_proc_address
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce 7600 GT/PCI/SSE2
OpenGL version string: 1.2 (2.1.1 NVIDIA 100.14.19)
OpenGL extensions:
GL_ARB_depth_texture, GL_ARB_imaging, GL_ARB_multitexture,
GL_ARB_point_parameters, GL_ARB_point_sprite, GL_ARB_shadow,
GL_ARB_texture_border_clamp, GL_ARB_texture_cube_map,
GL_ARB_texture_env_add, GL_ARB_texture_env_combine,
GL_ARB_texture_env_dot3, GL_ARB_texture_mirrored_repeat,
GL_ARB_window_pos, GL_ARB_texture_non_power_of_two, GL_ARB_vertex_program,
GL_ARB_fragment_program, GL_EXT_abgr, GL_EXT_bgra, GL_EXT_blend_color,
GL_EXT_blend_func_separate, GL_EXT_blend_minmax, GL_EXT_blend_subtract,
GL_EXT_draw_range_elements, GL_EXT_fog_coord, GL_EXT_multi_draw_arrays,
GL_EXT_packed_pixels, GL_EXT_rescale_normal, GL_EXT_secondary_color,
GL_EXT_separate_specular_color, GL_EXT_shadow_funcs, GL_EXT_stencil_wrap,
GL_EXT_texture3D, GL_EXT_texture_edge_clamp, GL_EXT_texture_env_add,
GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3, GL_EXT_texture_lod,
GL_EXT_texture_lod_bias, GL_EXT_texture_object, GL_EXT_vertex_array,
GL_ATI_texture_mirror_once, GL_IBM_texture_mirrored_repeat,
GL_NV_blend_square, GL_NV_texgen_reflection, GL_NV_texture_rectangle,
GL_NV_texture_env_combine4, GL_SGIS_generate_mipmap, GL_SGIS_texture_lod,
GL_SGIX_depth_texture, GL_SGIX_shadow
glu version: 1.3
glu extensions:
GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
0x2c 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 1868967532 1700946252 None
0x2d 24 tc 0 32 0 r . . 8 8 8 8 0 0 0 0 0 0 0 1919903278 1953720652 None
0x2e 32 tc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 1936280618 174483046 Ncon
0x2f 32 tc 0 32 0 r . . 8 8 8 8 0 0 0 0 0 0 0 1853190002 1735091041 Ncon

Merci de m'aider ^^.
Pauldb Sunday 14 October 2007 at 16:31
Pauldb

C'est où que tu l'as installer Steam ??
Normalment tu dois l'avoir là :
/home/ulrar/.PlayOnLinux/wineprefix/Steam/drive_c/Program Files/Steam
si c'est pas le cas, réinstalle-le là.
Et normalement tu n'auras plus de problème de droit vu que t'es chez toi !
Pour l'accélération graphique ==> http://doc.ubuntu-fr.org/acceleration_graphique
En ce qui concerne l'autre jeu je sais pas, essaye de le réinstaller...

Linux, for Belgian Being...
Aymeric P. Sunday 14 October 2007 at 21:13
Aymeric P.
Admin

Bon pour la 3d effectivement tu utilise les bon pilotes (enfin il me semble, je n'ai pas de nvidia), par contre tu n'as le "direct rendering".
Regarde là : http://www.playonlinux.com/forums/see_topic.php?topic=167 il y a peut être quelque chose a faire

Pour les droits, je n'ai aucune idée

Former member.
Quentin PÂRIS Sunday 14 October 2007 at 21:14
Quentin PÂRIS
Admin

Tu utiliserais pas Xgl par hazard ?
Ulrar Sunday 14 October 2007 at 22:54
UlrarAnonymous

Si, j'utilise Xgl. J'ai pas encore trouver le truc pour faire marcher compiz-fusion sans malheureusement.


@Pauldb : steam est deja installer la, j'ai laisser par defaut ^^. Et j'ai mis chmod -R 777 pour etre sur, mais ça change rien.

---> Pour l'acceleration 3D, je reboot sous openSuSe et je vois ça tout de suite . Merci !
Ulrar Sunday 14 October 2007 at 23:47
UlrarAnonymous

ça y est, j'ai compris pourquoi tu me demandais pour Xgl. ça renvoie toujours no a glxinfo | grep rendering quand on l'utilise ... je savais pas. Bah, j'aurai apris quelque chose au moin ^^. Bon, par contre, quand je lance le paneau de config nvidia, il me dis que X n'utilise pas le driver nvidia ... pourtant si. Et quand je lance la commande qu'il me donne, il genere un nouveau xorg.conf, identique au premier, donc ça change rien, toujours le meme message. (et oui j'ai penser a relancer X).

Maintenant, faudrai resoudre ce probleme de droit pour voir si ça marche.
Ulrar Monday 15 October 2007 at 3:29
UlrarAnonymous

Pour continuer dans la serie, je sais pas c'que j'ai fait encore mais les jeux veulent meme plus se lancer ><.

La console me dit :

wineserver: /tmp/.wine-1000 must not be accessible by other users
FIXME::POL::lib/wine:wait_wine_exit:fonction is in versus 0.2~alpha4
FIXME::POL::lib/wine:wait_wine_exit:Text not yet translated
Waiting for wine finish

Et ensuite le menu de POL revien. J'ai essayé de le reinstaller mais ça change rien. J'suis fort pour trouver des problemes moi xD.



EDIT : Probleme regler, j'aurai juste du me mettre en su avant de chmoder pour interdire l'acces aux autres qu'aux proprietaire ^^. Desolé

Edited by Ulrar

Ulrar Monday 15 October 2007 at 4:02
UlrarAnonymous

Bon voila, alors j'ai essayé de lancer steam. Comme il plante quand j'installe un jeu, j'ai copier les gcfs de ma partition windows. Et quand j'essaye de lancer le jeu ... meme erreur que quand je veux l'installer :



Bon, asser fait de conneries pour ce soir moi, j'vais m'coucher. Je revien la semaine prochaine, merci tout l'monde .


EDIT: j'ai oublier de preciser que mon probleme de droit est resolu. Comment, je sais pas, mais il l'est. Maintenant Guild Wars se lance pas plus pour autant ... seulement aucune fenetre n'aparait. Mais il bouffe bien toute ma ram. Quand je lance POL en console il ne me dis rien pourtant .... mais au moin j'peux le couper facilement. Quand je le lance a partir du menu il bouffe tout et je peux rien faire. Vive killall =). Bonne semaine les gens !

Edited by Ulrar

Вы находитесь здесь: Index > PlayOnLinux > Lancement de POL, root or not root ?