Вы находитесь здесь

Форум

Probleme Steam et playonlinux

Автор Replies
loiscooper91 Friday 1 June 2007 at 8:21
loiscooper91Anonymous

Bonjour a tous

Je vais essayé d'exposer mon probleme...le plus simplement possible. (cela ne va pas etre chose aisé )
tout d'abord les informations.

Nom de la distribution ebian etch 4.0rc0
- Nom et version du programme : wine-0.9.25 (wine des paquets stable)
- Gnome 2.14.3 (gnome etch stable)
en gros du etch 100% etch stable

j'ai installé playonlinux.(POL)..le .deb, nickel .!
ensuite, je lance POL , je choisi d'installer Steam.
ca lance...ca installe....et tout et tout ...jusque la. zero default.
je telecharge avec Steam, counter strike source...ca download.

apres, c'est la ou le bas blesse.

je clic sur lancer le jeu .....un popup s'ouvre...CS en cours de lancement....et.....le vent .. -_-' rin de rin.

je ferme Steam. je relance Playonlinux, je clic jouer a....rien...rien n'est installé o_O ....(bon...je verifie tout les droits sont ok, les acces aussi....)

je reinstall, la pas besoin il le vois, me propose de reparer et hop, Steam come back, mais toujours dans l'impossibilité de le lancer.

Bon bref.....j'ai bien export WINEPREFIX etc...mais voila, j'ai reussi a lancer CS source grace au script suivant:

#!/bin/bash
WINEDEBUG=fixme-all wine C:/Program\ Files/Steam/Steam.exe -fullscreen \
-width 1280 -height 1024 -refresh 75 -dxlevel 81 -applaunch 240 -console \
-heapsize 512000 +map_background none "$@"



le hic, c'est que j'ai du faire un lien symbolique de: .wine/drive_c/Programme files/
Steam -> /home/tof/.PlayOnLinux//wineprefix/Steam/drive_c/Program Files/Steam

sinon ca marche pas...

j'ai l'impression que wine et Playonlinux se melange les piceaux concernant leur respectifs....

Ma question est: Auriez vous un wiki pour installer steam (je n'ai rein trouvé dans le forum)

de plus maintenant POL vois Steam installé, je clic "Lancé" pouf la fenetre se ferme et reviens a POL .....(

Message de log : wine: could not load L"c:\\windows\\system32\\steam.exe": Module not found

bref....suis un peu pommé

voila...donc comment puis je lancé Steam et CS a partir de POL sans passé par des liens symbolique etc....et des scripts


Merci d'avance.

PS: en tous cas....c'est une riche idée POL,.....merci a vous.




GarulfoUnix Friday 1 June 2007 at 12:27
GarulfoUnix

Hum ton histoire de lien symbolique c'est assez bizarre. Tu n'as nul besoin de créer quoique ce soit pour installer Steam. De plus, ce message est trés bizarre :
Message de log : wine: could not load L"c:\\windows\\system32\\steam.exe": Module not found
Pourquoi chercher steam.exe dans le répertoire system32..

Je te conseil de refaire une installation propre. Supprime le répertoire de wine, ainsi que celui de POL. Puis éxécute le script comme d'habitude et reviens aux nouvelles .

Edited by GarulfoUnix


PenBook
Pour info: GuideCoder.org va être remplacé par PenBook.
loiscooper91 Friday 1 June 2007 at 13:33
loiscooper91Anonymous

Oki...

je fais ca des que je suis rentré...
Question , je dois tout effacer ? meme CS telecharger ?

ou je suis la FAQ et je resinatll par dessus le dossier .Playonlinux ?

dans le pire des cas, j'essaierais les deux...ca iras vite

en fait le plus etrange, c'est pas le system32.....c'est que une fois CS installé avec steam, playonlinux ne le vois pas....car il chercher par defaut dans .wine et non .Playonlinux

Pourtant je set bien WINEPREFIX, et la conf aussi.....

completement strange cette histoire

Je te tiens au courant des le milieu d'apres midi (vers 17h)
merci encore


GarulfoUnix Friday 1 June 2007 at 15:03
GarulfoUnix

Oui même CS téléchargé .

PenBook
Pour info: GuideCoder.org va être remplacé par PenBook.
Quentin PÂRIS Friday 1 June 2007 at 16:03
Quentin PÂRIS
Admin

Il n'est nullement nécessaire de supprimer .wine. PlayOnLinux ne s'en sert pas. Mets à jour wine vers la 0.9.37 déja
loiscooper91 Friday 1 June 2007 at 17:35
loiscooper91Anonymous

Bon c'est en cours....

alors...comme la 1ere fois
lancement de steam ,install steam OK

au moment de l'installation wineGecko...bah je clic installation...ca ferme directe la fenetre d'install, et steam s'ouvre....

donc pas de publicité en web, que du blanc ..mais steam tourne.

je ferme steam je relance playonlinux, je clic jouer, pas de jeu d'installé ....ca recommence...

obliger de reinstraller..., la une fenetre s'ouvre qui se nomme : "

"simulation du redemarrage de windows" fenetre Playonlinx.

la l'install gecko reviens je clic ionstall...ca marche.....
steam a donc la page web

je telecharge actuellement CS.

la petite fenetre "simulation du redemarrage...." tourne toujours ..je sais pas pourquoi .

je vous tiens au courant des que CS a fini de telechargher. (ca va assez vite)

PS: j'ai mis a jour wine...juste au cas ou, ca na rien changé

le truc en fait...c'est que, jai l'impression qui lis pas dans .Playonlinux, mais dans .wine ......

comme si la variable d'environement WINEPREFIX n'ete pas lu.....pourtant, steam s'install....

a tout de suite

et merci encore



Quentin PÂRIS Friday 1 June 2007 at 17:39
Quentin PÂRIS
Admin

Oh la ! J'ai du mal à comprendre.

Tape

playonlinux --run Steam et renvoi moi les erreurs
loiscooper91 Friday 1 June 2007 at 17:59
loiscooper91Anonymous

hop...

comme jai mis la derniere version de Wine...j'ai preferer tout refaire a propre

donc purge complete
puyrge des repertoires
install wine : wine-0.9.37

la....playonlinux, install steam install wine-gecko ==> OK

quitter steam....

relance playonlinux, jouer et la, steam directement. dans la liste ==> C MIEUX

donc la telechargement de CS source en cours....

ya deja du beaucoup mieux

bon , page blanche dans les news de steam pourtant gecko est la, peut etre leur site a un souci...

donc CS en cours de telechargement...

petit bug, que javais pas...je peux pas bouger ma fenetre STeam

elle reste bloqué en bas, alors qu'avec wine 0.9.25, je pouvais la deplacer...mais bon, rien de bloquant .!

je te tiens au courant des que CS est fini de download.

je crois, je suis pas sur, mais que c'ete wine 0.9-25 qui causer des problemes

...la suite ds quelques minutes

merci pour tout, tinou

PS: jai cliquer bouton droit sur l'icone en bas de steam, deplacer...a force de la bouger partout, elle c'est debloqué....du mieux tj du mieux)
reste a esperer que CS se lance bien ...et c'est tout bon

Edited by loiscooper91

loiscooper91 Friday 1 June 2007 at 21:08
loiscooper91Anonymous

MESSAGE FINAL

tout est OKKKKK

merci a tinou et tout le monde

en effet le probleme venais de WINE

il fallais la der des der

maintenant tou fonctionne a merveille

CS source a 90 fps..en 1280x1024....la perfection

bref un grand GG a vous et un grand merci pour votre aide....

bonne soirée
Вы находитесь здесь: Index > PlayOnLinux > Probleme Steam et playonlinux