Вы находитесь здесь

Форум

Space Pirates and Zombies

Автор Replies
Deleted account Saturday 27 August 2011 at 17:24
Deleted accountAnonymous

Hi,
I'm searching to make Space Pirates and Zombies works on Linux but it's not so easy.
First, there is a known gamma bug (the screen goes completly black when the game is launched), which can be fixed by a script like this one :

sleep 3 && xgamma -gamma 1.0 &
wine SpazGame.exe
sleep 1
xgamma -gamma 1.0


But on Steam, launching it with a gamma-correction script doesn't always seem to work either. I think steam adds a few seconds to its launch time or something.

However, I just use a secondary script that does the gamma correction only without launching spaz, and I can see fine if I call it after starting spaz up.
But it's really boring to do that always when I want to play, can you help me with this one pls?

(Another bug is the framerate going down to nothing once the main menu hits. But it seems that doesn't affect everybody).
Quentin PÂRIS Saturday 27 August 2011 at 18:56
Quentin PÂRIS
Admin

Is it a bash script ?
Deleted account Saturday 27 August 2011 at 19:25
Deleted accountAnonymous

Yes it is

There is a demo to try it with steam right there : http://store.steampowered.com/app/107200/

Edited by Deleted account

Quentin PÂRIS Saturday 27 August 2011 at 19:41
Quentin PÂRIS
Admin

- Add sleep 10 at the begining of the script
- Place it in .PlayOnLinux/configurations folder
- chmod +x
- Type in PlayOnLinux console : POL_Config_Write PRE_RUNNING '$POL_USER_ROOT/configurations/script name'

Edited by Tinou

Deleted account Saturday 27 August 2011 at 19:46
Deleted accountAnonymous

Okidoki, i'll try that :D
I'll keep you posted!
Deleted account Saturday 27 August 2011 at 20:21
Deleted accountAnonymous

That doesn't worked for me =s

Maybe I missed something.
Quentin PÂRIS Saturday 27 August 2011 at 20:28
Quentin PÂRIS
Admin

Start playonlinux from a terminal, and run your program. Tell me if there are some errors
Deleted account Sunday 28 August 2011 at 4:24
Deleted accountAnonymous

It's just that, I had this gamma bug again. ^^'
Deleted account Sunday 28 August 2011 at 19:53
Deleted accountAnonymous

But anyway, the bug has been fixed in wine 1.3.27, do you know how i can add it to PoL?
Quentin PÂRIS Sunday 28 August 2011 at 20:36
Quentin PÂRIS
Admin

Tools -> Manage wine versions

Edited by Tinou

Deleted account Sunday 28 August 2011 at 21:05
Deleted accountAnonymous

But it says that PoL can't access to internet =s

EDIT: Nvm, it was a wifi mistake!

And many thanks!

Edited by Deleted account

Вы находитесь здесь: Index > PlayOnLinux > Space Pirates and Zombies