Вы находитесь здесь

Форум

Linux Linpus lite

Автор Replies
jl123 Monday 12 September 2011 at 18:40
jl123Anonymous

HI I'm new to Linux so forgive me. I've installed Playonlinux onto my new notebook Acer Aspire One. It uses Linux Linpus Lite OS. I'm not even sure I did it right so have patience with me but I am willing to learn. If I go to Games I can see the Playonlinux icon but when I go to open it, nothing happens. If I put Playonlinux into the Terminal I get a whole list of text see below. I installed form the Fedora section and it is in my package manager. I've googled but cannot find an answer.Can someone please help me? I'm at a loss. Thanks.


[user@localhost ~]$ playonlinux
which: no xdg-user-dir in (/usr/local/bin:/bin:/usr/bin:/usr/acer/bin:/sbin/:/usr/sbin/:/home/user/bin:/usr/acer/bin)
which: no shasum in (/usr/local/bin:/bin:/usr/bin:/usr/acer/bin:/sbin/:/usr/sbin/:/home/user/bin:/usr/acer/bin)
which: no xdg-user-dir in (/usr/local/bin:/bin:/usr/bin:/usr/acer/bin:/sbin/:/usr/sbin/:/home/user/bin:/usr/acer/bin)
which: no shasum in (/usr/local/bin:/bin:/usr/bin:/usr/acer/bin:/sbin/:/usr/sbin/:/home/user/bin:/usr/acer/bin)
[install_plugins] Message: Checking plugin: Offline PlayOnLinux...
[install_plugins] Message: Checking plugin: Capture...
[install_plugins] Message: Checking plugin: Transgaming Cedega...
[install_plugins] Message: Checking plugin: Wine Import...
[install_plugins] Message: Checking plugin: Wine Look...
/usr/share/playonlinux/lib/plugins.lib: line 86: [: too many arguments
which: no xdg-user-dir in (/usr/local/bin:/bin:/usr/bin:/usr/acer/bin:/sbin/:/usr/sbin/:/home/user/bin:/usr/acer/bin)
which: no shasum in (/usr/local/bin:/bin:/usr/bin:/usr/acer/bin:/sbin/:/usr/sbin/:/home/user/bin:/usr/acer/bin)
Traceback (most recent call last):
File "mainwindow.py", line 657, in <module>
app = PlayOnLinuxApp(redirect=False)
File "/usr/lib/python2.5/site-packages/wx-2.8-gtk2-unicode/wx/_core.py", line 7757, in __init__
self._BootstrapApp()
File "/usr/lib/python2.5/site-packages/wx-2.8-gtk2-unicode/wx/_core.py", line 7354, in _BootstrapApp
return _core_.PyApp__BootstrapApp(*args, **kwargs)
File "mainwindow.py", line 601, in OnInit
self.frame = MainWindow(None, -1, os.environ["APPLICATION_TITLE"])
File "mainwindow.py", line 134, in __init__
self.wineserv_item = wx.MenuItem(self.expertmenu, 115, _('Close all {0} software').format(os.environ["APPLICATION_TITLE"]))
AttributeError: 'str' object has no attribute 'format'
Exception exceptions.TypeError: 'join() takes exactly 2 arguments (1 given)' in <module 'threading' from '/usr/lib/python2.5/threading.pyc'> ignored
/usr/share/playonlinux/playonlinux: line 60: python2.6: command not found
which: no xdg-user-dir in (/usr/local/bin:/bin:/usr/bin:/usr/acer/bin:/sbin/:/usr/sbin/:/home/user/bin:/usr/acer/bin)
which: no shasum in (/usr/local/bin:/bin:/usr/bin:/usr/acer/bin:/sbin/:/usr/sbin/:/home/user/bin:/usr/acer/bin)
which: no xdg-user-dir in (/usr/local/bin:/bin:/usr/bin:/usr/acer/bin:/sbin/:/usr/sbin/:/home/user/bin:/usr/acer/bin)
which: no shasum in (/usr/local/bin:/bin:/usr/bin:/usr/acer/bin:/sbin/:/usr/sbin/:/home/user/bin:/usr/acer/bin)
[install_plugins] Message: Checking plugin: Offline PlayOnLinux...
[install_plugins] Message: Checking plugin: Capture...
[install_plugins] Message: Checking plugin: Transgaming Cedega...
[install_plugins] Message: Checking plugin: Wine Import...
[install_plugins] Message: Checking plugin: Wine Look...
/usr/share/playonlinux/lib/plugins.lib: line 86: [: too many arguments
which: no xdg-user-dir in (/usr/local/bin:/bin:/usr/bin:/usr/acer/bin:/sbin/:/usr/sbin/:/home/user/bin:/usr/acer/bin)
which: no shasum in (/usr/local/bin:/bin:/usr/bin:/usr/acer/bin:/sbin/:/usr/sbin/:/home/user/bin:/usr/acer/bin)
Traceback (most recent call last):
File "mainwindow.py", line 657, in <module>
app = PlayOnLinuxApp(redirect=False)
File "/usr/lib/python2.5/site-packages/wx-2.8-gtk2-unicode/wx/_core.py", line 7757, in __init__
self._BootstrapApp()
File "/usr/lib/python2.5/site-packages/wx-2.8-gtk2-unicode/wx/_core.py", line 7354, in _BootstrapApp
return _core_.PyApp__BootstrapApp(*args, **kwargs)
File "mainwindow.py", line 601, in OnInit
self.frame = MainWindow(None, -1, os.environ["APPLICATION_TITLE"])
File "mainwindow.py", line 134, in __init__
self.wineserv_item = wx.MenuItem(self.expertmenu, 115, _('Close all {0} software').format(os.environ["APPLICATION_TITLE"]))
AttributeError: 'str' object has no attribute 'format'
Exception exceptions.TypeError: 'join() takes exactly 2 arguments (1 given)' in <module 'threading' from '/usr/lib/python2.5/threading.pyc'> ignored
Quentin PÂRIS Monday 12 September 2011 at 18:48
Quentin PÂRIS
Admin

Your python version is too old. You need to have at least python2.7
jl123 Monday 12 September 2011 at 19:47
jl123Anonymous

Your python version is too old. You need to have at least python2.7

Quote from Tinou


Ok I tried yo update python and got the following

[user@localhost ~]$ sudo yum update python
Setting up Update Process
Could not find update match for python
No Packages marked for Update
jl123 Monday 12 September 2011 at 19:52
jl123Anonymous

Your python version is too old. You need to have at least python2.7

Quote from Tinou


Ok I tried yo update python and got the following

[user@localhost ~]$ sudo yum update python
Setting up Update Process
Could not find update match for python
No Packages marked for Update
Quentin PÂRIS Monday 12 September 2011 at 20:18
Quentin PÂRIS
Admin

Update your distro :-°

Or try to install python2.7
jl123 Tuesday 13 September 2011 at 15:51
jl123Anonymous

Hi I use system live updates. is this what you mean? and when i go to install python2.7 this is what i get.
playonlinux 100% |=========================| 951 B 00:00
fedora 100% |=========================| 2.1 kB 00:00
updates 100% |=========================| 2.6 kB 00:00
Setting up Install Process
Parsing package install arguments
Package python - 2.5.1-15.fc8.i386 is already installed.

Sorry about this I really don't know what i am doing, only got into Linux as it was on my netboook when I bought it. Thanks for you patience and help
Quentin PÂRIS Tuesday 13 September 2011 at 18:24
Quentin PÂRIS
Admin

Your distro version is out to date. You need to Download and install a newer one
Вы находитесь здесь: Index > PlayOnLinux > Linux Linpus lite