Вы находитесь здесь

Форум

Dungeon Defenders on Steam

Won't get past the .NET 3.5 Install

Автор Replies
esente Thursday 12 January 2012 at 23:20
esenteAnonymous

Hi,

I guess this is a well-know problem with Wine and not PlayOnLinux, but maybe somebody will figure out a workaround for it.

I tried to play Dungeon Defenders on Steam through POL, but right after clicking on Play, it asks to install .NET Framework 3.5 and after an hour downloading 284MB of installer, it fails :(

I'm currently on Arch Linux, and my wine is the lastest. I hope there is a way for us to play those games, otherwise, I would have to go back to Window$ :(
BrownTsunami Monday 31 December 2012 at 7:01
BrownTsunamiAnonymous

I don't know if anyone else has dealt with this, but if you install .NET 3.5 with the PoL interface, you can get it to work by editing the registry as in the wine appdb posts.
Big_Taxi Wednesday 30 January 2013 at 18:02
Big_TaxiAnonymous

This is the root of my problem- .NET 3.5 won't install, even through my interface. I need .net 2.0sp1 to install 3.5, and I've installed that one (2.0 sp1) multiple times.
Big_Taxi Wednesday 30 January 2013 at 18:03
Big_TaxiAnonymous

I also get CLR error 80004005. I'm very lost, and would prefer to not start a new thread, in case other people have the same problems.
petch Wednesday 30 January 2013 at 18:55
petch
Developer

There's a native port of Dungeon Defenders for Linux now...
Big_Taxi Wednesday 30 January 2013 at 19:12
Big_TaxiAnonymous

What would I have to do to get that? Please forgive my ignorance.
petch Wednesday 30 January 2013 at 20:23
petch
Developer

Personally I got it from Humble Bundle...
Big_Taxi Thursday 31 January 2013 at 3:00
Big_TaxiAnonymous

The Humble Bundle where you got that ended a while ago- do you have any tips on how to get either my purchased copy to work straight to linux or through wine? Or help me find another native port, because currently I'm coming up empty.
petch Thursday 31 January 2013 at 8:59
petch
Developer

Mmmh the situation looks more complex than I thought, because Linux port wasn't handled directly by Trendy Games, but by Ryan C. Gordon (Icculus), so it's official-but-not-really-supported, something like that.
Tried the native version just now, and it was quite slow (probably assuming way too much from my laptop nVidia), and segfaulted after a few minutes in the game, so I'm not sure it's your best option yet...
Vantales Wednesday 6 February 2013 at 17:47
VantalesAnonymous

Here's what I did to get it to work:

1. Install Steam through POL
2. Change the Wine Version to 1.5.22
3. Install .NET Framework 3.5 (You get some errors that it crashed while it installs 2.0 and 2.5. Just click continue and it should work later)
4. Install Dxfullsetup
5. Manually add a registry entry for Dungeon Defenders: 
[HKEY_LOCAL_MACHINE\\Software\\TrendyEntertainment\\DungeonDefenders]
"InstalledUE3Redist"=dword:00000001

Most of the Steam games which work with Wine should work that way. Also the FPS should be better with the newest Wine version. At least they increased for me.

Hope this was a bit of help :)
Вы находитесь здесь: Index > PlayOnLinux > Dungeon Defenders on Steam