Вы находитесь здесь

Форум

League Of Legends

Автор Replies
Jump to the page: 1 - 2 - 3 - 4 - 5
petch Thursday 9 August 2012 at 11:24
petch
Developer

Sure, Install PlayOnLinux 4.1.6 (since it seems you recently downgraded),
Install button > Check "In testing" checkbox > Games > League of Legends
drfred79 Thursday 9 August 2012 at 23:51
drfred79Anonymous

Thank you for the instructions petch. I think I can further eliminate some possibilities with my issues.

I re-installed Ubuntu 12.04, installed POL 4.1.6, Install button > Check "In testing" checkbox > Games > League of Legends, LOL installed. Then when patching LOL the install process freezes between the 1st and 2nd step of patching. Closing my LOL client and restarting the client fixes this and it resumes install of patches.

I am still getting the same crash in League of Legends and I think I can deduce part of the reason. I suspect that I do not have the correct fonts installed that LOL uses. When the load screen for starting a game is running no ping numbers, user names, or character names are shown. Then when the game is about to start, League of Legends crashes. Following your method exactly led me to the same crash.

DrFred79
petch Friday 10 August 2012 at 0:01
petch
Developer

The script installs corefonts, and seeing nobody reporting specific fonts as needed I'm a bit doubtful.
Did you left PlayOnLinux download core fonts the first time it ran?
Otherwise, it could also be a video driver problem I think.
drfred79 Friday 10 August 2012 at 1:20
drfred79Anonymous

I let all the automated installs run so I will try updating my drivers and installing the 3rd party videocard drivers. Thank you for the suggestion.
drfred79 Friday 10 August 2012 at 9:41
drfred79Anonymous

Thank you petch for your advice. I've installed 3rd party drivers and I am able to load the game. My FPS is roughly 15-25 compared to 62 on Win8 so I will be following the already mentioned FPS fixes to improve my FPS. You've found my problem and solved it.
Turncloak Thursday 27 September 2012 at 21:05
TurncloakAnonymous

Wine version: 1.5.3
Distribution: Ubuntu

Distribution version: 11.10
Comments: When I start League of Legends it starts out fine, then when i either decide to spectate or play a game, a black sqaure is in the middle of my screen where the League of legennds logo is supposed to be appears.  Nothing happens at all i left it there at time but it still doesn't do anything.

Quote from samiscool30

I have the same problem.
Is there a solution?
luyz25 Friday 19 October 2012 at 20:58
luyz25

Guys, the problem with the FPS you can do this steps:

1- Open de therminal
2- Use this commands:

touch lol_fps.sh
gedit lol_fps.sh

3- Now you copy this:

while [ TRUE ]
do
PIDDOJOGO=`pgrep League`
taskset -p 1 $PIDDOJOGO
sleep 1;
done

4- Save the script and closed
5- Use this command:

chmod +x lol_fps.sh

6- Before you launch the game, open the termianl and use this command:

sh lol_fps.sh

6- Minimaze this terminal and play the game (my fps: 55-62)

And about the problem with the shop:

1- Open league of legends
2- Login
3- go to the opition "settings" and mark the option "disable animation menu"

my shops works fine ^^

Edited by luyz25

petch Saturday 20 October 2012 at 9:38
petch
Developer


Mmmmh I tried to add some similar tweak into the LoL shortcut, but setting the affinity for the whole program not just the game engine, and it seems to break the installer: I can't get past the 33% barrier. Crappy, crappy, crappy...
luyz25 Sunday 21 October 2012 at 16:01
luyz25

hm... you can creating this script and add a host for download and in the script league of legends of playonlinux you add a line to do the downloading this script and make the launcher of the game run the game and the script in the same time...what do you think about that?
petch Sunday 21 October 2012 at 16:21
petch
Developer


You don't need to download another script, it's not too difficult to have other script's code inside PlayOnLinux shortcut, say put it into a Bash function.
Why I don't like it, is the way it works, doing a small amount of work every second in the background, and depend on things conceptually more complex like being able to list all processes names (whatever that is, really), and filter that.
It's more of a programmer's feeling about it, I would have preferred to only depend on affinity being inherited between processes. But maybe there's no other way.

Also, as seen in another thread, adding affinity hints can give a speedup to some, and slowdowns for others:
http://www.playonlinux.com/en/topic-8901-2.html
So I guess I'll be even more conservative about affinity usage.

Edited by petch

luyz25 Sunday 21 October 2012 at 16:44
luyz25

This changes everything...but there is a provability that the version of the hardware are not updated in the same way ... ask them what the hardware version of each mine is 304.60...is a possibility but it does not solve the problem in script...=/

AMD Phenon II X4
Geforce GTS 250 1GB - Driver version 304.60
4GB Ram DDR3 1333

Edited by luyz25

petch Sunday 21 October 2012 at 17:45
petch
Developer


Beside the fact that I do not see why you call that a "hardware" version (drivers are software!), even if I knew their drivers versions... What to do with ATIs, Intels, others?
It really seems there's no one-fit-them-all solution, which is the point.
Renalin Sunday 28 October 2012 at 23:07
RenalinAnonymous

Hello! I have a problem of very very low fps (about 5 up to 10 sometimes) and it's not enought to play... I tried to make and run the script decribed by luyz25 but it didnt improved anything.
The problem shouldn't come from CPU or so, i have a i7 intel. As info: i run ubuntu 12.10 on a Lenovo T430s.
Do you have a idea where it could come from and how to improve this? I really want to avoid installing Windows...
Thanks for your help! :)

Edited by Renalin

cfet Wednesday 31 October 2012 at 3:48
cfetAnonymous

Greetings Summoners.

Installed with no issues, can access champion select and all pre-game functionality. Currently using PoL beta from git as of today. I have all functionality EXCEPT I have an entirely black screen upon beginning of game!!!

Sounds all occur, I can even tell I have control of my character. The glove cursor is also fully visible but nothing else is. Cursor reponds to ability usages and changes its appearance appropriately. I am running Linux Mint 13, Cinamon. Using ATI Radeon HD6870 with proprietary drivers. Have wine configured to run as W7.
GeorgeCh Wednesday 31 October 2012 at 14:09
GeorgeChAnonymous

Hello summoners.

I installed yesterday Ubuntu 12.10 and i immediately installed PlayOnLinux and LoL.It is working except the store but i have no drivers for my HD 4850 so it might be just that.Frames are from 40 to 50 and everything is working ok.
cfet Wednesday 31 October 2012 at 16:58
cfetAnonymous

An update for me, I now have more funtionality with Mint 13 Cinamon and the current git of POL with the exception of the minimap. My current wine configurations are as follows:

POL Testing Installer for LoL (1.5.5-LeagueOfLegends)
DESELECTED: Allow the window manager to decroate the windows
DESELECTED: Allow the window manager to control the windows
SELECTED: Emulate a virtual desktop (800x600)

I have no idea why this is working but I am now playing at full resolution 1920x1200 with a glitched minimap (flashing fog of war). I have not tested the store yet.

Edit: Will test with XP settings. Store still not working and minimap bugged.

Edited by cfet

GeorgeCh Thursday 1 November 2012 at 2:04
GeorgeChAnonymous

Update
Everything is working but i have no idea(no idea on linux either) what to check to post.Store is working too.The only thing is that that i use PoL default settings(xp).In game settings i just turned of shadows and effects on low and i have 50-60 fps.
cfet Thursday 1 November 2012 at 17:02
cfetAnonymous

George is your minimap bugged? Also, can you type in post-game chat boxes?
GeorgeCh Friday 2 November 2012 at 18:39
GeorgeChAnonymous

cfet everything is working in game fine.I have no issues,nothing.The game works almost perfectly.I can use chat boxes after game.I have only issue with RP purchase which can't load(i've seen it last night)

Edited by GeorgeCh

Ganil Saturday 10 November 2012 at 19:12
GanilAnonymous

Can you buy runes ?
The store "almost" work for me.

Everythings seems to work except filters and the rune page.

edit: oh god it loaded. It's just super slow but it loaded xD. It's faster if you check the 'use virtual desktop' option (but still slow).

Well, at least it's working. The description of the script is missleadig.

I love pol.

Edited by Ganil

Вы находитесь здесь: Index > > League Of Legends