Das Forum

32bits OpenGL Libraries Missing?

Autor Antworten
Epicurean Sunday 29 September 2013 at 22:46
EpicureanAnonymous

Good day people of POL

I am having issues with not being able to find 32bits OpenGL Libraries on start up. I am aware that there are other topics on this subject, but I have been unable to deduce how relevant they are under my configuration. I am very new to Linux, and I apologize if this post seems lazy as I have made an effort to try to solve this situation by searching first.

I will start by posting as much relevant information as I can. I am running Linux Mint 15 MATE. My GPU is an ATI Radeon HD 5450, and I have installed the AMD Catalyst Proprietary Display Driver 13.8 Beta. In the Catalyst Control Center under information the OpenGL is listed: OpenGL Provider ATI Technologies Inc., OpenGL Renderer ATI Radeon HD 5450; OpenGL Version 1.4 (2.1 (4.3.12441 Compatibility Profile Context 13.20.11)). So, I assume that the OpenGL Libraries have been installed.

Here is what happened when I attempted to start POL in the terminal:


playonlinux

[main] Message: PlayOnLinux (4.2.1) is starting

[clean_tmp] Message: Cleaning temp directory

libGL error: failed to load driver: swrast

libGL error: Try again with LIBGL_DEBUG=verbose for more details.

[Check_OpenGL] Warning: 32bits direct rendering is not enabled

[POL_System_CheckFS] Message: Checking filesystem for /home/user/.PlayOnLinux/

[main] Message: Filesystem is compatible

[install_plugins] Message: Checking plugin: Capture...

[install_plugins] Message: Checking plugin: ScreenCap...

[install_plugins] Message: Checking plugin: PlayOnLinux Vault...

[maj_check] Message: Web version : 1380487229

[maj_check] Message: Current local version : 1380487178

[maj_check] Message: Updating list

[POL_Config_Write] Message: Config write: LAST_TIMESTAMP 1380487229


Here is what is listed upon close of application:


Registered PID: 14433 (Missing)

Registered PID: 14467 (Missing)


Thank you for reading my post. I appreciate any efforts that may be directed towards resolving my issue.

booman Tuesday 1 October 2013 at 0:09
booman

Are you running 64-bit Linux Mint 15?

You probably need to install the 32-bit libraries for Mint.

Open Terminal

[code]
sudo dpkg --add-architecture i386
[/code]
press enter

[code]
sudo sed -i 's/deb /deb [arch=amd64,i386] /g' /etc/apt/sources.list
[/code]
press enter

[code]
sudo apt-get update
[/code]
press enter

[code]
dpkg --print-foreign-architectures
[/code]
press enter

...has to output i386

Editiert von: booman


† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Epicurean Tuesday 1 October 2013 at 0:51
EpicureanAnonymous

Thank you for the reply, booman. I am runing a 32bit distro. Should I still follow the above instructions or should those already be on my system?
booman Tuesday 1 October 2013 at 0:56
booman

Nope, you don't need any of the 32-bit libraries because you already have them.
I am also running 32-bit Mint for gaming and it is GREAT.

It looks like maybe the AMD drivers didn't install correctly.
This thread may have more information for you: Mint 15

Editiert von: booman


† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Epicurean Tuesday 1 October 2013 at 2:52
EpicureanAnonymous

I just installed the latest amd-catalyst-13.9-linux-x86.86_64.run and I have no error messages in playonlinux upon startup. I will mark this as solved as soon as I can get everything to work. I appreciate your input, and it was helpful. I am making progress. I am coincidentally the last poster on that thread you mentioned. ;)
booman Tuesday 1 October 2013 at 14:38
booman

No problem. What about your games?
Are they running properly?

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Epicurean Wednesday 2 October 2013 at 5:02
EpicureanAnonymous

Hello Again

So, I installed the first disk of Neverwinter Nights without incident, but it will not run. I am greeted by these messages from the game: “Your Video card has less than 128 mb of video memory" “Unable to detect a video card with hardware 3D acceleration", "Hardware 3D acceleration appears to be disabled."

I changed the settings to 512mb and did some other stuff, but to no avail. I am pretty new to all this.
I appreciate your help. Should I make another topic?
booman Wednesday 2 October 2013 at 19:28
booman

yes, definitely make a new post, sounds like catalyst didn't install correctly

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained