Das Forum

local script not loading

local install script not loading

Autor Antworten
kartoffelopa Saturday 15 July 2017 at 1:08
kartoffelopaAnonymous

Hello,

I am trying to put together a script for the Path of exile 3.0 beta (will be release client in 4 weeks). I encountered the problem that my script will not load at all with Tools->run a local script.

However if i put the commands one by one into the console the first few commands work fine. Any idea why it does not load at all?

Here is the script in question:

 

#!/bin/bash
# Date : 2017-07-15 00:30
# Last revision : 2017-07-15 00:30
# Wine version used : 2.10-staging
# Distribution used to test : Xubuntu 16.04
# Author : Kartoffelopa
[ "$PLAYONLINUX" = "" ] && exit 0
source "$PLAYONLINUX/lib/sources"
TITLE="Path of Exile 3.0 beta 64 bit"
DX="DirectX 9"

POL_SetupWindow_Init
POL_Debug_Init
POL_SetupWindow_presentation "poe3 beta" "poe" "a" "a" "a"
POL_Wine_SelectPrefix "poe3beta"
POL_Wine_PrefixCreate "2.10-staging"
POL_System_TmpCreate "poe3t"

cd "$POL_System_TmpDir"

POL_SetupWindow_InstallMethod "LOCAL,DOWNLOAD"
 
if [ "$INSTALL_METHOD" = "LOCAL" ]
then
    POL_SetupWindow_browse "Please select the installation file to run." "poe"
    POL_SetupWindow_wait "Installation in progress." "poe"
    POL_Wine start /unix "$APP_ANSWER"
elif [ "$INSTALL_METHOD" = "DOWNLOAD" ]
then
    cd "$POL_System_TmpDir"
    POL_Download "https://web.poecdn.com/downloads/PathOfExileBetaInstaller.exe"
    POL_SetupWindow_wait "Installation in progress." "poe installation"
    POL_Wine start /unix "$POL_System_TmpDir/PathOfExileBetaInstaller"
fi


POL_SetupWindow_wait "$(eval_gettext 'Please wait while $DX is installed.')" "$DX"
POL_Install_directx9
POL_SetupWindow_wait "Please wait" "TITLE"
POL_Wine start /unix "$POL_System_TmpDir/PathOfExileBetaInstaller.exe"
POL_Wine_Direct3D "UseGLSL" "disabled"
POL_System_TmpDelete
POL_Shortcut "PathOfExile.exe" "32bit poe"
POL_Shortcut "PathOfExile_x64.exe" "$TITLE"
POL_SetupWindow_Close
exit

 

edit: I will try to make it standard conform after i get it to work locally.

Editiert von: kartoffelopa