Das Forum

AEO2 HD : Jeu qui se lance mais écran noir

Dommage tout marche nickel autrement :)

Autor Antworten
mattspider Monday 29 July 2019 at 23:39
mattspiderAnonymous

Bonjour à tous,

Je suis nouveau ici, n'hésitez pas à me dire si il manque des choses dans ma description.

J'ai installé AOE2 HD sur Playonmac. Tout se passe correctement le jeu se lance et la partie aussi.
Seulement voilà, la zone de jeu est complètement noire (écran noir).
Les bandeaux du haut (menu) et du bas (MAP et touches d'actions) eux s'affichent correctement.

J'ai installé le jeu sur un disque virtuel 32bit, version wine : 3.10.
j'ai un Mac de mid-2009 avec version OSX 10.10.5 (yosemite)

Voici le rapport debug quand je lance le jeu :

[07/29/19 23:32:41] - Running wine-3.10 AoK HD.exe (Working directory : /Volumes/Mac HD/pierrematteudi/Library/PlayOnMac/wineprefix/AgeOfEmpires2/drive_c/Program Files/Age of Empires II HD)
dbus[9824]: Dynamic session lookup supported but failed: launchd did not provide a socket path, verify that org.freedesktop.dbus-session.plist is loaded!
0009:err:winediag:wined3d_dll_init The GLSL shader backend has been disabled. You get to keep all the pieces if it breaks.
0009:fixme:system:SystemParametersInfoW Unimplemented action: 110 (SPI_GETSHOWIMEUI)
0009:fixme:win:EnumDisplayDevicesW ((null),0,0x33e748,0x00000000), stub!
0009:fixme:system:SystemParametersInfoW Unimplemented action: 111 (SPI_SETSHOWIMEUI)
0028:err:hid_report:process_hid_report Device reports coming in too fast, last report not read yet!
0035:fixme:d3d:context_check_fbo_status FBO status GL_FRAMEBUFFER_UNDEFINED (0x8219).
0035:err:d3d:context_check_fbo_status FBO 0 is incomplete, driver bug?
0035:err:d3d:wined3d_check_gl_call >>>>>>> GL_INVALID_FRAMEBUFFER_OPERATION (0x506) from glBlitFramebuffer() @ surface.c / 285.
0009:err:module:load_builtin_dll failed to load .so lib for builtin L"winepulse.drv": dlopen(/Volumes/Mac HD/pierrematteudi/Library/PlayOnMac/wine/darwin-x86/3.10/lib/wine/winepulse.drv.so, 258): Libr  Referenced from: /Volumes/Mac HD/pierrematteudi/Library/PlayOnMac//wine
0028:err:hid_report:process_hid_report Device reports coming in too fast, last report not read yet!
0039:fixme:winmm:MXD_GetControlDetails What should the sw-side mixer controls map to?
0039:fixme:winmm:MXD_SetControlDetails What should the sw-side mixer controls map to?
0039:fixme:winmm:MXD_SetControlDetails What should the sw-side mixer controls map to?
0009:err:quartz:GetClassMediaFile Media class not found
0035:err:d3d:wined3d_check_gl_call >>>>>>> GL_INVALID_OPERATION (0x502) from setting clip space and viewport @ state.c / 4073.
0009:fixme:win:EnumDisplayDevicesW ((null),0,0x33e698,0x00000000), stub!
0009:fixme:quartz:VMR9WindowlessControl_SetAspectRatioMode (0xa60fb90/0xa60f978)->(...) stub
0009:fixme:quartz:VMR7FilterConfig_SetRenderingMode (0xa5fe1bc/0xa5fdfc0)->(2) stub
0039:fixme:winmm:MXD_GetControlDetails What should the sw-side mixer controls map to?
0039:fixme:winmm:MXD_SetControlDetails What should the sw-side mixer controls map to?
0039:fixme:winmm:MXD_SetControlDetails What should the sw-side mixer controls map to?
0039:fixme:winmm:MXD_SetControlDetails What should the sw-side mixer controls map to?
0039:fixme:winmm:MXD_SetControlDetails What should the sw-side mixer controls map to?
0028:err:hid_report:process_hid_report Device reports coming in too fast, last report not read yet!

Merci d'avance de votre aide,

Matt

Dadu042 Wednesday 31 July 2019 at 22:49
Dadu042
Moderator

Bjr, lorsqu'un script est créé, le support se passe sur la page du script : https://www.playonlinux.com/fr/app-2167-Age_Of_Empires_II__HD.html

mattspider Monday 5 August 2019 at 10:21
mattspiderAnonymous

Mmm à vrai dire je n'ai pas utilisé le script dont-il est question sur le lien que tu me suggères.

J'ai installé directement le jeu sur un disque virtuel Wine. (à partir du setup.exe)