Das Forum

StarCraft II Wings of Liberty

Miam !!

Autor Antworten
Jump to the page: 1 - 2 - 3
thjack Monday 9 August 2010 at 12:22
thjackAnonymous

Ha oui ok, j'avais mal compris.
Ben je vais retenter quand même... sinon je verrais de mon côté... (c'est un officiel au fait ^^)

Enfin bref, merci à toi et à ce que POL nous apporte.
Bon courage pour la suite.
GNU_Raziel Monday 9 August 2010 at 12:31
GNU_Raziel

Donc tu peu téléchargé légalement la version FR en Digital Download sur le site de battle.net, tu aura juste a te loguer sur ton compte battle.net et il te proposera ensuite la version en download, gratuitement biensur vu que tu as une clé valide.

Ca t'évitera de perdre du temp avec le magasin/blizzard pour faire chager ton DVD...ils te diront surement la même chose d'ailleurs, ca m'étonnerais qu'il te renvoi un DVD, ils te conseillrons plutôt de dl la version Digitale.
thjack Monday 9 August 2010 at 12:37
thjackAnonymous

Ok! Merci
Je suis entrain de télécharger. J'éspère que ça résoudra le problème :)

Je te tiens au courant.
Bonne journée
thjack Monday 9 August 2010 at 23:16
thjackAnonymous

Alors, je viens au nouvelle.

Après 3 téléchargement de SC2 (ils ont foiré à environ 80 %), j'ai enfin réussi à l'avoir.
L'installation c'est bien déroulé, pas de problème. Le téléchargement des mises à jour aussi.
Seul problème (oui, mais c'est le dernier), quand je lance SC2, j'ai un message d'erreur qui me dit que DirectX n'est pas installé...
J'ai pourtant bien activé mes pilotes graphiques, pilotes 3D...Etc

Désolé de te "causer" autant de problème... je suis vraiment maudit ces temps-ci...

Editiert von: thjack

GNU_Raziel Tuesday 10 August 2010 at 0:16
GNU_Raziel

la ca dois venir de ta carte graphique (une intel intégrée si je me souviens bien), pas sur que le pilote supporte les extension GLX, il dois plutot faire au AIGL (pour compiz) et basta...

Pour verifié ca, utilise cette commande :

glxinfo | head -n 3 | grep rendering


Avec une carte supportant pleinnement l'accélération 3D sous linux tu auras ça :

direct rendering: Yes


Si c'est No t'es foutu...
thjack Tuesday 10 August 2010 at 7:36
thjackAnonymous

Non non, c'est une Nvidia Geforce 9800 qui n'est pas intégré à la carte mère.
Et avec la commande, j'obtiens le bon résultat

P.S.: je vais tenter de le réinstaller. Je ne pense pas que ça vienne de ça mais bon... on ne sait jamais

Editiert von: thjack

djiock Saturday 14 August 2010 at 12:51
djiockAnonymous

Merci pour le script ! Moi j'ai un souci que je préfère détailler ici, ça me parait plus pertinent que d'ouvrir un bug :

J'ai bien tapé la commande exacte, elle s'exécute sans souci et j'ai bien le bon montage mais le script n'avance pas ! Il reste bloqué sur "attente des commandes à entrées par l'utilisateur" (attention à la faute d'ailleurs :)).

Suis-je le seul ? J'aimerais bien pas rebooter pour jouer :)
GNU_Raziel Saturday 14 August 2010 at 14:41
GNU_Raziel

Faute corrigée.

Ferme le terminal une fois les commande entrées, c'est ca que POL attend avant de continuer.
Berillions Saturday 14 August 2010 at 15:32
Berillions

Salut GNU_Raziel,

Pour la version DVD, pourquoi copies-tu l'ensemble du DVD sur le HDD?
Parce que l'installation ne se lance pas après avoir démonté/remonté le DVD?

Si c'est le cas, c'est un problème que j'ai également eu, Wine se coupait au bout de 5s. Pour résoudre le problème, il a fallu que je fasse une petite manip dans winecfg.

En faite, il faut rajouter /media (et surtout pas $CDROM) en tant que lecteur cdrom dans l'onglet lecteur de Winecfg mais seulement après avoir démonter/remonter le DVD.

J'ai testé chez moi et l'installation se lance très bien. Si possible, essaie ma méthode chez toi en changeant le nom du prefix.

Berillions,

Editiert von: GNU_Raziel


GNU_Raziel Saturday 14 August 2010 at 15:40
GNU_Raziel

L'installation ne se lance pas depuis le DVD parsque Blizzard a fait un DVD pourri, c'est tout. Copier le contenu du DVD une fois remonté (fichiers cachés visibles donc) est le seul moyen sur a 100% pour que ca fonctionne.

De plus :
1-Le point de montage n'existera plus une fois le DVD démonté (les automount créent des dossiers TEMPORAIRES) donc la valeur de $CDROM sera forcement fausse une fois le DVD démonté.
2-Monter dans /media directement est idiot et dangereux, de dossier est utiliser pour d'autre péripheriques.

La méthode actielle fonctionne bien et elle est sure.
djiock Saturday 14 August 2010 at 15:41
djiockAnonymous

Yes ça marche, merci pour ta réactivité ! :)
Berillions Saturday 14 August 2010 at 16:17
Berillions

@GNU_Raziel,
Toi qui voit, c'est ton script mais bon, déjà que l'installation dure entre 10 et 15min alors si en plus, il faut copier 7Go sur le disque...

nandayo Monday 16 August 2010 at 2:37
nandayoAnonymous

Bonsoir,

toute l'install se passe sans souci, mais quand je lance le jeu depuis playonlinux rien ne se passe. Comme j'ai aussi wine 1.142 installé par ailleurs, j'ai essayé de le lancer puis le menu démarrer de wine (avec la 1.142 donc), et là quelque chose se passe, le jeu se lance, mais les textures sont complètement brisées, impossible même de me logger à bnet, obligé de rebooter le pc comme un sauvage.

Pourquoi il m'est impossible de le lancer avec playonlinux et wine 1.2 ?


N.B. J'ai une 4850HD et je tourne sur un C2D@3Ghz, Ubuntu 10.04, dernière version de playonlinux qui a installé wine 1.2.

Editiert von: nandayo

GNU_Raziel Monday 16 August 2010 at 11:30
GNU_Raziel

Pour wine 1.1.42 c'est normal, version trop vieille.

Lance POL depuis un terminal, ça te permettra d'avoir une sortie d'erreur et post la.
obibann Monday 16 August 2010 at 11:37
obibannAnonymous

Bonjour, en ce qui concerne les problème de montage du DVD, avez-vous essayer de monter celui-ci en utilisant le système de fichier "udf" au lieu de l'"iso9660" ?
GNU_Raziel Monday 16 August 2010 at 12:12
GNU_Raziel

il n'y a pas de problèmes de montage du DVD, l'étape manuelle est obligatoire car certains fichiers du DVD sont cachés et si on ne remonte pas le DVD afin de les révélés l'installeur du jeu plante indiquant que ses fichiers sont introuvables.
draco31.fr Saturday 21 August 2010 at 11:45
draco31.fr

Bonjour,
On est OK sur le fait qu'il faille remonter le DVD, mais si on pouvait éviter de tout recopier sur le disque dur, ça serait parfait.
Je pense que la remarque de obibann va dans ce sens.

Personnellement, la copie des fichiers du DVD m'a posé un problème de taille !
Une fois les fichiers copié, je n'avais plus assez de place dans mon home pour installer le jeu. Du coup, je l'ai installé sur une autre partition de mon disque (emplacement Z:/jeux/Starcraft2 pour Wine).
Résultat : Le lanceur de POL ne fonctionnait pas. Etant encore débutant avec POL, WinE et les prefix, j'ai mis du temps à comprendre d'où venait le problème !!
Serait-il possible d'indiquer à l'utilisateur de combien de place il a besoin, et de lui demander où copier les fichiers temporaires ?
Ou alors, l'autre solution serait que le script détecte l'emplacement utilisé pour l'installation, et corrige le lanceur en conséquence.

Malgré tout ces déboires, je remercie grandement GNU_Raziel et tout les développeur de POL et Wine sans qui je serai passé à côté d'un formidable jeu !!

EDIT : Pour le problème de thjack et de DVD corrompu. Tu n'aurais pas acheté la version MAC par hasard ?

Editiert von: draco31.fr

GNU_Raziel Saturday 21 August 2010 at 17:57
GNU_Raziel

1-mount detecte automatiquement le BON format, aucun besoin de le forcer donc.
2-Ca n'a RIEN a voir avec le fait de copier le contenu sur le disque dur, j'ai rajouté cette étape uniquement parsque chez certainne personne l'install ne démarrait pas depuis le DVD alors que chez d'autre (dont moi) aucun souci.
3-Copie le contu de ton dvd ou tu veu et lance l'install POL comme si tu avez la version digitale et ca fonctionnera parfaitement.
GNU_Raziel Thursday 26 August 2010 at 15:04
GNU_Raziel

pmithrandir Thursday 11 November 2010 at 16:48
pmithrandirAnonymous

Bonjour

J'ai fait un petit compte rendu d'installation pour starcraft 2... quelques problème au menu.

Je suis sous mandriva.
http://forum.mandriva.com/viewtopic.php?t=132924

Bugs non resolu :
Pas de 3D sous starcraft, mais du noir a la place.
Le DRI est bien activé sous linux.

J'ai amélioré la situation en mettant en configurant les options avancées de direct3D.(configuration avancée de wine). Maintenant, je vois... beaucoup d'ombres, mais un peu les personnages et d'autres details.
Les personnages que j'ai passé en 3D pour tester ne s'afichent plus alors qu'ils s'affichaient en 2D.

Carte video : intel integré.

Admin et créateur de http://www.jaiuneidee.net le nouveau site de démocratie participative locale.

Mes idées :
[URL="http://www.jaiuneidee.net/42/taxer-les-transactions-financires-inutiles"]Taxer les transactions financières inutiles[/URL]
[URL="http://www.jaiuneidee.net/35/rmunrer-les-stages-services-civiques-selon-le-diplme"]Rémunérer les stages / services civiques selon le diplôme[/URL]
[URL="http://www.jaiuneidee.net/44/une-eco-taxe-plus-simple"]Une eco-taxe simple à mettre en oeuvre[/URL]