Das Forum

Issues while trying to "instal" starcraft 2

wine errors

Autor Antworten
0949er Friday 3 December 2010 at 20:34

Hey guys, how are you?

I am running the latest version of "PlayOnLinux" and have come across a issue. While trying to "install" "starcraft II wings of liberty" I get a error on the first step. I get to the first window that says "this wizard will help you install starcraft II on on your computer".

I click "forward" at the bottom of the dialog, and I get a error almost emediatly after start that says:

"Wine version server temporary unavaliable. Please try again later."

I have tried later... many times but nothing works. I am connected to the Internet and have no idea what the issue could be.

I am running Ubuntu 10.10 w/ proprietary nvidia drivers installed. Any help would be greatly appreciated.
GNU_Raziel Friday 3 December 2010 at 20:47

If you use a proxy, set it in POL too.
Server is up and running, no problem reported.
BTW, Ubuntu 10.10 is reported as very problematic with POL and wine...There is something like "trusted apps" in 10.10, add POL in it.

Also note that Ubuntu 10.10 will block BLizzard updater, you need to unlock a security measure to make SC2 working (not sure this security is enabled by default) :

echo 0 | sudo tee /proc/sys/kernel/yama/ptrace_scope

Since I do not use Ubuntu 10.10 it's difficult to help you.

Editiert von: GNU_Raziel

0949er Friday 3 December 2010 at 21:21

below is the ouput information when I run playonlinux is a terminal. This is what I am doing:

1) starting program
2) going to install
3) finding starcraft II
4) clicking apply
5) clicking "forward"

that is where I get my "wine version server" error. Do you see anythign strange in the output?

swooshonln@power-house:~$ playonlinux
PlayOnLinux v3.8.6

touch: cannot touch `/home/swooshonln/.PlayOnLinux/configurations/last_string': Permission denied
Checking plugin: Advanced Wine Configuration...
Checking plugin: Offline PlayOnLinux...
Checking plugin: Capture...
Checking plugin: Transgaming Cedega...
Checking plugin: Wine Import...
Checking plugin: Wine Look...
Checking plugin: Detour...
Xlib: extension "RANDR" missing on display ":0.0".
Running install menu
Xlib: extension "RANDR" missing on display ":0.0".
/home/swooshonln/.PlayOnLinux/install: line 46: cd: /home/swooshonln/.PlayOnLinux/tmp/*.jpg: No such file or directory
--2010-12-03 15:18:58-- http://mulx.playonlinux.com/wine/linux-i386/LIST
Resolving mulx.playonlinux.com...
Connecting to mulx.playonlinux.com||:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 10010 (9.8K) [text/plain]
Saving to: `STDOUT'

100%[======================================>] 10,010 41.0K/s in 0.2s

2010-12-03 15:18:59 (41.0 KB/s) - written to stdout [10010/10010]