Das Forum

Problème d'image sur Guidl wars :

Autor Antworten
Jump to the page: 1 - 2
Rogan Sunday 9 December 2007 at 12:42
RoganAnonymous

Bonjour à tous.

Pour commencer je tiens à me présenter comme un débutant complet au monde linux/unix. Et étant un ancien accro windowsiens, je suis en manque de jeu x)
Bref je tiens aussi à remercie l'équipe de playonlinux qui m'a simplifié la vie.

Mais voila j'ai décider il y a peus d'installer guildwars avec playonlinux. l'installation se passe comme il faut, sans probleme apparent. Le probleme étant que je n'ai aucune image en arrivant sur le jeu, seulement le son (et le pointeur de sourie, quand meme). J'ai essayer de me renseigner mais aucun résultat.

Information utile :
Je suis sur mandriva 2008, ma version de wine est la 0.9.49. Je suis sur un ordinateur portable que j'ai acheter il y a peus.

S'il vous manque d'autre information je suis là merci d'avance pour ceux qui prendrons le temps de m'aider.

Editiert von: Rogan

Apocalypse555 Sunday 9 December 2007 at 12:51
Apocalypse555

Slt et bienvenu sous Linux ,

Alors pour ton problème il est possible que ce soit la vidéo ...
Si tu utilise la version 2.x de POL alors un message t'indique si ton accélération graphique n'est pas installée !
Si tu as eu ce message il faut cherché de coté ! Pour vérifier tu peux lancer une console et taper :
glxgears
Indique ensuite ici le nombre de fps et ta carte graphique (avec les drivers que tu lui as attribué ...)

On verra ensuite avec ces informations

Si tu n'as pas compris une méthode ou quoi que ce soit demande

Et petite note perso : Bienvenus dans le Monde Libre !!!

Rogan Sunday 9 December 2007 at 13:11
RoganAnonymous

Merci pour ta réponse Apocalypse555

Apres avoir taper glxgears j'obtiens:

libGL warning: 3D driver claims to not support visual 0x63
5851 frames in 5.0 seconds = 1170.118 FPS
6083 frames in 5.0 seconds = 1216.459 FPS
6079 frames in 5.0 seconds = 1215.763 FPS
6079 frames in 5.0 seconds = 1215.743 FPS
(etc..)

Pour ce qui est des drivers de ma carte graphique.. j'ai rien toucher pas rapport à l'installation. J'avais deja cherche des infos sur les mise a jours des drviers etc, mais j'avais rien compris donc laisser vite tomber.

Pour ce qui est de la carte graphique, je n'ai pas encore bien compris comment fonctionnait les ordinateur portable à ce niveau, tout ce que je peux vous dire c'est : Intel Graphics Media Accelerator X3100 (obtenus sur la fiche technique de mon ordi http://h20195.www2.hp.com/V2/default.aspx?reg=fr&lang=fr&pn=Mobile%20Products/Compaq%20Presario%20C700%20Notebook%20PC%20series pour ceux qui serait interesser c'est le modele C750EF)

je rajoute ce lien aussi si ça peus aider :
http://support.intel.com/support/graphics/intelgm965/
(apparament c'est s'qui est dans mon portable mais je sais pas si cela va vous aider).

Voila. merci encore

Editiert von: Rogan

Apocalypse555 Sunday 9 December 2007 at 14:19
Apocalypse555

Ok t'inquiète pas moi aussi ça m'a fais le même coup au début

Alors 2-3 petits conseils : cherche pas à mettre tous les drivers, la plupart sont mis automatiquement ...
Les seuls à vraiment regardé sont la vidéo (très important), le son (si besoin) et le réseau sans fil (si besoin et si existant ^^)

Pour la vidéo sous Linux c'est un vrai soucis même si le problème se règle de jour en jour ! Surtout pour les ATI qui ont du mal avec Linux alors que Nvidia ont bien géré leur coup ... D'ailleurs à ce propos tu a sûrment une ATI car X3100 est sûrment une gamme de chez ATI ! Désolé t'as pas pris le plus simple (ni le plus performant pour le moment ) je ne vais te fais un cours sur les drivers ATI mais il serais mieux que tu connaisses le sujet : http://doc.ubuntu-fr.org/materiel .

Sinon j'espère aussi que niveau paquetages et dépôt tu es bien renseigné car c'est la grande différence avec Windows mais dès que tu as le coup de main tu trouve ça au moins 100 fois mieux (Paroles d'ancien Windowsien ) Sinon recherche et règles tes dépôts c'est la base d'un système Linux

Bon je reviens sur le sujet, avec 1000 FPS il est évident que ton accélération graphique n'est pas optimal mais étant donné que tu as une ATI c'est peut-être le maximum que tu puisse avoir pour le moment ! Mais si tu n'a rien touché tu peut peut-être regarder mes liens pour optimiser ta vidéo !

NOTE IMPORTANTE : suis le tuto au cas où la vidéo plante cela t'évitera de formater comme moi ! Il est très facile de faire une sauvegarde du X.org (qui est en gros l'interface graphique de ton bureau ...).

Petite précaution

Avant toute manipulation sauvegardez votre fichier xorg.conf" (à restaurer en cas de problème) :

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.bak
Pour restaurer :

sudo cp /etc/X11/xorg.conf.bak /etc/X11/xorg.conf

Quote from Tuto de Ubuntu.fr.org


J'espère que ça va t'aider (je sais il y a beaucoup d'informations et de nouveauté mais quand tu as compris ça tu as compris presque toute la différence entre Linux et Windows, c'est le plus dur courage )

EDITE : Pour toi si tu es sous Mandriva ce n'est pas sudo mais :
su
ton pass
cp /etc/X11/xorg.conf /etc/X11/xorg.conf.bak

et pareil pour restauré (oublis pas le "su" avant sinon tu n'as pas les permissions) :
cp /etc/X11/xorg.conf.bak /etc/X11/xorg.conf

EDITE 2 : Pour les drivers ATI, un gestionnaire de driver existe : Envy je ne l'ai pas essayé mais il a des bons et des mauvais écho sans compté que je ne sais s'il marche sous Mandriva ...

Editiert von: Apocalypse555


Rogan Sunday 9 December 2007 at 14:36
RoganAnonymous

Apres avoir jeter un oeil sur le site ubuntu-fr, on me demande de faire :

[rogan@localhost ~]$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)

pour savoir si j'ai bien une carte ATI, apparament se n'est pas le cas? Par contre je trouve rien sur ce materiel en faisant des recherches sur google.

Quentin PÂRIS Sunday 9 December 2007 at 14:38
Quentin PÂRIS
Admin

Fait

glxinfo | grep "rendering"
Rogan Sunday 9 December 2007 at 14:42
RoganAnonymous

Voila se que j'obtiens :

libGL warning: 3D driver claims to not support visual 0x63
direct rendering: Yes

Apocalypse555 Sunday 9 December 2007 at 14:46
Apocalypse555

La commande te permet de savoir si ton accélération graphique est activée ...

Dans ton cas, elle l'est !

Rogan Sunday 9 December 2007 at 14:49
RoganAnonymous

C'est se que je pensais avoir compris merci ^^ mais j'arrive toujours pas à savoir se qu'est "libGL warning: 3D driver claims to not support visual 0x63 ".

Apres si effectivement tout est normalement bon pour la carte graphique, je me demande se qui cloche :/ meme quand j'essaie de faire marcher steam, ça plante tout l'temps, je faire lancer counter strike et apres 30 sec de freeze sur la meme image du menu steam ça quit.

Assez étrange.
Quentin PÂRIS Sunday 9 December 2007 at 14:51
Quentin PÂRIS
Admin

Essais

expert > Gérer les versions de wine > Assigner > Guild wars > 0.9.50
Apocalypse555 Sunday 9 December 2007 at 14:57
Apocalypse555

Je pense que si tu n'arrive pas a avoir plus de 1000 FPS ce n'est pas la peine d'essayer de jouer : ça va laguer à mort surtout pour un FPS (je parle de CSS) mais même si sous Guild War la vidéo est moins demandée elle l'est quand même trop pour jouer avec 1000 FPS ... J'ai le même problème avec mon portable et pour le moment il me sert juste à jouer à Wormux et à regarder des film ! J'ai mis POL dessus, juste parce que j'aime bien ce logiciel ^^

Editiert von: Apocalypse555


Quentin PÂRIS Sunday 9 December 2007 at 14:58
Quentin PÂRIS
Admin

Mais n'importe quoi

ça veux rien dire les fps avec glxgears, il faut pas s'y fier.
Rogan Sunday 9 December 2007 at 15:00
RoganAnonymous

" Essais

expert > Gérer les versions de wine > Assigner > Guild wars > 0.9.50 "

Le jeu ne se lance plus, encore plus étrange
Apocalypse555 Sunday 9 December 2007 at 15:02
Apocalypse555

Mais n'importe quoi

ça veux rien dire les fps avec glxgears, il faut pas s'y fier.

Quote from Tinou


Même si sous le bureau 1000 FPS c'est amplement suffisant, sous un jeu récent (genre Guil War) ça redescend à 20-30 et encore ... Alors oui faut pas s'y fier mais bon ça donne un ordre d'idée !

Quentin PÂRIS Sunday 9 December 2007 at 15:02
Quentin PÂRIS
Admin

Ensuite,

expert => Tuer wineserver
Rogan Sunday 9 December 2007 at 15:47
RoganAnonymous

" Ensuite,

expert => Tuer wineserver "

Hum, le jeu ne démarre toujours pas :o
Quentin PÂRIS Sunday 9 December 2007 at 15:57
Quentin PÂRIS
Admin

Ah ...

Essais la même manip avec la version 0.9.37 de wine par exemple.
Rogan Sunday 9 December 2007 at 16:28
RoganAnonymous

Ha, du changement, le jeu démarre, j'ai de l'image, mais effectivement au niveau des FPS .. et il reste quelque bug aussi niveau de l'affichage, mon personnage par exemple ne s'affiche pas comme il faut au menu pour choisir le perso. Et encore pleins de petit détail qui fait que c'est pas vraiment jouable je pense.. (j'ai pas oser telecharger tout les fichier mise a jour de guild wars pour acceder au jeu proprement dis, car si je lag rien qu'a l'écran de login etc, jpense qu'une fois dans le jeu ..)

Bref apparament ça sera pas trop possible de jouer sur linux à partir de mon portable, et malheureusement sur xp j'ai trouver aucun pilotes son donc pas de jeu pour le moment sur mon portable :/
Quentin PÂRIS Sunday 9 December 2007 at 16:30
Quentin PÂRIS
Admin

Ah ! il marchait pas sous xp déjà !

Ba ouai je pense que c'est mort
Rogan Sunday 9 December 2007 at 16:33
RoganAnonymous

Non, non sur xp ça marche, c'est juste que en achetant mon ordi j'avais vista dessus .. donc beurk, j'ai voulus mettre xp en dual boot avec linux, mais bon impossible de trouver des drivers pour mon matos de son sur xp, donc jouer sans son .. c'est pas mon truc.

C'est dommage, je pensais que comme j'avais un pc portable recent, j'aurai pu jouer à des jeux meme aussi costaud que guild wars.