Das Forum

Diablo III Weird freeze + Cannot find 7z issues

Autor Antworten
Oscar_swe Friday 15 June 2012 at 13:35

Hi! I just got myself DIablo III and a new graphics card ; Radeon HD 6770.

This is my list of procedures:

1. Downloaded and installed latest POL onto my Ubuntu
2. Installed DIablo III from the game DVD without issues
3. Tried to run - unsupportet videocard
4. 100$ later installed new Videocard
5. Updated videodrivers
6. Started POL
7. Error message: "PlayOnLinux cannot find 7z. You should install it to use PlayOnLinux"
8. Installed 7zip via terminal
9. Diablo III RUNS! :D
10. Diablo III Locks up after a few minutes but I can still move the mouse and the music/dialog is still playing. :C

Now I think the problem lies with the 7zip. I installed it but I still get the same error message from POL. When I went to the terminal and tried to install it again it told me

oscar@Two-eyes:~$ sudo apt-get install p7zip
Reading package lists... Done
Building dependency tree      
Reading state information... Done
p7zip is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

And I tryed purging both POL and p7zip and wine and no dice. I really need help with this since the game is taunting me and running only a few minutes and then freezing forcing me to reboot. I can't even get a terminal up...

I am thankfull for help soon! I want to play ^^

Quentin PÂRIS Friday 15 June 2012 at 14:05
Quentin PÂRIS

7zip has nothing to do with that.

I'm afraid that ATI cards are really badly supported on linux. Please read the latest news. You'll have to update your drivers

Editiert von: Tinou