The forum

New Warning Message on startup

Author Replies
Jump to the page: 1 - 2
Daerandin Tuesday 7 May 2013 at 15:28
DaerandinAnonymous

After a rather large update on my Arch Linux system last night, I discovered today that whenever I start PlayOnLinux I get a small PlayOnLinux warning window. The message reads:

iCCP: known incorrect sRGB profile

And that is all it says. The same message pops up if I click on "Configure". There is no more information available regarding this warning message. I should point out that there are no other issues that I can detect. Games work without problem. Since I have never seen this before the update I had last night obviously this is related to one of the updated packages, but I am admittedly a bit at a loss to which one since yesterday's update involved 65 packages for me (and I do daily updates).

If this bug is only exists with PlayOnLinux is something I am uncertain about. I have not yet encountered any warning messages with any other apps.

I wonder if anyone else have encountered this issue.
Ronin DUSETTE Tuesday 7 May 2013 at 17:52
Ronin DUSETTE
Admin

Arch strikes again. haha.

I havent seen that at all. Im just about to run some updates on my system, so Ill see if maybe whatever package changed that, changes on mine too.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Smon Wednesday 8 May 2013 at 0:29
SmonAnonymous

Hey Daerandin,

the same here on arch.
When i start Virtualbox, it is the same:
Qt WARNING: libpng warning: iCCP: known incorrect sRGB profile

So i think a downgrade from libpng would help, but i have NOT tested it.
Ronin DUSETTE Wednesday 8 May 2013 at 1:24
Ronin DUSETTE
Admin

Ah. That is a little more clear of an answer. Has to be some recent update. I built a computer last night with xubuntu 12.04.2 LTS and installed POL without that error. I have to think its an arch repo issue.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Smon Wednesday 8 May 2013 at 7:59
SmonAnonymous

Yes, and see here: it changed 44 hours ago:
https://projects.archlinux.org/svntogit/packages.git/log/trunk?h=packages/libpng

I installed arch here yesterday (changed from debian sid), so i have no version 1.6.2-2 in my cache and can't test.
Daerandin Wednesday 8 May 2013 at 14:53
DaerandinAnonymous

I've been doing some googling, and it would appear that this is warning is a new feature of libpng 1.6.x as far as I can gather. I also got the same error message in when starting virtualbox from terminal and that message also mentioned libpng.

As far as I can figure out, the warning message does not actually mean that there is a bug. This forum topic touches on the subject:

http://www.imagemagick.org/discourse-server/viewtopic.php?f=2&t=23214

I have also seen the exact warning message mentioned on a couple of other forums with some googling. So in other words, this is no bug. Many distros use older versions of packages to ensure stability, and I expect xubuntu 12.04 LTS is using an older version.

So from what I can make of this, it is not a bug and there is no need to worry. It is just annoying.

Edit: I just read the libpng update changes, and it is indeed a new feature that it provides a warning about this. It is safe to ignore the warning message. I tried looking for a way to disable this warning but could find none so far. The way I understand it, a png with an incorrect RGB profile is the cause of this, I suspect the game icons could be the cause with PlayOnLinux. When I want to install anything new and start typing in the name for whatever game I might want to install, the warning pops up again as the list is populated by games that fit my search, and those have icons too.

Edited by Daerandin

Smon Thursday 9 May 2013 at 14:18
SmonAnonymous

Nice one! Thank you very much for the information.

A playonlinux comand line option --ignore-warnings or --dont-show-warnings or sth would be nice :>
Ronin DUSETTE Thursday 9 May 2013 at 17:57
Ronin DUSETTE
Admin

EDIT: Wrong thread. sorry. :)

Edited by RoninDusette


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
malevolent Friday 17 May 2013 at 10:29
malevolentAnonymous

Yes, another Arch here, suffering this annoying message... well, we'll wait until debian-based distros upgrade their libpng and this error appears on them. :)
Smon Friday 17 May 2013 at 19:26
SmonAnonymous

Yeah malevolent, wait a year ;)
xpander Saturday 18 May 2013 at 13:05
xpander

having the same error message.
its easy to downgrade with A.R.M. but it sucks to have old libraries :D
Alda Monday 27 May 2013 at 9:20
AldaAnonymous

I have the same problem since the upgrade to libpng16.

Here is the list of the faulty pngs:

`/usr/share/playonlinux/resources/images/configure/cmd.png'
`/usr/share/playonlinux/resources/images/configure/killall.png'
`/usr/share/playonlinux/resources/images/configure/regedit.png'
`/usr/share/playonlinux/resources/images/configure/taskmgr.png'
`/usr/share/playonlinux/resources/images/configure/wineboot.png'
`/usr/share/playonlinux/resources/images/configure/winecfg.png'
`/usr/share/playonlinux/resources/images/icones/virtual_drive_32.png'
`/usr/share/playonlinux/resources/images/icones/virtual_drive_64.png'
`/usr/share/playonlinux/resources/images/menu/virtual_drive_32.png'
`/usr/share/playonlinux/resources/images/menu/virtual_drive_64.png'
`/usr/share/playonlinux/resources/images/toolbar/48/stop.png'
`/usr/share/playonlinux/resources/images/toolbar/stop.png'

You can tell by running "identify $pol_png_file"


It'd be great if you could correct them as the warning will appear anywhere as soon as libpng16 gets propagated.



calvertvl Wednesday 26 June 2013 at 3:15
calvertvlAnonymous

I can confirm that this is the issue. I used GIMP to reassign the default sRGB profile (from some HP-provided profile that was embedded).


The steps to do this yourself are:
1. Open file in GIMP
2. Select Images->Mode->Assign profile
3. Click Assign.
4. File->Overwrite [image]
5. File->Close View

Keyboard shortcuts, for those who like them and are using GIMP defaults:
Ctrl+O,pick file, Meta+I,M,A,Meta+A,Meta+F,W,Ctrl+W,Meta+W.

imagemagick should be able to automate this via something like:
convert $file -strip $file
where of course $file is the filename of each image.

(edited to fix URL)

Edited by calvertvl

Smon Friday 28 June 2013 at 5:58
SmonAnonymous

Thank you!
One warning is gone.
I executed:
cd /usr/share/playonlinux/resources/
for i in `find . | grep png`; do convert "$i" -strip "$i"; done

But this warning is still remaining, any idea?
iCCP: known incorrect sRGB profile


Edit: Before my commands, there were 2 warnings

Edited by Smon

Deleted Please speak english
petch Friday 28 June 2013 at 19:18
petch
Developer

Thanks calvertyl, I updated the icons in the development branch.
The last icon (toolbar/48/stop.png) looks strange, but so does the original file, it must be a bug...
Smon Friday 28 June 2013 at 19:20
SmonAnonymous

Oh sorry, my fault, forgotten to speak english.

I executed IFS="
"
for i in `find . | grep png`; do convert "$i" -strip "$i"; done

in my .PlayOnLinux directory, it succesfully repairs some files, but it does not help and the error massage is again there.

The error massage appers in the tabs Games and office in the Installer section too, but it does not show affected files

I'm gone through all files in my playonlinux archive on arch and found, that this file:
/usr/share/playonlinux/etc/onglet/wine.png
is corrupted too, but fixing the file doesnt fix the error messages


justin8 Sunday 21 July 2013 at 6:18
justin8Anonymous

I was still getting the error message after stripping the files detailed in this thread. I also found /usr/share/playonlinux/etc/onglet/wine.png had a bad profile.

The easiest (short term) fix currently is:
(as root)
for i in `pacman -Qql playonlinux`
do
convert "$i" -strip "$i"
done

Ronin DUSETTE Sunday 21 July 2013 at 11:33
Ronin DUSETTE
Admin

Switch from Arch. :) lol. All I see is problems with Arch unless you are a Linux badass. Im pretty good with Linux, and after trying it for a day, I decided to go with distro that is put together by people smarter than I. hahaha

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
justin8 Sunday 21 July 2013 at 13:02
justin8Anonymous

That's the reason I can't use ubuntu; Too many packages altered from upstream to work with some weird issue the maintainer had, then I got pushed away from Debian because whenever a feature had issues, I had maintainers just disable the feature and close the bug.

The main issue with arch is you need to know how linux works, be willing to fix it when you do have an issue (which hasn't been any more often than I had with Ubuntu/Fedora in the past), and you end up with a system that can easily access the latest versions of upstream packages.

This issue hasn't hit a lot of other distros yet, but once they upgrade to the new libpng, they will be seeing the same issue.