The forum

Battle.net Client

Can't get it working

Author Replies
Jump to the page: 1 - 2
siflar Monday 11 November 2013 at 19:32
siflarAnonymous

I am relatively new to LInux, but thanks to this thread I was able to get Hearthstone running again finally! :D

I'm running into the same 2x sound issue though when I launch it. How do you limit pulseaudio to prevent the overdrive? I'm running Wine 1.6 on Ubuntu 12.04 LTS.
izberion Monday 11 November 2013 at 19:42
izberionAnonymous

Install cpulimit. It'll be in the Ubuntu repositories.

Open the terminal and enter: cpulimit -e pulseaudio -c 1 -l 10

"-c 1" tells it to limit to 1 core

"-l 10" tells it to limit to max 10%

That works well for my system but you might need to play with the numbers. And when you have this active, watch out for super high sound louds. It won't break anything, but it will cause your sound to get skippy.

By the way if you have any program with the fast audio/video it will help. I have to do this while watching Netflix though it takes some tweaking because of sync. With games I haven't noticed any sync problems yet.
siflar Monday 11 November 2013 at 19:58
siflarAnonymous

Yeah, I had the same problem with Netflix as well. Thank you very much for the quick reply!

I'll play with the numbers, and hopefully this will fix the Diablo 3 sound issues I was having too. Haha
izberion Monday 11 November 2013 at 20:24
izberionAnonymous

Good luck. By the way you can apply for the Heroes of the Storm beta now. It's not available yet though. And Blizzard's system reader that grabs your system details for your beta profile works perfectly through Wine, if you need to update your system details
vamphion Thursday 12 December 2013 at 6:15
vamphionAnonymous

Hey i am new to linux and just got the beta to hearthstone as well.(just got it)
i try to run the exe with wine but it starts up battle.net and then gives me a error.
Napkin Thursday 19 December 2013 at 8:40
Napkin

Seems like the overriding of dbghelp.dll to "disabled" no longer works. Also, at least for me, the installation of the old crypt32 as booman suggested earlier doesn't work.

Would it be possible to make a patched version of wine available via PlayOnLinux?

http://bugs.winehq.org/show_bug.cgi?id=33947

There is the patch to make battle.net work, it's been updated last on November 17th. For some reason it's still waiting to be applied.
Napkin Friday 20 December 2013 at 10:30
Napkin

Ok, I did finally manage to compile the beast with the patch suggested on WineHQ.

I can confirm that Battle.net no longer crashes. Also, the news inside the Battle.net Client are successfully loaded and shown now. Without the need to set dbghelp.dll to "disabled"!

I will request a patched Wine version for PlayOnLinux.

Until then, anyone impatient like me can try the deb package I've build:

https://develz.org/pol/wine-unstable_1.7.8-1_i386.deb

It needs all existing wine* and libwine-* packages to be removed from the system first. I haven't enforced any package dependencies. It will install everything to /usr/local/. In PlayOnLinux you need to configure the wineprefix to use the "System" Wine version.

Cheers!
Napkin Friday 20 December 2013 at 10:52
Napkin

booman Friday 20 December 2013 at 17:04
booman

Awesome, thanks for updating us. Try requesting a patched version of Wine at contact@playonlinux.com
They might patch it for you.

† Booman †
Mint 19.3 64-bit | Nvidia 450 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
killua99 Tuesday 28 January 2014 at 0:43
killua99Anonymous

Hi guys,

First thanks for this forum and you hard work on playonlinux :D

I'm trying to run the battle.net program but it's really hard. I see this patch is working.

http://bugs.winehq.org/show_bug.cgi?id=33947#c29

I was trying to read the docu to generate a wine version and add it to the "wine library" to select an extra one and not the system or other wine config. It's hard to make a compilation of wine with this patch? Thanks!