The forum

"There is nothing installed to run .php?id=143 files"

Protocol handler not handling protocol properly

Author Replies
apb1963 Tuesday 1 November 2016 at 20:35


First off, thank you for writing the software.  It looks beautiful.

I've never used POL before but it was recommended to me by the good folks in #ubuntu as a way to run Office 2000.  Unfortunately I have been unable to get it (Office) to work.   (ubuntu 16.04, Xenial)

I tried to install POL by downloading and installing it, but that it gave me an internal error, and no cd rom found after it spun up the drive.  I tried with the Office CD in the drive both mounted and unmounted.

Then #ubuntu told me to install this package,

and so I installed "playonlinux 4.2.6-1 (amd64 binary) in ubuntu xenial".

Then I was told to go to but when I tried to install from that page it generated this message "Firefox doesn’t know how to open this address, because one of the following protocols (playonlinux) isn’t associated with any program or is not allowed in this context."

So I used the directions from here and specifically the info for "Firefox 3.5 and above"


  • Type about:config into the Location Bar (address bar) and press Enter.
  • Right-click -> New -> Boolean -> Name: network.protocol-handler.expose.playonlinux -> Value -> false

But when I tried to repeat the above MS Office install, it gives me "There is nothing installed to run .php?id=143 files". 

I then tried:

gconftool-2 -s /desktop/gnome/url-handlers/playonlinux/command '/usr/bin/playonlinux %s' --type String
gconftool-2 -s /desktop/gnome/url-handlers/playonlinux/enabled --type Boolean true

But still no joy.  Thank you in advance for your help.

apb1963 Wednesday 2 November 2016 at 6:39

I just noticed that Office 2000 is here:


which is highly coincidental in regard to the ".php?id=143" portion of the error message.  I don't know if that helps you help me.