The forum

Change application language of PoL itself

Author Replies
anyb Wednesday 7 November 2018 at 22:31
anybAnonymous

This may sound stupid, but how can I change the application language of PoL itself?

In my case, the language of PoL differs from the system language.

Tutul Friday 9 November 2018 at 14:56
Tutul
Moderator

What's the language in POL ?


Gentils modérateur dans mes bon jours - Attention, à tenir hors de portée des enfants. En cas de contact, veuillez immédiatement rincer à l'eau clair. Peut provoquer des sueurs froide !
anyb Thursday 15 November 2018 at 7:11
anybAnonymous

PoL is in German.
Tutul Thursday 15 November 2018 at 14:29
Tutul
Moderator

And what's your system language ? You're probably having one of your system settings set in German


Gentils modérateur dans mes bon jours - Attention, à tenir hors de portée des enfants. En cas de contact, veuillez immédiatement rincer à l'eau clair. Peut provoquer des sueurs froide !
anyb Thursday 15 November 2018 at 18:22
anybAnonymous

In fact, the only installed language is English, though I use German for regional formats such as time and paper format as well as the keyboard layout. But to my knowledge those settings should not affect the application language? PoL is the only program where this problem occurs.
Tutul Friday 16 November 2018 at 13:52
Tutul
Moderator

Probably one of the LANG settings that POL read and shouldn't use. I'll see what I can do


Gentils modérateur dans mes bon jours - Attention, à tenir hors de portée des enfants. En cas de contact, veuillez immédiatement rincer à l'eau clair. Peut provoquer des sueurs froide !
anyb Friday 16 November 2018 at 20:18
anybAnonymous

That is terrific, thank you very much!
Tutul Sunday 18 November 2018 at 13:39
Tutul
Moderator

can you show me the result of :

locale -a

Gentils modérateur dans mes bon jours - Attention, à tenir hors de portée des enfants. En cas de contact, veuillez immédiatement rincer à l'eau clair. Peut provoquer des sueurs froide !
anyb Tuesday 20 November 2018 at 8:15
anybAnonymous

$ locale -a
C
C.UTF-8
de_DE.utf8
en_AG
en_AG.utf8
en_AU.utf8
en_BW.utf8
en_CA.utf8
en_DK.utf8
en_GB.utf8
en_HK.utf8
en_IE.utf8
en_IL
en_IL.utf8
en_IN
en_IN.utf8
en_NG
en_NG.utf8
en_NZ.utf8
en_PH.utf8
en_SG.utf8
en_US.utf8
en_ZA.utf8
en_ZM
en_ZM.utf8
en_ZW.utf8
POSIX
Tutul Tuesday 20 November 2018 at 17:43
Tutul
Moderator

Sorry I send you the wrong command ^^"

locale

without the -a then


Gentils modérateur dans mes bon jours - Attention, à tenir hors de portée des enfants. En cas de contact, veuillez immédiatement rincer à l'eau clair. Peut provoquer des sueurs froide !
anyb Wednesday 21 November 2018 at 15:15
anybAnonymous

No problem.

$ locale
LANG=en_US.UTF-8
LANGUAGE=en_US
LC_CTYPE="de_DE.UTF-8"
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY="de_DE.UTF-8"
LC_MESSAGES="de_DE.UTF-8"
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"
LC_ALL=de_DE.UTF-8
Tutul Wednesday 21 November 2018 at 20:53
Tutul
Moderator

I think we use LC_ALL... Need to check that


Gentils modérateur dans mes bon jours - Attention, à tenir hors de portée des enfants. En cas de contact, veuillez immédiatement rincer à l'eau clair. Peut provoquer des sueurs froide !
anyb Thursday 22 November 2018 at 6:43
anybAnonymous

I think you are correct. I just set LC_ALL=en_US.UTF-8 and PoL started in English. I don't know the precise meaning of the locales, but in terms of language maybe LANG should be used instead?
Tutul Thursday 22 November 2018 at 14:22
Tutul
Moderator

yea, LC_ALL is used for troubleshooting but override all the other. I'm not sure if POL use LANG, but detect anr respect the override. I'll see that with the team


Gentils modérateur dans mes bon jours - Attention, à tenir hors de portée des enfants. En cas de contact, veuillez immédiatement rincer à l'eau clair. Peut provoquer des sueurs froide !
anyb Friday 23 November 2018 at 7:56
anybAnonymous

Thank you very much!

The workaround would be to start PoL using a bash script:

#!/bin/bash
LC_ALL=en_US.UTF-8
playonlinux
Tutul Saturday 24 November 2018 at 15:47
Tutul
Moderator

After further reading, I'm not sure LC_ALL should be set to something. On my system, it's blank so I'm not sure why yours is set


Gentils modérateur dans mes bon jours - Attention, à tenir hors de portée des enfants. En cas de contact, veuillez immédiatement rincer à l'eau clair. Peut provoquer des sueurs froide !
anyb Monday 26 November 2018 at 20:38
anybAnonymous

According to https://help.ubuntu.com/community/Locale, LC_ALL overrides individual LC_* settings, it is probably just a short way to define the other LC_* settings.

It should not conflict with LANG, however.
Tutul Tuesday 27 November 2018 at 0:34
Tutul
Moderator

LANG is just the default value for LC_*

so if LC_ALL is set, it override all LC_* value (LANG is just here to put his value in unspecified LC_* )


Gentils modérateur dans mes bon jours - Attention, à tenir hors de portée des enfants. En cas de contact, veuillez immédiatement rincer à l'eau clair. Peut provoquer des sueurs froide !