The forum

fixed SWTOR script needs 4.12.1

Author Replies
Korianne Thursday 8 August 2019 at 0:24
KorianneAnonymous

In PlayOnMac, window "Manage Wine Versions" the last available versions I find are 4.3 or 4.11.

The last fixed script requires wine 4.12.1 and obviously it stops saying POM can't find wine 4.12.1. Am I doing something wrong?

Dadu042 Thursday 8 August 2019 at 16:37
Dadu042
Moderator

What is your PlayOnMac version ?

Korianne Friday 9 August 2019 at 3:11
KorianneAnonymous

version 4.3.4, the last one available. I already tried redownloading and installing a fresh app, to no difference.

Dadu042 Friday 9 August 2019 at 11:21
Dadu042
Moderator

I don't know on PlayOnMac 4.3.4 what is the latest Wine version available.

 

In your case, you may copy  the script from its web page then copy it into a text file ".POL", then edit it and change the Wine version, save it, then use it manually from POM (menu Tools -> Run a local script).

Edited by Dadu042

Korianne Friday 9 August 2019 at 22:19
KorianneAnonymous

Tried using up to 4.11 (most recent wine version POM can find), and also have tried every time deleting the install directory first, to have a fresh start, but apparenty it doesn't work still.

At first, the wizard would stop at choosing language for the installation - the script instructs to open a window to choose, and what I got was instead a window with "Choose language" and then blank slate. I made a modification to skip that issue by commenting out the lines in the script, and set just lang=en-US from the start.

######################
# Language selection #
######################

#POL_SetupWindow_menu "Choose a language:" "$TITLE" "English|Français|Deutsch" "|"
#if [ "$APP_ANSWER" = "English" ]; then
    lang="en-us"
#elif [ "$APP_ANSWER" = "Français" ]; then
#    lang="fr-fr"
#elif [ "$APP_ANSWER" = "Deutsch" ]; then
#    lang="de-de"
#fi

At this point it proceeds, lets me run the installer but stops immediately after, saying the xml is corrupt (?) and it can't find launcher.exe.

N.B. I installed the game in VirtualPC from the very same installer exe, so I don't think it can be its fault.

I suspect it might very well be an issue with the wine version, yet I don't know what else to try. Is there a way for me to install a 4.12.1 manually?

Dadu042 Friday 9 August 2019 at 23:39
Dadu042
Moderator

> Is there a way for me to install a 4.12.1 manually?

 

No, until it appear in the POM's list.

Korianne Saturday 10 August 2019 at 0:12
KorianneAnonymous

Ah, well, I'll wait then, hopefully it will happen at some point. Thank you for your help!

Dadu042 Wednesday 14 August 2019 at 17:47
Dadu042
Moderator

FYI, build status is there : https://www.playonlinux.com/wine/

Edited by Dadu042

Ayris Thursday 5 September 2019 at 20:25
AyrisAnonymous

I'm also trying to play SWTOR and running into the same issue. I don't understand why it requires 4.12.1 if it's not even available?

Dadu042 Friday 6 September 2019 at 23:23
Dadu042
Moderator

Because the last person that updated the script did not think/test about OSX users, or thought (like me) that the 4.12.1 release would come fast.

Dadu042 Saturday 7 September 2019 at 12:02
Dadu042
Moderator

I downgraded the script to Wine 4.11, and made some little changes.