The forum

GTA1 (gtawin) Multiplayer - Ubuntu 22.04 - crashes at TCP-IP Create Session

Author Replies
evild4ve Saturday 7 January 2023 at 3:59

I'd be most grateful for any help, but also to write down where I have got up to in trying to get this game to work multiplayer.

I've only been able to get anywhere with gtawin, and after long trial-and-error I believe I've got the game to detect the network hardware properly. But something else is crashing to a black screen when it passes the hardware detection and tries to open the Create Session screen.

"Join Game" brings up a Windows default-style window requesting an IP address.

The same crash happens on gta_uk and gta61


POL 4.3.4
Wine Staging 6-10
Windows XP
Winetricks: MFC42, directplay, microsoft core fonts, vbrun6
DLL overrides: default ones + mss32, wdir16, wdir32, pmpro16, pmpro32, smackw32

Router: UPnP off. Virtual Servers (aka Port Forwards) at 2300-2400, 11155, 47624 (tcp+udp)
Iptables ACCEPT and ufw ALLOW the same ports

Must run settings.exe

Seeing as the Join Game search prompt leaves the game's style and reverts to that of the OS, I wondered if the Create Session screen used an unusual window style, or some graphical effect. I tried to find out on Youtube what it's meant to look like but couldn't find anything.

But in the terminal there is an audio error:-

[POL_Wine] Message: Running wine-6.10-staging gtawin.exe (Working directory : /home/dave/.PlayOnLinux/wineprefix/GTA1/drive_c/GTA1/gtawin)
[POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See
ALSA lib conf.c:4002:(snd_config_hooks_call) Cannot open shared library (/usr/lib/i386-linux-gnu/alsa-lib/ cannot open shared object file: No such file or directory)
ALSA lib seq.c:935:(snd_seq_open_noupdate) Unknown SEQ default

So I tried to set sfx and music both to "Off" in the options before starting multiplayer, but this didn't work.

sudo apt-get install libasound2-plugins:i386

This reduced the error to:-

[POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See

But I see this all the time and doubt it matters. Unless the broken Create Session page needs some part of windows that winemenubuilder is equivalent to...

The web address given in POL's error is a 404. Can't find anything on google. So at this point I'm stuck


Edited by evild4ve

This site allows content generated by members, and we promptly remove any content that infringes copyright according to our Terms of Service. To report copyright infringement, please send a notice to