The forum

Diablo 3 - Infinite Update Loop

Game Is & Isn't Up-to-Date :s

Author Replies
throne777 Friday 1 June 2012 at 14:27

Game launches into the log-in screen and a dialog box says that there's an update to install, so quits and takes me back to the launcher. However, the launcher says that the game is up-to-date. If I click play it then takes me back to the log in screen which says that there's an update available, and so on ad infinitum.
Any ideas?
Running Arch x64.
rychlis Saturday 2 June 2012 at 3:43

Got the same problem :(

Tried to install using both EU and US installers from scratch (I'm in EU) and even copied the whole installation from windows partition (it works without problems in windows), always the same problem happens.

Arch x64

Edited by rychlis

nightmarebadger Saturday 2 June 2012 at 9:21

Well, probably doesn't help you much, but it's working for me right now.

But I did have this problem before, and it was when patches hit - while EU servers were down I tried to login into US ones and I got the "need to update the game" but when I clicked okay and it went back to launcher, it said my game is up to date.
My guess is it happened because US was already on 1.2a (or whatever) and EU was still updating - and since I had an EU account/launcher, I didn't get the update yet.

Is it working now?
nightmarebadger Saturday 2 June 2012 at 9:55

Also, I remembered seeing something on the US D3 forums, so I dug it up.

You could try this

And there is an extra thread dedicated to problems on updates it seems:

Hope it helps!
rychlis Saturday 2 June 2012 at 12:51

I've gone through logfiles and finally found what was amiss.
I was missing lib32-libldap library, after installing it Diablo 3 works!
throne777 Thursday 7 June 2012 at 15:49

Yay, installed lib32-libldap and now it runs perfectly. Thanks!
aurelienbis Tuesday 12 June 2012 at 22:09

The problem is here again. Can you tell me how to install lib32-libldap ?
thrillerbee Wednesday 13 June 2012 at 0:54

aurelienbis: depends on your OS, but there is likely a lib32-libldap package... What are you using?
quincyfreal Wednesday 13 June 2012 at 4:25

Mine is doing the same thing, runs game just fine, go to login then says there is a patch available and exits immediately back to the launcher. Launcher says that it is up to date, but same thing keeps happening... I'm running Ubuntu 12.04 LTS (Precise Pangolin)
aurelienbis Wednesday 13 June 2012 at 23:53

In fact, it is the same thing at every patch update. We are doing update on US server, and his maintenance is one day before EUR. So for one day we can only play on US server.
throne777 Wednesday 5 June 2013 at 18:27

Just a quick note, I managed to solve this issue when it reared its head again (running Crunchbang x64).
sudo apt-get install ia32-libs
Ronin DUSETTE Wednesday 5 June 2013 at 20:02

If people were posting all computer specs and debug output like required, this would have been marked as solved last year. Haha :-)

Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts

This site allows content generated by members, and we promptly remove any content that infringes copyright according to our Terms of Service. To report copyright infringement, please send a notice to