El Foro

Age of Empires II: Conquerors -- installed but won't run

Install okay, then can't find cd-rom

Autor Respuestas
sfmatheson Saturday 18 January 2014 at 18:18
sfmathesonAnonymous

I'm running Playonmac (Wine 1.6) on a Mac running Mavericks. Installation of AoK seemed to go fine (off my legit cd versions), ditto for installation of Conquerors and the patch. But when I try to run the game, with CD in the drive, message says that program can't find cd and doesn't start.

Is Playonmac assuming I don't have the CD? Can I tweak the script to tell it what to do? Thanks for any help, glad to provide more info.
petch Saturday 18 January 2014 at 18:25
petch
Developer

According to the AppDB you may need a no-cd patch to run this game.
By policy we provide no support in this matter though.

The install script may lack a warning about that, I'll have to see with the script author.
sfmatheson Saturday 18 January 2014 at 18:48
sfmathesonAnonymous

Oh, ack, I thought that was something optional. I'll look into the patch but would love it if the script could be tweaked for those who have the CD.
sfmatheson Saturday 18 January 2014 at 18:59
sfmathesonAnonymous

So the AppDB page says this: "(you can play using aocsetup.exe from the cd, if you can’t afford to NoCD)".

I'd be so happy if someone could point me to how to do that!
petch Saturday 18 January 2014 at 19:11
petch
Developer

In the comments there's also a suggestion to copy "game\sound" folder to the installation...
sfmatheson Saturday 18 January 2014 at 21:31
sfmathesonAnonymous

Well, got things working with the nocd patch but now can't pass keystrokes to the game. I suppose this might be an xquartz issue but frustrating. Mouse works fine.
fekir Saturday 18 January 2014 at 23:20
fekirAnonymous

@sfmatheson:
Hi, petch wrote me a private message asking if I knew if you need a NO-CD patch.

I'm sorry to say that my PC does not have a CD drive, so I'm not able to tell if the game works also with a physical CD, and I'll also not be able to verify if copying the "game\sound" folder helps (never heard of that suggestion before).

I was going to update all the scripts for installing AoE (new wine version, some minor fixes, official and unofficial updates and so on). Before updating the scripts I'll be posting them on the forum, and I could also add the feature to copy the "game\sound", maybe you can test it and confirm if it makes it possible to play with the CD or not, I hope it'll not be too late for you.

Beware: I'm not using Mac OS, I hope that the scripts work for you without any problems/modifications.
sfmatheson Saturday 18 January 2014 at 23:23
sfmathesonAnonymous

Hi fekir, thanks for the message. I have sound, got to the initial screen (in xquartz) but can't enter keystrokes so can't make a user so can't play. So close!

I'm playing with ubuntu in a vmware virtual machine right now but would be glad to test-drive anything you have.

Not sure my problem is with your script or playonmac, we'll see.
sfmatheson Saturday 18 January 2014 at 23:56
sfmathesonAnonymous

btw, I haven't tried copying the game\sound folder but that doesn't seem worthwhile since the folder and all its files are already in the installation. not sure why that came up unless I'm missing something.
sfmatheson Sunday 19 January 2014 at 0:04
sfmathesonAnonymous

btw, I haven't tried copying the game\sound folder but that doesn't seem worthwhile since the folder and all its files are already in the installation. not sure why that came up unless I'm missing something.
fekir Sunday 19 January 2014 at 9:29
fekirAnonymous

Could it be thath you have to configure on wine your cd drive?

Try the option under (sorry, I don't have the software in english, so the names could be wrong):
Configure -> Wine -> Configure Wine
and search for: Drive Configuration

Maybe you CD drive is not configured at all, and from here you can simply add it.

Edit:

I've checked tha game/sound folder, they are there in my installation directory, but they do not have inside all the mp3 files that are on the CD.
Maybe it could really help.

Editado por: fekir

sfmatheson Monday 20 January 2014 at 20:41
sfmathesonAnonymous

Hi fekir, again thanks for the suggestions. It's a shame the game doesn't work in playonmac, not sure what's up but it won't accept keystrokes to enter a username so can't play.

I can get the game running in ubuntu in a VMware virtual machine but it's just too slow. Maybe copying the mp3 files will make a difference there but I kinda doubt it. Seems an issue with wine or with xquartz