El Foro

Guild wars se fige au lancement

Autor Respuestas
Electro-X Saturday 23 February 2008 at 23:05
Electro-XAnonymous

Bonjour
Lorsque je lance la jeu Guild wars le petit écran de téléchargement de mise a jour se lance parfaitement mais une fois fini et la ou le jeu devrais normalement se lancer, l'application plante.
Je suis sous Fedora 8 et j'ai une carte ATI avec les derniers pilotes d'installé et j'utilise la version 2.0.9 de playonlinux que j'ai installé avec le rpm trouvé sur ce site qui fonctionne parfaitement.
J'ai tenté de lancé Guilds wars avec les version suivante de wine :
- 0.9.30
- 0.9.32
- 0.9.33
- 0.9.38
- 0.9.42
- 0.9.43
- 0.9.46
- 0.9.55
mais a chaque fois Guild wars ne se lance pas mais mon pointeur devient comme celui du jeu.
En revanche quelque fois pour la version 0.9.32 où la au bout de 15 second une cinematique se lance mais vraiment au relanti (environ une image toute les 5 second).
J'ai éssayé de le lancer en désactivant le par-feu et SElinux mais toujours le même resultat.
J'éspére avoir était clair dans mes explication.
J'attend avec impatience vos reponse et suggestion.
Merci de m'avoir accordé un peu de votre temps.

Editado por: Electro-X

Aymeric P. Sunday 24 February 2008 at 8:44
Aymeric P.
Admin

Salut,
Ton problème vient a 99.9% des pilotes graphiques ATI qui sont trop récent ... (merci ATI)
Les derniers utilisable pour GW sont les 8.40.4 disponible là : http://ati.amd.com/support/drivers/linux/radeonprevious-linux.html

Il faut que tu desinstalle les nouveaux, puis que tu installe les ancien.

Former member.
Electro-X Sunday 24 February 2008 at 9:56
Electro-XAnonymous

Merci MulX
Comme tu me la conseillé j'ai désinstallé mes pilote ATi puis installé les 8.40.4, j'ai ensuite fait aticonfig --initial -f mais mintenant lorsque je lance playionlinux il me dit que l'acceleration 3D n'est pas activé.
Comment puis-je faire pour activer l'accélaration 3D??
Ou si vous avez un tuto pour installe les pilot 8.40.4 sur fedora 8 (ou une autre istrib) sa m'aiderais. merci

Editado por: Electro-X

Aymeric P. Monday 25 February 2008 at 9:01
Aymeric P.
Admin

Ah ça c'est des vrais pilotes ATI ! chez moi défois je passe 10 heures a faire des manips pour arriver a mettre c'est *#~?!$ de pilote en état ...
Enfin bref, poste le contenu du fichier xorg.conf (/etc/X11/xorg.conf) L'idéal serait que tu envoie le fichier sur un site pour ne pas surcharger le forum, mais à défaut poste le ici
Et le résultat de la commande :
grep -e "EE" -e "WW" /var/log/Xorg.0.log -n

Former member.
Electro-X Monday 25 February 2008 at 9:57
Electro-XAnonymous

ok alors pour mon xorg.conf voici le lien :
http://electroftp.free.fr/xorg.conf
Sinon voici se que me rne renvoi la command que tu ma indiqué :
$ grep -e "EE" -e "WW" /var/log/Xorg.0.log -n
14: (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
23WW) The core pointer device wasn't specified explicitly in the layout.
238II) Loading extension MIT-SCREEN-SAVER
313WW) fglrx: No matching Device section for instance (BusID PCI:1:0:1) found
456WW) fglrx(0): Failed to open DRM connection
459WW) fglrx(0): board is an unknown third party board, chipset is supported
510WW) fglrx(0): Only one display is connnected,so single mode is enabled
666WW) fglrx(0): No DRM connection for driver fglrx.
724EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized.
725WW) fglrx(0): ***********************************************
726WW) fglrx(0): * DRI initialization failed! *
727WW) fglrx(0): * (maybe driver kernel module missing or bad) *
728WW) fglrx(0): * 2D acceleraton available (MMIO) *
729WW) fglrx(0): * no 3D acceleration available *
730WW) fglrx(0): ********************************************* *
751WW) fglrx(0): Option "VendorName" is not used
752WW) fglrx(0): Option "ModelName" is not used
794WW) <default pointer>: No Device specified, looking for one...


De plus avec la ommand fglrxinfo il me renvoi les info du pilote libre au lieu de ceux du pilote proprio que j'ai installé :
$ fglrxinfo
Xlib: extension "XFree86-DRI" missing on display ":0.0".
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.4 (2.1 Mesa 7.0.2)

Voila j'éspére que cela pourra t'aider a trouver une solution, merci pour ta patience.

Editado por: Electro-X

Aymeric P. Wednesday 27 February 2008 at 10:25
Aymeric P.
Admin

Well tu as donc un problème avec le module drm
Il doit y avoir un fichier qui contient les modules a charger au démarrage, comme je n'ai pas F8 je ne sais pas où c'est, sur Ubuntu c'est dans /etc/modules.
En rajoutant a cette liste, drm et fglrx (drm avant fglrx important) ça devrait peut être passer.

Dans ton fichier xorg.conf il faut aussi que dans la section Modules tu rajoute

Load "glx"
Load "dri"

Il y aussi dans le xorg.conf AIGLX & Composite a désactiver (tu ne pouras plus avoir Compiz & co mais ça c'est de la faute a ATI)

Un site qui peut t'interesser : http://wiki.cchtml.com/index.php/Troubleshooting

PS : A 98% tu as vers la ligne 458 du fichier Xorg0.log des ligne comme ceci :
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is -1, (No such device or address)
drmOpenDevice: open result is -1, (No such device or address)
drmOpenDevice: Open failed

Editado por: MulX


Former member.