El Foro

Centos7 Install

Dependencies

Autor Respuestas
anxo Wednesday 10 September 2014 at 1:37
anxoAnonymous

Just put a fresh install of Centos7 down and got the following when I tried to do a yum install. A little confused since I thought POL is just a front end for wine and wxPython is already installed when I try to (re)install. Has anyone seen this before?

--> Finished Dependency Resolution
Error: Package: playonlinux-4.2.5-fedora0.noarch (playonlinux)
           Requires: wxPython
Error: Package: playonlinux-4.2.5-fedora0.noarch (playonlinux)
           Requires: p7zip-plugins
Error: Package: playonlinux-4.2.5-fedora0.noarch (playonlinux)
           Requires: wine
Error: Package: playonlinux-4.2.5-fedora0.noarch (playonlinux)
           Requires: p7zip
Error: Package: playonlinux-4.2.5-fedora0.noarch (playonlinux)
           Requires: cabextract

TIA,

anxo

Ronin DUSETTE Wednesday 10 September 2014 at 6:39
Ronin DUSETTE
Admin

Is it in your PATH? Also, is the rest installed, as well? It seems to be missing a lot. POL will for sure need those, so just make sure that you have them installed, and it should be good. As for wxPython, it should be in your path. If you open a Python shell and try to import wx does it throw an error?


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
anxo Thursday 11 September 2014 at 21:58
anxoAnonymous

Thanks for the reply! Noob here when it comes to this so I am running down all your suggestions. Thanks a lot.

Ronin DUSETTE Friday 12 September 2014 at 3:10
Ronin DUSETTE
Admin

For sure. I am sure if you resolve those dependencies (make sure they are the 32 bit versions), and make sure that anything python-related is in your PATH, everything should jive just fine. 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Ueliton Sunday 6 September 2015 at 21:06
Ueliton

Dependencies for Playonlinux on CentOS 7 x86_64:

$ sudo wget -O /etc/yum.repos.d/playonlinux.repo http://rpm.playonlinux.com/playonlinux.repo

$ sudo yum install -y wine wxPython cabextract SDL.i686 p7zip-plugins p7zip ImageMagick libXaw xterm mesa-dri-drivers.i686 mesa-libGL.i686 libGLEW.i686 mesa-libGLU.i686 nc

$ sudo yum install -y playonlinux

Run the wineconfig and confirm the installation of mono and gecko.

Now just run PlayOnLinux ignoring the error message in openGL:

$ playonlinux

Editado por: Ueliton


Antix Linux
Memória: 3.5 GiB
Processador: Intel® Celeron(R) CPU 847 @ 1.10GHz × 2
OS Type: 32-bit
Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics driver: i915
OpenGL: renderer: Mesa DRI Intel Sandybridge Mobile x86/MMX/SSE2 v: 3.3 Mesa 13.0.6
Space-icewm
Disco: 454,8 GB
schotty Sunday 13 September 2015 at 2:43
schotty

This is what I have been using for some time now to get things working on EL7 installations (Lately mostly RHEL7).  Perhaps there is something here that you missed.

 

http://www.schotty.com/wordpress/?page_id=57

january Saturday 10 March 2018 at 12:04
januaryAnonymous

I had same problem.

i just do this

yum install epel-release

 

I want that this can be helped