El Foro

problem with civ 4

Plaiyonlinux 4.3.4

Autor Respuestas
hackcoeur Thursday 6 June 2019 at 17:54
hackcoeurAnonymous

Hello,

I installed without problem the civilization 4 complete edition.
But at startup it crashes and leaves me this message.
I am under linux mint 19 LMDE, wine 17.5.5, I tried to pass in wine 4.9 but still the same problem

06/06/19 17:44:39] - Running wine-1.7.55 Civ4BeyondSword.exe (Working directory : /home/pannen/.PlayOnLinux/wineprefix/Civilization4/drive_c/Program Files/2K Games/Firaxis Games/Sid Meier's Civilizat[06/06/19 17:44:43] - Running wine-1.7.55 Civ4BeyondSword.exe (Working directory : /home/pannen/.PlayOnLinux/wineprefix/Civilization4/drive_c/Program Files/2K Games/Firaxis Games/Sid Meier's Civilizatp11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/p11-kit-trust.so: /usr/lib/i386-linux-gnu/pkcs11/p11-kit-trust.so: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier dep11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: Ne peut ouvrir le fichier d'objet partagé: Aucun fichierwine: configuration in '/home/pannen/.PlayOnLinux//wineprefix/Civilization4' has been updated.
fixme:system:SystemParametersInfoW Unimplemented action: 55 (SPI_SETMOUSEKEYS)
fixme:system:SystemParametersInfoW Unimplemented action: 59 (SPI_SETSTICKYKEYS)
libGL error: unable to load driver: i965_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: i965
libGL error: unable to load driver: i965_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: i965
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  155 (GLX)
  Minor opcode of failed request:  3 (X_GLXCreateContext)
  Value in failed request:  0x0
  Serial number of failed request:  945
  Current serial number in output stream:  949

 

What is the solution, thanks for your help

 

Pascal

OliverS Sunday 4 August 2019 at 20:07
OliverSAnonymous

 

Hello,

I installed without problem the civilization 4 complete edition.
But at startup it crashes and leaves me this message.
I am under linux mint 19 LMDE, wine 17.5.5, I tried to pass in wine 4.9 but still the same problem

06/06/19 17:44:39] - Running wine-1.7.55 Civ4BeyondSword.exe (Working directory : /home/pannen/.PlayOnLinux/wineprefix/Civilization4/drive_c/Program Files/2K Games/Firaxis Games/Sid Meier's Civilizat[06/06/19 17:44:43] - Running wine-1.7.55 Civ4BeyondSword.exe (Working directory : /home/pannen/.PlayOnLinux/wineprefix/Civilization4/drive_c/Program Files/2K Games/Firaxis Games/Sid Meier's Civilizatp11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/p11-kit-trust.so: /usr/lib/i386-linux-gnu/pkcs11/p11-kit-trust.so: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier dep11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: Ne peut ouvrir le fichier d'objet partagé: Aucun fichierwine: configuration in '/home/pannen/.PlayOnLinux//wineprefix/Civilization4' has been updated.
fixme:system:SystemParametersInfoW Unimplemented action: 55 (SPI_SETMOUSEKEYS)
fixme:system:SystemParametersInfoW Unimplemented action: 59 (SPI_SETSTICKYKEYS)
libGL error: unable to load driver: i965_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: i965
libGL error: unable to load driver: i965_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: i965
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  155 (GLX)
  Minor opcode of failed request:  3 (X_GLXCreateContext)
  Value in failed request:  0x0
  Serial number of failed request:  945
  Current serial number in output stream:  949

 

What is the solution, thanks for your help

 

Pascal

 

Facing same issue here too. Help is appreciated.

Thanks in advance.
Regards,

Oliver 


Dadu042 Sunday 4 August 2019 at 22:30
Dadu042
Moderator

More log would be welcome:

http://wiki.playonlinux.com/index.php/How_to_Post_in_the_Forums  "What information is needed in my post?"

 

Sometimes useful: http://wiki.playonlinux.com/index.php/How_to_Read_Debug_Logs