El Foro

Adobe Dreamweaver CS4


Autor Respuestas
ljmellor Tuesday 17 November 2009 at 9:41

Hi, I was wondering if anybody is interested in making a script for the Adobe CS4 collection (or already has)?

I know that these things are installable under wine, I've done it myself following one of the many tutorials available out there. I simply do not have any scripting skills in order to produce these scripts myself.

Anyone up for the challenge?

Better still, anyone up for the challenge of helping me to produce these scripts?

marieuh Tuesday 17 November 2009 at 10:31


if you go there http://www.playonlinux.com/en/page-2-Documentation.html you'll find all you need to begin scripting.
Once you've read the documentation and understand the workings of a script, you can give it a shot and then post it on the forum. I'm sure our star scriptor would be glad to help by pointing out where it needs improvement.
good luck :)

If there is a problem, fill out complaint form and place it in an envelope addressed to the name of the hospital in which you were born....
ljmellor Tuesday 17 November 2009 at 12:17

I decided to start with the Dreamweaver 8 Script and edit it down from there...

Here's what I evetually wound up with...
#Is playonlinux running?
if [ "$PLAYONLINUX" = "" ]
exit 0
#Load & Check dependencies
source "$PLAYONLINUX/lib/sources"

#Cleaning temp directory:
rm *.*

if [ "$POL_LANG" == "fr" ]; then
INSTALL="En attente de l'installation de Dreamweaver CS4..."
FINISH="Dreamweaver CS4 à été installé avec succes."
FILELOCATION="Veuillez selectionner le fichier .exe d'installation."
INSTALL="Installing Dreamweaver CS4..."
FINISH="Dreamweaver CS4 has been sucessfully installed."
FILELOCATION="Please select the .exe installation file."

#Script Begins Here

POL_SetupWindow_Init "" ""

#Setup Window
POL_SetupWindow_presentation "Adobe Dreamweaver CS4" "Adobe" "http://www.adobe.com/products/dreamweaver/?promoid=BPDEC" "ljmellor" "DWCS4"

#select wine version for install...
POL_SetupWindow_install_wine "1.1.17"
Use_WineVersion "1.1.17"

#Create Install Directory
select_prefix "$HOME/.PlayOnLinux/wineprefix/DWCS4/"

mkdir -p $REPERTOIRE/tmp/DWCS4
wget http://www.kegel.com/wine/winetricks -P $TEMPDIR
bash $TEMPDIR/winetricks msxml6 gdiplus gecko vcrun2005 ie6

#Install Dreamweaver CS4
POL_SetupWindow_browse "$FILELOCATION" "Dreamweaver CS4" 
POL_SetupWindow_wait_next_signal "$INSTALL" "Dreamweaver CS4"
wine "$FILE"

#select wine version for running...
POL_SetupWindow_install_wine "1.1.22"
Set_WineVersion_Assign "1.1.22" "DWCS4" 

#cleaning the folder of the temporary files
rm -r $TEMPDIR

POL_SetupWindow_make_shortcut "DWCS4" "Program Files/Adobe/Adobe Dreamweaver CS4/" "Dreamweaver.exe" "" "DWCS4"

POL_SetupWindow_message "$FINISH" "Dreamweaver CS4"

Editado por: ljmellor

ljmellor Tuesday 17 November 2009 at 12:23

the steps I wish for the script to take are as follows...

*install wine 1.1.17
*winetricks install msxml6 gdiplus gecko vcrun2005 ie6
*start "wine setup.exe" via your terminal from within your installation directory
*ignore the terminal error message spam
*after successfull installation upgrade wine to 1.1.22
marieuh Tuesday 17 November 2009 at 12:57

I'm not much of a scriptor myself but i don't understand why you need to install a certain verrsion of wine and upgrade it afterwords... what can be fdone is use the wine version tool to apply a certain version of wine to a certain program. (not sure it helps, NSLW should be able to help you more when he comes around)

If there is a problem, fill out complaint form and place it in an envelope addressed to the name of the hospital in which you were born....
ljmellor Tuesday 17 November 2009 at 13:07

The installer doesn't work in anything newer than 1.1.17, if you leave that version installed afterwards then there is a bug with the menus sticking around permanently rather than disappearing, hence the required upgrade after install. I have edited my original post with my latest happenings, this script can't be far from completion as far as I can see besides the fact that it doesn't actually run the .exe at present.

Once this is done then adapting it to photoshop cs4 and the master collection should be a sinch :)
NSLW Tuesday 17 November 2009 at 19:12

wine "$FILE"
instead of
wine $FILE

or you've got alternative

Browse file which is on your desktop.

BTW. What's that?

TEMPDIR="$REPERTOIRE/tmp/DWCS4"wget http://www.kegel.com/wine/winetricks -P $TEMPDIR
ljmellor Thursday 19 November 2009 at 18:12

That my friend was a typo, I've put the line break in now, thanks for the help so far, I'll update again soon, got a busy work schedule on this week so progress will be in bits and bobs.
ljmellor Monday 23 November 2009 at 2:58

There we go, worked for me :D>

Consider this one complete.

How do I go about having it added to the official ones once somebody else has tested it?
ljmellor Saturday 20 March 2010 at 10:29

I don't seem to be able to run my own script anymore, has something changed in POL?
NSLW Saturday 20 March 2010 at 10:53

Nothing changed. Please post terminal output after running playonlinux from terminal and then running your script.
ljmellor Saturday 20 March 2010 at 11:06

this seems to be the most relevant part to me, however I cannot seem to get the permissions correct...

/home/luke/.PlayOnLinux/tmp/DWCS4/winetricks: line 26: /home/luke/.PlayOnLinux/WineVersions/1.1.17/usr/bin/wine: Permission denied
ljmellor Saturday 20 March 2010 at 14:26

sorted it, bad settings within my fstab, all is working again.
trusktr Thursday 2 September 2010 at 12:41

I tried this script for Premiere CS4 and it seemed to work. When I launch Premiere, it goes to the Activation screen, and once i get past that window, then nothing happens! Premiere doesn't start. Any idea why this might be?
trusktr Thursday 2 September 2010 at 13:05

Hmmm, I just tried it for After Effects CS4 and it gave me an error like this:

Perhaps my installer is messed up. I'm going to try to acquire a new installer and see what happens.
dmcwebd Monday 29 November 2010 at 10:54

I managed to install dwcs4 but i cant start it.. any ideas?