El Foro


The script can't download a DLL

Autor Respuestas
abelthorne Tuesday 24 August 2010 at 15:26

I've reported a problem related to the Starcraft (first game, from 1998) script on the french forum but I've been told to report it here because the script author seems to be NSLW (forum admin I guess).

I've installed Starcraft on Windows and tried to run it through Wine using a custom prefix (I usually prefer to make my own scripts and launchers than using POL) and discovered that it runs really slow. Browing through the tests on AppDB, I saw that the slowness comes from the game using GDI to display graphics and it was advised to set OpenGL rendering through the register.
Unfortunately, when setting OpenGL, I get a blank screen (the game works, as I can click on the unseen options, I hear the music...).
I also saw some old report from users that said that installing the game with POL fixed their slowness problem. But I'm not sure if it's because of some options POL sets during install or simply because it sets OpenGL instead of GDI generally?

So, I tried to install it with POL but the script is broken: it tries to download a DLL (ddraw.dll) from archive-host.com and the link is dead. BTW, you should fix this, as the game isn't installable with the current script (it just stops at the "downloading DLL" step).

As I have no clue as to why it tries to download a copy of ddraw.dll, can someone tell me what is the purpose of this lib? In the script, it's said that it's a "Battle.net patch" but in what way? I'd think a problem with Battle.net would be related to some network lib, not a graphic one. Is it a hacked DLL that is supposed to fix general graphic issues or is it really related only to Battle.net problems?
If it's a specific lib, is there a working link out there? I've tried the regular ddraw.dll from dll-files.com with no change to my problem (which might be related to graphic drivers).

If it's of any help, I use Ubuntu 10.04 with Wine 1.2 (from the dedicated PPA repo). My graphic card is a bit old (nVidia GeForce FX 5200) and the lastest drivers don't seem to support this GPU anymore (I'm using drivers v. 173 from the Ubuntu repos).

EDIT: it seems someone reported a similar problem not long ago (http://www.playonlinux.com/en/topic-3700-Following_file_is_no_longer_available_on_server_ddrawdll_Why.html). Didn't see it before posting, sorry.
Anyway, my questions are still relevant. ;)

Editado por: abelthorne

Aymeric P. Wednesday 25 August 2010 at 12:47
Aymeric P.

Other post GNU_Raziel say that it's solved, if not reopen.

Former member.
abelthorne Wednesday 25 August 2010 at 14:58

Ok. Just to sum up for people that would check this subject : the POL script is fixed but the ddraw.dll didn't fix my problem (so I guess it comes from my graphic drivers).
Estas Aqui: Index > PlayOnLinux > Starcraft