El Foro

Bioshock can't find CD during install

Autor Respuestas
seanj Monday 21 March 2011 at 11:21

Hi, I am trying to install Bioshock from my disc with PlayOnLinux 3.8.12 on Ubuntu 10.10 32-bit. Everything starts fine until the installer tries to download a patch from online, then pops up a window saying CD not inserted. I hit cancel and the installation fails, leaving a bunch of files behind but no Bioshock.exe. What can I do?
GNU_Raziel Monday 21 March 2011 at 17:36

Oh my...this bug is back again...

Ok, until I make a "fix" in PoL installer, you can proceed like this :
1- When it hang at online patch, open a terminal
2- Use the following command :
mv "$HOME/.PlayOnLinux/wineprefix/bioshock/drive_c/Program Files/2k Games/Bioshock" "$HOME/.PlayOnLinux/wineprefix/bioshock/drive_c/Program Files/2k Games/Bioshock_save"
3- Let the game installer "cancel" the installation
4- Revert now the previous command :
mv "$HOME/.PlayOnLinux/wineprefix/bioshock/drive_c/Program Files/2k Games/Bioshock_save" "$HOME/.PlayOnLinux/wineprefix/bioshock/drive_c/Program Files/2k Games/Bioshock"
5- Let PoL installer continu it's work.
6- Use the PoL installer for Bioshock Patch to properly patch the game.

Note : the command path may not be 100% accurate, adapt it to you installation path of course.

Editado por: GNU_Raziel

seanj Monday 18 April 2011 at 22:03

Thanks GNU_Raziel. I have followed your instructions, but the patcher stays at 0%, even after being left hours. Not sure what to do now.
seanj Monday 18 April 2011 at 22:34

I spoke too soon. Even though the patcher gave no feedback, the game did get patched. It is however unplayable due to constant hitching and stuttering. Thanks very much for the help, though.
seanj Monday 16 May 2011 at 13:12

I'm very confused now. I had to re-install my system. If I run Bioshock with regular Wine, it just grinds the hard disk forever and doesn't start. If I run it through PlayOnLinux, it runs. When trying to apply the 1.1 patch through PlayOnLinux, neither of the two options (download or install from local file) work. Downloading works up until actually running the patcher, which just freezes and does nothing. Trying my local copy crashes as soon as I start the patching process. I better dig up my win xp cd I think.
maxwelldeaton Wednesday 12 October 2011 at 1:03

I am having the same problem and I did exactly what you described here. The patch said it installed successfully (with only one hitch, it said it could not find "old file", i accepted and it continued with no problems. not sure if that means anything.) So after the patch installed I reopened playonlinux and attempted to Run Bioshock. At this point terminal says -

Running Bioshock
wine: cannot find ' '

If you could help me that would be great!
maxwelldeaton Friday 21 October 2011 at 20:05

Thanks for all your help douches

This site allows content generated by members, and we promptly remove any content that infringes copyright according to our Terms of Service. To report copyright infringement, please send a notice to dmca-notice@playonlinux.com