El Foro

Bioshock install issues

Autor Respuestas
mikey Wednesday 11 May 2011 at 14:25


I've just attempted to install Bioshock using playonlinux 3.8.8-1 for ubuntu 11.04. The install encountered the same "No CDROM/DVD detected" issue as in this thread. I followed the work around but running the 1.1 patch from playonlinux hung in the same way as for the first poster, however after this process I did not have a Bioshock.exe and the
~/.PlayOnLinux/configurations/installed/Bioshock script was broken. It had:

wine "" -nointro $@

as it's launcher. So out of desperation I tried copying the Bioshock.exe from another install I had made under wine. Surprisingly it ran and ran reasonably well with this. Although it was not patched to 1.1. It tried patching it to 1.1 again using playonlinux and it failed to do anything again. I upgraded playonlinux to 3.8.12 and tried to patch again and got the same results.

I also found that the red fog issue was still a problem with my NVidia card (8600 GT) and wine 1.3.10-64b (also on latest 1.3.19) despite saying it's been fixed since wine 1.3.2. The fix did however work.

My ~/.PlayOnLinux/configurations/installed/Bioshock script now look like this (and is probably complete garbage):

export WINEPREFIX="/home/USERNAME/.PlayOnLinux/wineprefix/bioshock"
export WINEDEBUG="-all"
cd "/home/USERNAME/.PlayOnLinux/wineprefix/bioshock/drive_c/Program Files/2K Games/BioShock/Builds/Release"
nice -19 wine ./Bioshock.exe -nointro $@

Just thought I would share my experiences. Let me know if you have any thoughts.
GNU_Raziel Wednesday 11 May 2011 at 16:07

I will fix PoL installer and patch for this game as soon as possible, I must find my game disk first, lost in the darkness of my celling...

Thx for the report...Feel free to fix it yourself if you want by upgrading current installer and post it on the forum :)
mikey Wednesday 11 May 2011 at 17:08

Are there any tutorials on writing installers? I would suggest removing the 1.1 patch step from the vanilla install as it appears to be incompatible with the Red Fog fix for NVidia cards. The patch itself seems to need to be run from within the C:\\Program Files\\2K Games\\Bioshock\\Builds\\Release\\ folder (or whatever it is).

Also apparently you're only allowed 5 installs of Bioshock before it wont install again. Using the uninstall apparently increases the count again. So it may be an idea to actually run the uninstall rather then just removing the bioshock wineprefix. I think I've probably lost one install this way.
GNU_Raziel Wednesday 11 May 2011 at 20:47

The "5 installs" thing was removed a while ago by 2k if I'm not mistaken so no need to worry about that.

You do not have to rewrite the PoL installer from scratch, just modify the actual version to fix problems. To check PoL current mandatory rules, use this thread.

The DVD installer automatically patch the game after installer, it's impossible to disable it so you have to deal with it, using the "fix" I provided in a previous thread.

I will try to fix it this next WE if I can find my disk and have time to do it.
mikey Wednesday 11 May 2011 at 21:49

Ok, thanks. I'll have a look. That's really weird. As I installed it first time by hand in wine just by running the install of the DVD and it didn't try to patch it... weird.
seanj Monday 13 June 2011 at 7:40

Weeks later this still doesn't seem to work. I gave up and installed XP. Maybe PlayOnLinux is only really suited to software developers and technicians. I don't have the patience or the brain power to keep up.

This site allows content generated by members, and we promptly remove any content that infringes copyright according to our Terms of Service. To report copyright infringement, please send a notice to dmca-notice@playonlinux.com