El Foro

[Test] How to install League of Legends

It works!

Autor Respuestas
Jump to the page: 1 - 2
kevin1534 Friday 13 April 2012 at 14:01

I don't know if I'm posting this in the correct sub forum so please move it if it's in the wrong place.

I recently installed League of Legends successfully on PlayOnMac.
Since I don't know how to write a script, I thought I would share what I did to make it work.

First of all I downloaded the Wine version 1.3.17-LeagueOfLegends by clicking Tools > Manage Wine versions.
Then I went into the manual installation by clicking "Install a non-listed program" on the Install window.
I selected all 3 checkboxes; "Use another version of wine", "Configure wine", "Install some libraries".
When I had to select which Wine version to use, I selected 1.3.17-LeagueOfLegends.
When I had to configure Wine, I changed the operating system to Windows 7.
When I had to install some libraries, I installed:

POL_Install_directx9 (But I don't think this is required)

Then I downloaded the appropriate file;
North America:
Europe West:
Europe Nordic and East:

And I used that file as the installer for League of Legends.
So far, my game is applying patches so I haven't been able to test how/if it works, but it should work unless there's something wrong with AdobeAir (since the game uses Air to create the game windows).

I hope this can help someone!

Editado por: kevin1534

Tr0n0s Saturday 14 April 2012 at 19:55

Testing in PlayOnLinux...
vord Wednesday 18 April 2012 at 22:40

Confirmed that the steps for installation work in PlayOnLinux on Linux Mint 12, using latest PlayOnLinux.

Still awaiting patching to test ingame.

I don't know anything about POL scripts yet, but I feel the one here could be adapted to work: http://www.playonlinux.com/repository/?script=781

A final POL script should definitely include server selection.

Editado por: vord

vord Thursday 19 April 2012 at 3:02

So far, can install and patch, but can't login. This was with 1.3.26-LeagueOfLegends.

EDIT: Seems to be stuck on "Retrieving data from server"

May be this issue, investigating.


Editado por: vord

vord Thursday 19 April 2012 at 17:48

Here is initial code for a custom script, which covers everything above.

So far, I can patch and get to login screen, still working out how to log in and play a game. Could use some guidance, since I am very new to PoL. Would be very interested in becoming a tester to get LoL to supported status.
# Date : (2012-04-19 11-20)
# Last revision : (2012-04-19 11-20)
# Wine version used : 1.3.17-LeagueOfLegends
# Distribution used to test : Linux Mint 12
# Author : Vord
# Script licence : GPLv3
# PlayOnLinux and PlayOnMac Init
[ "$PLAYONLINUX" = "" ] && exit 0
source "$PLAYONLINUX/lib/sources"
# Variables
TITLE="League Of Legends"
# Starting Window API
# Starting debugging API

POL_SetupWindow_presentation "$TITLE" "Riot Games" "http://www.leagueoflegends.com" "Vord" "$PREFIX"

# Prompt for Server
POL_SetupWindow_menu "Region to Install" "Pick your region" "North America|Europe East (and Nordic)|Europe West" "|"

if [ "$APP_ANSWER" = "North America" ]then
elif [ "$APP_ANSWER" = "Europe East (and Nordic)" ]
elif [ "$APP_ANSWER" = "Europe West" ]

POL_SetupWindow_message "Downloading and configuring\\nLeague Of Legends specific Wine instance." "$TITLE"

POL_SetupWindow_install_wine "1.3.17-LeagueOfLegends"
Use_WineVersion "1.3.17-LeagueOfLegends"
POL_Debug_Message "Selecting prefix : $REPERTOIRE/wineprefix/$PREFIX"
select_prefix "$REPERTOIRE/wineprefix/$PREFIX"
POL_Debug_Message "Creating prefix (wineboot)"


POL_Debug_Message "Installing packages : vcrun2005 ie6 d3dx9 adobeair wininet wintrust"
#Used in old script...don't think is needed
#POL_Winetricks -q vcrun2005 ie6 d3dx9 adobeair

POL_Call POL_Install_vcrun2005
POL_Call POL_Install_ie6
POL_Call POL_Install_AdobeAir
POL_Call POL_Install_d3dx9
POL_Call POL_Install_wininet
POL_Call POL_Install_wintrust

#Attempting reboot here
wine reboot

POL_SetupWindow_textbox "Please download the following, if you have not already\\nSelect the downloaded EXE for the next step" "$TITLE" "$DOWNLOAD_URI"
POL_SetupWindow_browse "Please select the downloaded file" "Install file selection" "$HOME/Downloads/$EXE_STR"
POL_SetupWindow_message "Make sure to uncheck 'Run League Of Legends'\\n at end of install." "$TITLE"

POL_Debug_message "Creating shortcut ($TITLE) lol.launcher.exe"

# Custom shortcut for this issue (http://appdb.winehq.org/objectManager.php?sClass=version&iId=19141&iTestingId=70298)
#POL_SetupWindow_make_shortcut "$PREFIX" "c/Riot Games/League of Legends/RADS/system" "rads_user_kernel.exe" "c/Riot Games/League of Legends/lol.launcher.exe" "$TITLE" "" "run lol_launcher ../../LoLLauncher.exe"
POL_SetupWindow_auto_shortcut "$PREFIX" "lol.launcher.exe" "$TITLE"
POL_Debug_message "Setting patched wine version to $TITLE"
Set_WineVersion_Assign "1.3.17-LeagueOfLegends" "$TITLE"
POL_SetupWindow_message "League Of Legends installation is finished." "$TITLE"

Editado por: vord

vord Thursday 19 April 2012 at 17:57

Trying to get this running using a PoL shortcut, since this seems to resolve the issue I'm noticing with login on Linux. Could use some help, as I am only a beginner.

export WINEPREFIX="$HOME/.wine-lol"
cd "$WINEPREFIX/drive_c/Riot Games/League of Legends/rads/system"
wine "rads_user_kernel.exe" run lol_launcher $(ls ../projects/lol_launcher/releases/) LoLLauncher.exe

Editado por: vord

malevolent Saturday 19 May 2012 at 16:36

Did you resolve the login problem? In my case, I can install through PoL 4.0.19 test script, but I cannot login...
FullMetal48 Wednesday 6 June 2012 at 13:42

I got a wine crash when i log in. At the second try i succeed in log in =). But when i try a game in trainning (just for a test), i have no sound...is it normal?
PSyCHoHaMSTeRza Monday 13 August 2012 at 17:55

I got a wine crash when i log in. At the second try i succeed in log in =). But when i try a game in trainning (just for a test), i have no sound...is it normal?

Quote from FullMetal48

Run the game in borderless mode instead of full screen. Worked for me.
petch Monday 13 August 2012 at 18:26

Why not use existing script?
Install PlayOnLinux 4.1.x, then
Install button > Check "In testing" checkbox > Games > League of Legends
faith42o Tuesday 21 August 2012 at 9:41

Works perfect thanks i could not get it to work in 64bit I downloaded 32bit and it worked perfect
monstroz Saturday 20 October 2012 at 18:27

Im using fedora 17 and i installed the test version of the game ,but i get this wine error when i try to run it. I installed all the libraries and if someone can help or if someoned runed the game on fedora 17 i would apriciate the help. (:
jackofspades Wednesday 2 January 2013 at 17:03

Why not use existing script?
Install PlayOnLinux 4.1.x, then
Install button > Check "In testing" checkbox > Games > League of Legends

Quote from petch

Using the given script install correctly the game, but an unsuspected issue have appeared, I can't select Brazil server since it's not shown in the region selection.

I tried to modify locale.conf, launcher and system.cfg to show the option but still that seems not to be effective.

any possible help ?

zecarlo Thursday 3 January 2013 at 18:14

Same problem, but I still can't login here. The script above but some names/paths must have changed, instead I used the following to run it:

export WINEPREFIX="$HOME/.PlayOnLinux/wineprefix/LeagueOfLegends"
export WINE="$HOME/.PlayOnLinux/wine/linux-x86/1.5.18-LeagueOfLegends"
cd "$WINEPREFIX/drive_c/Riot Games/League of Legends/RADS/system"
${WINE}/bin/wine "rads_user_kernel.exe" run lol_launcher $(ls ../projects/lol_launcher/releases/ | tail -n 1) LoLLauncher.exe

But again, the login problem is not fixed by it ...
benjisp94 Monday 3 June 2013 at 22:59

did anyone find a solution for the Brazil server issue?
petch Monday 3 June 2013 at 23:28

You can try this script that uses the official downloader:

It has its own share of issues, but it should allow you to select the brazilian server.
benjisp94 Tuesday 4 June 2013 at 0:03

im sorry... could you show me how to add a script?...
petch Tuesday 4 June 2013 at 0:04

Save it in your computer, then, in PlayOnLinux menus,

    Tools > Run a local script

You'll get a warning that it's not signed, this is to be expected since it doesn't come from the official repository.

Editado por: petch

benjisp94 Tuesday 4 June 2013 at 0:11

thanks!!! i'm sorry i have one more question... is there any way to add Latin America?
Deleted dupe message