Het forum

wrong path, programs cannot start

Auteur Antwoorden
Anubis Vrijdag 25 Januari 2008 om 19:04
Anubis

anubis@linux-pc:~> /usr/share/playonlinux/playonlinux --run "Notepad++"

PlayOnLinux v2.0
----------------
Checking python : [ Ok ]
Notepad++: line 4: cd: /home/anubis/.PlayOnLinux/wineprefix/NotepadPlusPlus//drive_c/Program Files/Notepad++: No such file or directory
wine: could not load L"c:\\windows\\system32\
otepad++.exe": Module not found


that's normal because the path is NOT

/home/anubis/.PlayOnLinux/wineprefix/NotepadPlusPlus//drive_c/Program Files/Notepad++

but

/home/anubis/.PlayOnLinux/wineprefix/NotepadPlusPlus/drive_c/Programmi/Notepad++

anubis@linux-pc:~/.PlayOnLinux/wineprefix/NotepadPlusPlus/drive_c> ls
Programmi windows
anubis@linux-pc:~/.PlayOnLinux/wineprefix/NotepadPlusPlus/drive_c> cd Programmi
anubis@linux-pc:~/.PlayOnLinux/wineprefix/NotepadPlusPlus/drive_c/Programmi> ls
Common Files Internet Explorer Notepad++
anubis@linux-pc:~/.PlayOnLinux/wineprefix/NotepadPlusPlus/drive_c/Programmi> cd Notepad++
anubis@linux-pc:~/.PlayOnLinux/wineprefix/NotepadPlusPlus/drive_c/Programmi/Notepad++> ls
change.log langs.xml nativeLang.xml plugins SciLexer.dll uninstall.exe
config.xml license.txt notepad++.exe QuickText.ini shortcuts.xml
contextMenu.xml LINEDRAW.TTF nppcm.dll readme.txt stylers.xml

Aangepast door Anubis

Quentin PÂRIS Vrijdag 25 Januari 2008 om 19:25
Quentin PÂRIS
Admin

What version of wine are you using ?

(You are not in the right section)
Anubis Zaterdag 26 Januari 2008 om 13:20
Anubis

why wrong section... it looks like a bug or not?

anyway.... 0.9.53
goku Zaterdag 26 Januari 2008 om 13:43
goku

I think you have to edit the script launching notepad++ ( $HOME/.PlayOnLinux/configurations/installed/Notepad++ )


You have just to change the direction of the directory opened
cd "/home/user/.PlayOnLinux/wineprefix/NotepadPlusPlus//drive_c/Program Files/Notepad++"
become:
cd "/home/user/.PlayOnLinux/wineprefix/NotepadPlusPlus//drive_c/Programmi/Notepad++"

Windows de Microsoft.

Mac de Apple.

Linux du monde entier.
Quentin PÂRIS Zaterdag 26 Januari 2008 om 14:34
Quentin PÂRIS
Admin

I think it is because you have an Italien version of wine. In french or in english, it is "Program Files"
Anubis Zaterdag 26 Januari 2008 om 19:29
Anubis

I think you have to edit the script launching notepad++ ( $HOME/.PlayOnLinux/configurations/installed/Notepad++ )


You have just to change the direction of the directory opened
cd "/home/user/.PlayOnLinux/wineprefix/NotepadPlusPlus//drive_c/Program Files/Notepad++"
become:
cd "/home/user/.PlayOnLinux/wineprefix/NotepadPlusPlus//drive_c/Programmi/Notepad++"

Quote from goku


infact..works
hasi Zaterdag 26 Januari 2008 om 22:27
hasiAnonymous

By the way, why are there two slashes between "NotepadPlusPlus" and "drive_c"?
gnud Vrijdag 1 Februari 2008 om 5:40
gnudAnonymous

I have this same problem, because Wine respects my systems locale settings and playonlinux does not. This prevents the launcher from working, and also breaks some install scripts.

PlayOnLinux really needs a way to specify paths like "Program Files" and "Application Data" (on my computer, the names are "Programfiler" and "Fellesfiler".

I suggest that you scrape the system.reg file in a shell file that gets .source'd by all install scripts:
PROGRAMFILES="drive_c$(grep -e \"ProgramFiles\" system.reg|tr -d \"|tr = /|cut -d/ -f2 -|cut -d: -f2)"

This will give a relative path like "drive_c\\Program Files"






juancarlospaco Donderdag 22 Mei 2008 om 23:05
juancarlospacoAnonymous

Hi, im from Argentina, sorry for my english...

i have the same problem installing M$ Office 2003 Spanish Version,
POL keep searching " Program Files " but the CD install it in " Archivos de Programa ".

A Script could correct this problems...? sounds easy.
thanks for all...
GNU_Raziel Vrijdag 23 Mei 2008 om 8:45
GNU_Raziel

we will work on a solution as soon as possible, stay tuned
meloves Zaterdag 24 Mei 2008 om 20:12
melovesAnonymous

It should be marked as SOLVED.
juancarlospaco Zaterdag 24 Mei 2008 om 21:07
juancarlospacoAnonymous

Thanks a lot, this is REAL support.
VeauX Woensdag 9 Juli 2008 om 6:46
VeauXAnonymous

Same issue here. I have a spanish version of openSuse. programs install themselves in the ARCHIVOS DE PROGRAMA directory and the scrip calls PROGRAM FILES

Play on linux version 3.something .. sorry the about button don't work
OpenSuse 11 x86_64
wine 1.1.0
game Diablo 2 installed yesterday.(game works changing directory names)
meloves Woensdag 9 Juli 2008 om 21:23
melovesAnonymous

I second that: "I think you have to edit the script launching notepad++ ( $HOME/.PlayOnLinux/configurations/installed/Notepad++ ) "

VeauX, you should try the same thing.

Go to $HOME/.PlayOnLinux/configurations/installed/ folder and edit your scripts (i.e. change Program files to Archivos de programa).

SOLVED
Any questions, PM me.
VeauX Donderdag 10 Juli 2008 om 1:20
VeauXAnonymous

No issue I did that and it worked like a charm. Just mentioning this as a bug because it should simply not happen... doing it each time I install somehting new is not the solution of that bug, just a countermeasure. The root cause is not solved.
Quentin PÂRIS Zondag 14 December 2008 om 16:20
Quentin PÂRIS
Admin

Since PlayOnLinux 3.1, this problem is solved.