Het forum

AMD HD5870 64-bit driver installed, but need 32-bit to play

AND Failed to initialise DirectX, need to reinstall it.

Auteur Antwoorden
en.code Zondag 31 Maart 2013 om 22:57
en.codeAnonymous

Hi,

i'm working on Debian, here I got playonlinux installed, 3D openGL Support (tested with superTux :D in openGL mode).

I want to play SC2 again here (some days ago I had 32bit installed, there everything worked fine). Today I installed Debian64bit, now I receive after installation, that I have to reinstall directx again (after clicking on start). I think this can be due to a message that appears after starting gameonlinux: "64bit openGL driver install, but need 32bit".

Here my problem is that I cannot select 64bit AMD driver installation, cause the Catalyst driver automatically selects the 64bit driver.

Any ideas for my 2 Problems/ or perhaps, it is the same :D
Thanx mates!


petch Zondag 31 Maart 2013 om 23:18
petch
Developer

32bit libraries can be installed along with 64bit ones and the 64bit driver.
(and "3D OpenGL" is sort of rendundant ;) )
en.code Maandag 1 April 2013 om 0:51
en.codeAnonymous

Of course I can, but how can I do this?

The amd linux driver gives me no choice of 32/64bit. It installs the 64bit version direclty.

If you mean only the opengl lib, what is the exact name of the file I have to install via apt?

Aangepast door en.code

petch Maandag 1 April 2013 om 1:00
petch
Developer

OpenGL is the API implemented by many different libraries, and when we say "32bit OpenGL library", like in the warning, it means anyone of them, not a library that would be called "opengl".
I don't know how you can install the AMD 32bit libraries on 64bit systems, I thought Catalyst installed both automatically...
Ronin DUSETTE Maandag 1 April 2013 om 19:36
Ronin DUSETTE
Admin

I don't know how you can install the AMD 32bit libraries on 64bit systems, I thought Catalyst installed both automatically...

Citeer


Last time that I installed ATI drivers, it gave me a choice to install the libraries with it during the install, though, that was last year, so installing CCC might have changed.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts