Het forum

windows program Bankroller not working need 2.0 NET

Auteur Antwoorden
ntggg Woensdag 29 Mei 2013 om 13:57
ntgggAnonymous

Dear Playonmac community,

i have encoutnered a problem with a program called bankroller. I am pretty new to using a windows program on a mac and sorry for maybe not describing it as effiencently as possible. 
I installed metatrader which works fine, then i wanted to install bankroller, which didnt work. i looked up in the debug report that said: 


after installing "mono 28" pushing the configure button on the bankroller application

it still doesnt open the app. now it says that :

err:mscoree:expect_no_runtimes Process exited with a Mono runtime loaded.

[05/29/13 13:53:20] - Running wine- Bankroller.exe (Working directory : /Users/nickfu/Library/PlayOnMac/wineprefix/Bankroller_/drive_c/Program Files/Bankroller)



Unhandled Exception: System.TypeInitializationException: An exception was thrown by the type initializer for <Module> ---> System.DllNotFoundException: msvcm90.dll



  at (wrapper managed-to-native) <Module>:<CrtImplementationDetails>.ThrowModuleLoadException (string,System.Exception)



  at <Module>.<CrtImplementationDetails>.LanguageSupport.Initialize (<CrtImplementationDetails>.LanguageSupport* ) [0x00000] in <filename unknown>:0 



  at <Module>..cctor () [0x00000] in <filename unknown>:0 



  --- End of inner exception stack trace ---


err:mscoree:expect_no_runtimes Process exited with a Mono runtime loaded.



I am using a mac with :
10.8.3 mountain lion



thank you in advance your help. It would be so awesome if I could use that program on my mac. thanks guys

regards, 


Ronin DUSETTE Woensdag 29 Mei 2013 om 17:50
Ronin DUSETTE
Admin

Install vcrun2008 in Install Components.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
ntggg Donderdag 30 Mei 2013 om 23:46
ntgggAnonymous

thank you for your post, but i still cant open it

now the debug report says:
[05/30/13 23:42:41] - ----- Ending function POL_Install_vcrun2008 -----
[05/30/13 23:42:54] - Running wine- Bankroller.exe (Working directory : /Users/nickfu/Library/PlayOnMac/wineprefix/Bankroller_/drive_c/Program Files/Bankroller)
wine: Install Mono for Windows to run .NET 2.0 applications.
[05/30/13 23:43:01] - Running wine- Bankroller.exe (Working directory : /Users/nickfu/Library/PlayOnMac/wineprefix/Bankroller_/drive_c/Program Files/Bankroller)
wine: Install Mono for Windows to run .NET 2.0 applications.
[05/30/13 23:43:36] - ----- Starting function POL_Install_mono28 -----
[05/30/13 23:43:37] - Running wine- start /unix mono-2.8-gtksharp-2.12.10-win32-9.exe /silent (Working directory : /Users/nickfu/Library/PlayOnMac/ressources/mono28)
fixme:msg:ChangeWindowMessageFilter c046 00000001
fixme:win:DisableProcessWindowsGhosting : stub
fixme:sfc:SfcIsFileProtected (0x0, L"C:\\\\Program Files\\\\Mono-2.8\\\\unins000.exe") stub
fixme:system:SetProcessDPIAware stub!
[05/30/13 23:44:19] - ----- Ending function POL_Install_mono28 -----
[05/30/13 23:44:29] - Running wine- Bankroller.exe (Working directory : /Users/nickfu/Library/PlayOnMac/wineprefix/Bankroller_/drive_c/Program Files/Bankroller)
implement type compare for 1b!

[05/30/13 23:44:36] - Running wine- Bankroller.exe (Working directory : /Users/nickfu/Library/PlayOnMac/wineprefix/Bankroller_/drive_c/Program Files/Bankroller)
implement type compare for 1b!

err:mscoree:expect_no_runtimes Process exited with a Mono runtime loaded.
Ronin DUSETTE Vrijdag 31 Mei 2013 om 17:58
Ronin DUSETTE
Admin

You may need to install regular .NET 2.0 in a fresh virtual drive, along with vcrun2008 and try again. MONO can usually handle 2.0, though.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
ntggg Zondag 2 Juni\ 2013 om 2:48
ntgggAnonymous

thnaks again for your reply... i now reinstalled bankroller in a fresh virtual drive along with vcrun2008 and regular net 2.0 into that drive as well... not it opens but there is a new error something with net2.0 had to close down due ...

i just found out that bankroller needs :
Microsoft .NET Framework 2.0
Sicherheitsupdate für Microsoft Visual C++ 2005 Service Pack 1 Redistributable Package ATL
Microsoft Visual C++ 2005 SP 1 Redistributable Package (x86)

is that the reason it is not working ???

thank you... if it still doesnt work,thank you for your efforts... but maybe you know which of the install components may be there ? in playonmac ?
Ronin DUSETTE Zondag 2 Juni\ 2013 om 8:22
Ronin DUSETTE
Admin

try vcrun2005

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts