Het forum

Diablo 3 not working with fglrx drivers

Auteur Antwoorden
pwkpete Donderdag 13 Maart 2014 om 21:50
pwkpeteAnonymous

Hi All,

I had D3 running on Mint 15 and 16 now with the stock xorg-ati driver. I have tried 2 video cards: HD 5450 (1G) and R7 240 (2G)

The stock fglrx drivers that come with mint 15/16 support the 5450, but not the R7 so I installed those from the ATI site - both release and beta versions - all same result with respect to behavior of D3 running on PoL/Wine - Images on Battlenet loader are flickering and oddly tiled - odd crashes d3d issues when the game does actually fire up.

I verified the driver installed correctly.

Running HDMI - sound over HDMI set up - everything else works as normal.

Other than that both drivers seems to work fine. I searched for solutions but am at a loss here.

Update - switch back to the distro fglrx driver and found the right spot on the screen to click to run and it finally worked. No idea why it ran this time. Mouse pointer in game has no texture and the items I hover over (chests and monsters get pixelated) but other than that it works...

Perhaps the reinstall with the xorg driver worked in a way that left the game sane and then switching the driver under the covers did it... I can't make any sense of it so wouldn't call it solved...

Do wonder why the grfx are a little munged...

Aangepast door pwkpete

This site allows content generated by members, and we promptly remove any content that infringes copyright according to our Terms of Service. To report copyright infringement, please send a notice to dmca-notice@playonlinux.com