Het forum

Problem with using amd64 wines (League Of Legends)

Auteur Antwoorden
flatl3y Woensdag 27 Augustus 2014 om 1:37
flatl3yAnonymous

Hello! I installed a fresh 14.04 and tried to play with LoL but I came across with this issue. The game started properly,it was okay but I only got like 40 fps on medium settings so I downloaded the proper Ati Catalyst,rebooted the system and the game no longer worked correctly. Everything is ok until the actual game launches,after that nothing happens for like a minute and then I get a bug splat error message. I figured out what causes the problem,I need to use a different version of the Wine with Catalyst installed. So I tried to download an amd64 version of 1.7.19-LeagueOfLegends2 but somehow I cant actually select amd64 ones,it only lists x86 versions. This is my first time using Ubuntu so I literally have no clue for basically anything,for the most part I just read a lot or watch tutorial videos but couldn't find an anserw for this so I'd appriciate your help!

petch Woensdag 27 Augustus 2014 om 12:43
petch
Developer

You cannot change the architecture used for a Wine virtual drive once created, this is a Wine constraint.

You shouldn't have to change Wine version though, I'm not sure what made you think you do.

 

Aangepast door petch

flatl3y Woensdag 27 Augustus 2014 om 13:16
flatl3yAnonymous

Well I just kinda guessed because before I installed the driver it was working. 

Aangepast door flatl3y

flatl3y Vrijdag 29 Augustus 2014 om 14:58
flatl3yAnonymous

Since then I reinstalled the os,got the drivers,installed POL,from POL got LOL,the client starts but the game isn't,after about 30 seconds I get a bugsplat error and that's it.I'm using the basic configutration.I'havent changed anything with Wine. I really have no idea what is wrong so please help.

petch Vrijdag 29 Augustus 2014 om 19:35
petch
Developer

Currently League of Legends no longer works, see the other users' comments in

http://www.playonlinux.com/en/app-1135-League_Of_Legends.html