Het forum

PlayOnMac Keeps Crashing

"PlayOnMac has encountered a fatal error, and will now terminate."

Auteur Antwoorden
meaner6788 Maandag 22 December 2014 om 1:36
meaner6788Anonymous

Every time I try to open PlayOnMac I get a pop-up that reads, "PlayOnMac has encountered a fatal error, and will now terminate." 

How should I go about trying to fix this? I even tried an earlier version of PlayOnMac and it still doesn't work. 

OS X Yosemite

Processor: 1.4 GHz Intel Core i5

Ronin DUSETTE Maandag 22 December 2014 om 3:54
Ronin DUSETTE
Admin

Run playonmac from a terminal and post the output. It should say why it is not running. 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
meaner6788 Maandag 22 December 2014 om 4:02
meaner6788Anonymous

This is what I get from the Terminal, (iTerm):

/Library/Internet\ Plug-Ins/Unity\ Web\ Player.plugin/Contents/Frameworks/PlayOnMac.app/Contents/MacOS/playonmac; exit;
2014-12-21 21:01:34.337 defaults[34630:486345]
The domain/default pair of (/Users/549040/Library/Preferences/com.apple.dock, loc) does not exist
bash: /Library/Internet: No such file or directory
Traceback (most recent call last):
  File "/Library/Internet Plug-Ins/Unity Web Player.plugin/Contents/Frameworks/PlayOnMac.app/Contents/Resources/__boot__.py", line 137, in <module>
    _run('mainwindow.py')
  File "/Library/Internet Plug-Ins/Unity Web Player.plugin/Contents/Frameworks/PlayOnMac.app/Contents/Resources/__boot__.py", line 134, in _run
    execfile(path, globals(), globals())
  File "/Library/Internet Plug-Ins/Unity Web Player.plugin/Contents/Frameworks/PlayOnMac.app/Contents/Resources/playonlinux/python/mainwindow.py", line 1255, in <module>
    app = PlayOnLinuxApp(redirect=False)
  File "/Library/Internet Plug-Ins/Unity Web Player.plugin/Contents/Frameworks/PlayOnMac.app/Contents/Resources/lib/python2.7/lib-dynload/wx/_core.py", line 8470, in __init__
    self._BootstrapApp()
  File "/Library/Internet Plug-Ins/Unity Web Player.plugin/Contents/Frameworks/PlayOnMac.app/Contents/Resources/lib/python2.7/lib-dynload/wx/_core.py", line 8035, in _BootstrapApp
    return _core_.PyApp__BootstrapApp(*args, **kwargs)
  File "/Library/Internet Plug-Ins/Unity Web Player.plugin/Contents/Frameworks/PlayOnMac.app/Contents/Resources/playonlinux/python/mainwindow.py", line 1077, in OnInit
    self.systemCheck()
  File "/Library/Internet Plug-Ins/Unity Web Player.plugin/Contents/Frameworks/PlayOnMac.app/Contents/Resources/playonlinux/python/mainwindow.py", line 1185, in systemCheck
    playonlinux.SetSettings("SEND_REPORT","TRUE")
  File "/Library/Internet Plug-Ins/Unity Web Player.plugin/Contents/Frameworks/PlayOnMac.app/Contents/Resources/playonlinux/python/lib/playonlinux.py", line 89, in SetSettings
    fichier = open(cfile,"r").readlines()
IOError: [Errno 2] No such file or directory: '/Users/549040/Library/PlayOnMac//playonlinux.cfg'

Ronin DUSETTE Maandag 22 December 2014 om 4:08
Ronin DUSETTE
Admin

It seems like your install of POM failed for some reason. I would delete your POM install, re-download the newest version of POM, and try to reinstall it. At least that is what it looks like to me. 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
meaner6788 Maandag 22 December 2014 om 4:19
meaner6788Anonymous

Redownloaded, and it crashed again. I ran it through the terminal and got this output:

 

/Library/Internet\ Plug-Ins/Unity\ Web\ Player.plugin/Contents/Frameworks/PlayOnMac.app/Contents/MacOS/playonmac; exit;
2014-12-21 21:17:43.090 defaults[34879:494358]
The domain/default pair of (/Users/549040/Library/Preferences/com.apple.dock, loc) does not exist
bash: /Library/Internet: No such file or directory
wget: WGETRC points to /Users/549040/Library/PlayOnMac//configurations/wgetrc, which doesn't exist.
Traceback (most recent call last):
  File "/Library/Internet Plug-Ins/Unity Web Player.plugin/Contents/Frameworks/PlayOnMac.app/Contents/Resources/__boot__.py", line 140, in <module>
    _run('mainwindow.py')
  File "/Library/Internet Plug-Ins/Unity Web Player.plugin/Contents/Frameworks/PlayOnMac.app/Contents/Resources/__boot__.py", line 134, in _run
    execfile(path, globals(), globals())
  File "/Library/Internet Plug-Ins/Unity Web Player.plugin/Contents/Frameworks/PlayOnMac.app/Contents/Resources/playonlinux/python/mainwindow.py", line 1329, in <module>
    app = PlayOnLinuxApp(redirect=False)
  File "/Library/Internet Plug-Ins/Unity Web Player.plugin/Contents/Frameworks/PlayOnMac.app/Contents/Resources/lib/python2.7/lib-dynload/wx/_core.py", line 8631, in __init__
    self._BootstrapApp()
  File "/Library/Internet Plug-Ins/Unity Web Player.plugin/Contents/Frameworks/PlayOnMac.app/Contents/Resources/lib/python2.7/lib-dynload/wx/_core.py", line 8196, in _BootstrapApp
    return _core_.PyApp__BootstrapApp(*args, **kwargs)
  File "/Library/Internet Plug-Ins/Unity Web Player.plugin/Contents/Frameworks/PlayOnMac.app/Contents/Resources/playonlinux/python/mainwindow.py", line 1147, in OnInit
    self.frame = MainWindow(None, -1, os.environ["APPLICATION_TITLE"])
  File "/Library/Internet Plug-Ins/Unity Web Player.plugin/Contents/Frameworks/PlayOnMac.app/Contents/Resources/playonlinux/python/mainwindow.py", line 406, in __init__
    self.Reload(self)
  File "/Library/Internet Plug-Ins/Unity Web Player.plugin/Contents/Frameworks/PlayOnMac.app/Contents/Resources/playonlinux/python/mainwindow.py", line 870, in Reload
    self.games = os.listdir(Variables.playonlinux_rep+"shortcuts/")
OSError: [Errno 2] No such file or directory: '/Users/549040/Library/PlayOnMac/shortcuts/'

 

Ronin DUSETTE Maandag 22 December 2014 om 4:29
Ronin DUSETTE
Admin

I mean, if you look at the output, it says what is wrong:

The domain/default pair of (/Users/549040/Library/Preferences/com.apple.dock, loc) does not exist
bash: /Library/Internet: No such file or directory

OSError: [Errno 2] No such file or directory: '/Users/549040/Library/PlayOnMac/shortcuts/'

It seems that all sorts of stuff is missing, so I am not sure. Can you confirm that these directories exist? It may sound silly, but it is basically saying that it cannot find certain directories; I am not sure what else to infer from that. 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
meaner6788 Maandag 22 December 2014 om 4:36
meaner6788Anonymous

I'M SO DUMB. Ugh, you were exactly correct. I just added in the folders and it worked! Thanks loads!

Ronin DUSETTE Maandag 22 December 2014 om 4:53
Ronin DUSETTE
Admin

:) No problem. 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts