Het forum

update package for League of Legends?

Auteur Antwoorden
fdljkdsflkjsdflkjsfd Zondag 24 Mei 2015 om 4:11
fdljkdsflkjsdflkjsfdAnonymous

The League of Legends installer is out of date by at least a few years. When installed, it requires several GB of updates. Is it possible to update this package?

petch Zondag 24 Mei 2015 om 6:56
petch

This site allows content generated by members, and we promptly remove any content that infringes copyright according to our Terms of Service. To report copyright infringement, please send a notice to dmca-notice@playonlinux.com