Het forum

Cannot get (any part of) PlayOnMac to work

Auteur Antwoorden
Alna the Silver Zondag 24 Januari 2016 om 20:19
Alna the SilverAnonymous

I am trying to get PlayOnMac to work with very little success. PlayOnMac apparently can't install any version of Wine, and it’s difficult even printing a log. Please help!


What I did: 

I downloaded the 224 MB DMG from PlayOnMac's main website, opened up the DMG, and moved the PlayOnMac application to my the Applications folder on my Mac. I opened up the application, and got a dialogue box offering me to install a program. So far so good. Unfortunately, this is as far as I get before things stop working.


1. I tried installing Star Wars The Old Republic from the list. I am able to bring up the list and select it. It then tries to download and install Wine 1.7.53. While it downloads successfully, it seems that it cannot install Wine. POM continues to go back and over installing various Wine versions in an endless loop.


2. I tried installing a Windows application I have on my computer, so I selected "Install a program into a new virtual drive" and then gave it a one-word name, clicked through the next buttons, and get the following error message:

Error in POL_Wine
Wine seems to have crashed

If your program is running, just ignore this message

I am then unable to select the .exe file or the folder that I want to copy.


3. I select the "configure" button on the top of my application window. I can see my virtual drives, including both my SWTOR drive and the drive for my manually-installed program. If I click on the Wine tab, and then select any of the eight buttons, a dialogue box opens up and then closes down again immediately.

4. I select “Manage Wine Versions” from the Tools menu, since I’m apparently unable to install Wine. I see that I have no versions installed, and when I try to install a version (any version), it downloads, extracts - but doesn’t install.

5. I select the POM console from the Tools menu. XQuarts fires up, but displays no window that resembles a console.

6. By selecting the POM Debugger from the Tools menu, I am able to get the following logs:

(For the self-made virtual image:)

[01/24/16 11:07:17] - This is a 32bits prefix!
[01/24/16 11:07:20] - Running wine- cmd /c echo %ProgramFiles% (Working directory : /Applications/PlayOnMac.app/Contents/Resources/playonlinux/python)
wine client error:9: sendmsg: Bad file descriptor
[01/24/16 11:10:18] - Running wine- winecfg (Working directory : /Applications/PlayOnMac.app/Contents/Resources/playonlinux/python)
wine client error:9: sendmsg: Bad file descriptor
[01/24/16 11:13:44] - Running wine- winecfg (Working directory : /Applications/PlayOnMac.app/Contents/Resources/playonlinux/python)
wine client error:9: sendmsg: Bad file descriptor


(For SWTOR:)
> uname -a
  Darwin andrews-mbp-3.home 13.4.0 Darwin Kernel Version 13.4.0: Wed Mar 18 16:20:14 PDT 2015; root:xnu-2422.115.14~1/RELEASE_X86_64 x86_64
> lsb_release -a
> wine --version (Be careful; this version might not be the version used
in the script. Read the content of this file for more information)
  wine-1.8 (Staging)
> glxinfo \| grep rendering
> glxinfo \| grep renderer
> OpenGL libs
> export
  declare -x AMD64_COMPATIBLE="False"
declare -x APPLICATION_TITLE="PlayOnMac"
declare -x ARGVZERO="./playonmac.real"
declare -x Apple_PubSub_Socket_Render="/tmp/launch-JKwHlD/Render"
declare -x COMMAND_MODE="unix2003"
declare -x DESKTOP="/Users/andrewsimpson/Desktop"
declare -x DISPLAY="/tmp/launch-gdIYTm/org.macosforge.xquartz:0"
declare -x DONT_MONITOR="1"
declare -x DYLDPATH_ORIGIN="/Applications/PlayOnMac.app/Contents/MacOS"
declare -x DYLD_FALLBACK_LIBRARY_PATH="/usr/X11/lib:/usr/lib::"
declare -x DYLD_LIBRARY_PATH="/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/tools/lib/dyld:/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/image_magick/lib:/Appdeclare -x EXECUTABLEPATH="/Applications/PlayOnMac.app/Contents/MacOS/./playonmac.real"
declare -x GECKO_SITE="http://wine.playonlinux.com/gecko"
declare -x GNUPGHOME="/Users/andrewsimpson/Library/PlayOnMac//gpg"
declare -x HELPPATH="/Users/andrewsimpson/util/etc/help"
declare -x HOME="/Users/andrewsimpson"
declare -x IGNORE_ICON_DIR="false"
declare -x INFOPATH="/sw/share/info:/sw/info:/usr/share/info"
declare -x LANG="en_US.UTF-8"
declare -x LD_32_PATH_ORIGIN=""
declare -x LD_LIBRARY_PATH="/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/image_magick/lib:/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/tools/lib/ld:/opt/X11declare -x LD_PATH_ORIGIN=""
declare -x LESS="-P\" ---Less--- ?f%f :\\(stdin\\) .Line %lt?pt \\(%pt\\%\\):.?e \\(EOI\\):.\""
declare -x LOGNAME="andrewsimpson"
declare -x MACHTYPE="x86_64-apple-darwin13"
declare -x MAGICK_HOME="/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/image_magick/"
declare -x MANPATH="/sw/share/man:/usr/share/man:/usr/local/share/man:/opt/X11/share/man:/Applications/Xcode.app/Contents/Developer/usr/share/man:/Applications/Xcode.app/Contents/Developer/Toolchains/declare -x MD5_COMMAND="md5"
declare -x MONO_SITE="http://wine.playonlinux.com/mono"
declare -x NOBUGREPORT="YES"
declare -x OLDPWD="/Users/andrewsimpson/Library/PlayOnMac/plugins"
declare -x OSX_SUB_VERSION="4"
declare -x OSX_VERSION="13"
declare -x OS_NAME="darwin"
declare -x OpenGL32="1"
declare -x OpenGL64="1"
declare -x PAGER="less"
declare -x PATH="/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/wine/bin:/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/image_magick/bin:/Applications/PlayOnMacdeclare -x PATH_ORIGIN="/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/wine/bin:/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/image_magick/bin:/Applications/Pldeclare -x PERL5LIB="/sw/lib/perl5:/sw/lib/perl5/darwin"
declare -x PLAYONLINUX="/Applications/PlayOnMac.app/Contents/Resources/playonlinux"
declare -x PLAYONMAC="/Applications/PlayOnMac.app/Contents/Resources/playonlinux"
declare -x POL_ARCH="x86"
declare -x POL_COOKIE="BmSkVnq0BnzWEVBNHci0"
declare -x POL_CURL="curl"
declare -x POL_DNS="playonmac.com"
declare -x POL_HOST=""
declare -x POL_ID="29182440"
declare -x POL_LANG="en"
declare -x POL_OS="Mac"
declare -x POL_PORT="30000"
declare -x POL_SetupWindow_ID="21343"
declare -x POL_TERM="xterm"
declare -x POL_UPTODATE="TRUE"
declare -x POL_USER_ARCH="x86"
declare -x POL_USER_ROOT="/Users/andrewsimpson/Library/PlayOnMac/"
declare -x POL_WGET="wget --prefer-family=IPv4 -q"
declare -x PROGRAMS="/Users/andrewsimpson/Written_C_Programs"
declare -x PWD="/Applications/PlayOnMac.app/Contents/Resources/playonlinux/python"
declare -x PYTHONHOME="/Applications/PlayOnMac.app/Contents/Resources"
declare -x PYTHONPATH="/Applications/PlayOnMac.app/Contents/Resources"
declare -x REPERTOIRE="/Users/andrewsimpson/Library/PlayOnMac/"
declare -x RESOURCEPATH="/Applications/PlayOnMac.app/Contents/Resources"
declare -x RLANG="en_US.UTF-8"
declare -x SCRIPTID="Star Wars: The Old Republic"
declare -x SED="sed"
declare -x SETUPWINDOW_INIT="true"
declare -x SHELL="/bin/bash"
declare -x SHLVL="3"
declare -x SITE="http://repository.playonlinux.com"
declare -x SSH_AUTH_SOCK="/tmp/launch-j23Sif/Listeners"
declare -x SYSTEM="Darwin"
declare -x TEXTDOMAIN="pol"
declare -x TEXTDOMAINDIR="/Applications/PlayOnMac.app/Contents/Resources/playonlinux/lang/locale/"
declare -x TITLE="Star Wars: The Old Republic"
declare -x TITRE="PlayOnMac"
declare -x TMPDIR="/var/folders/sx/262tngj57hd_vw029t4ysfvw0000gn/T/"
declare -x USER="andrewsimpson"
declare -x UTIL="/Users/andrewsimpson/util"
declare -x VERSION="4.2.10"
declare -x WGETRC="/Users/andrewsimpson/Library/PlayOnMac//configurations/wgetrc"
declare -x WINEDLLOVERRIDES="winemenubuilder.exe=d"
declare -x WINEPREFIX="/Users/andrewsimpson/Library/PlayOnMac//wineprefix/default"
declare -x WINE_SITE="http://wine.playonlinux.com/binaries"
declare -x WRITE_DYLD="/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/tools/lib/dyld:/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/image_magick/lib:/Applicatiodeclare -x WRITE_LD="/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/image_magick/lib:/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/tools/lib/ld:/opt/X11/lib/:"declare -x __CF_USER_TEXT_ENCODING="0x1F5:0:0"
declare -x __CHECKFIX1436934="1"

01/24/16 11:03:47 - [POL_Wine_SelectPrefix] Message: Selecting prefix: SWTOR
01/24/16 11:03:47 - [POL_Wine_PrefixCreate] Message: Setting POL_WINEVERSION to 1.7.53
01/24/16 11:03:47 - [POL_Wine_PrefixCreate] Message: Creating prefix (1.7.53)...
01/24/16 11:03:47 - [POL_Wine_PrefixCreate] Message: Using wine 1.7.53
01/24/16 11:03:47 - [POL_Wine_InstallVersion] Message: Installing wine version path: 1.7.53, x86
01/24/16 11:04:16 - [POL_Wine_Install_resources] Message: Installing gecko for wine 1.7.53 x86
01/24/16 11:04:16 - [POL_Wine_Install_resources] Message: Linking gecko
01/24/16 11:04:16 - [POL_Wine_Install_resources] Message: Installing wine_gecko-2.40-x86.msi
01/24/16 11:04:16 - [POL_Download] Message: Downloading http://wine.playonlinux.com/gecko/x86/wine_gecko-2.40-x86.msi
01/24/16 11:04:32 - [POL_Download] Message: Download MD5 matches
01/24/16 11:04:32 - [POL_Wine_Install_resources] Message: Installing mono for wine 1.7.53 x86
01/24/16 11:04:32 - [POL_Wine_Install_resources] Message: Linking mono
01/24/16 11:04:32 - [POL_Wine_Install_resources] Message: Installing wine-mono-4.5.6.msi
01/24/16 11:04:32 - [POL_Download] Message: Downloading http://wine.playonlinux.com/mono/wine-mono-4.5.6.msi
01/24/16 11:05:15 - [POL_SetupWindow_question] Message: question answer: TRUE
01/24/16 11:05:15 - [POL_Download] Message: Downloading http://wine.playonlinux.com/mono/wine-mono-4.5.6.msi
01/24/16 11:10:12 - [POL_Download] Message: Download MD5 matches
01/24/16 11:10:13 - [POL_Config_PrefixWrite] Message: Prefix config write: ARCH x86
01/24/16 11:10:13 - [POL_Config_PrefixWrite] Message: Prefix config write: VERSION 1.7.53
01/24/16 11:10:13 - [POL_Wine_SetVersionEnv] Message: Wine 1.7.53 not installed. Installing it
01/24/16 11:10:13 - [POL_Wine_InstallVersion] Message: Installing wine version path: 1.7.53, x86
01/24/16 11:13:27 - [POL_Wine_Install_resources] Message: Installing gecko for wine 1.7.53 x86
01/24/16 11:13:27 - [POL_Wine_Install_resources] Message: Linking gecko
01/24/16 11:13:27 - [POL_Wine_Install_resources] Message: wine_gecko-2.40-x86.msi already installed. Skipping
01/24/16 11:13:27 - [POL_Wine_Install_resources] Message: Installing mono for wine 1.7.53 x86
01/24/16 11:13:27 - [POL_Wine_Install_resources] Message: Linking mono
01/24/16 11:13:27 - [POL_Wine_Install_resources] Message: wine-mono-4.5.6.msi already installed. Skipping
01/24/16 11:13:27 - [POL_Wine_SetVersionEnv] Message: Wine 1.7.53 not installed. Installing it
01/24/16 11:13:27 - [POL_Wine_InstallVersion] Message: Installing wine version path: 1.7.53, x86

Alna the Silver Dinsdag 26 Januari 2016 om 15:53
Alna the SilverAnonymous



After several reboots of the OS, I decided to try again with SWTOR. It didn't install, but it got further than the last time and seems to have been a problem with SWTOR itself rather than PlayOnMac (or, more likely, POM misplaced the IP address of SWTOR's download, based on the content of the error message). Wine appears to have worked. I'm going to test this out some more - stay tuned.

Aangepast door Alna the Silver

Alna the Silver Dinsdag 26 Januari 2016 om 16:03
Alna the SilverAnonymous

Addendum to Addendum:


SWTOR seems to be installing. I think my problem may have been a failed to do reboot correctly. However, I still need to check my custom software package...

Alna the Silver Dinsdag 26 Januari 2016 om 16:14
Alna the SilverAnonymous

Okay, SWTOR seems to be running properly; however, my other package is not.


Here's the rub: this indie software that I have does not come via an installer. It comes via a .zip file, which contains the working program and supporting files already inside of it. In Windows, running it simply consists of running the executable. However, PlayOnMac wants to run an installer. I can find (and run) the executable in this application, but it immediately crashes because POM only copied the executable itself into the virtual drive, without any of the required supporting files. How do I tell POM to copy the entire folder including everything formerly in the .zip file?

petch Dinsdag 26 Januari 2016 om 16:25

Here's the rub: this indie software that I have does not come via an installer. It comes via a .zip file, which contains the working program and supporting files already inside of it.

There's no specific support for "installer less" programs in PlayOnLinux/PlayOnMac, so you have to manually

1. Create a virtual drive: Configure button > "New" button (bottom left)

2. Unzip the files inside the virtual drive you just created

3. Create shortcut(s) for the programs you want to run: Configure button > (select virtual drive) > General tab > "Make a shortcut from this virtual drive" button

Alna the Silver Dinsdag 26 Januari 2016 om 16:50
Alna the SilverAnonymous

I see, and the directory inside the virtual drive is a standard Mac-Unix directory which means that I can add/remove files whenever I want (for instance, one of my apps is RPGMaker, which I want to be able to make and export games from). Great!


Alna the Silver Dinsdag 26 Januari 2016 om 17:00
Alna the SilverAnonymous

Yes, it all seems to be working now. Thank you very much!


How do I mark this thread as resolved?

Aangepast door Alna the Silver