Het forum

S.T.A.L.K.E.R. Shadow of Chernobyl

Starting game issue.

Auteur Antwoorden
usr.drc Woensdag 1 Juni\ 2016 om 7:09
usr.drcAnonymous

Greetings:

After sucessfully installing the game, I ran the game and it worked perfectly fine. Any time after I attempted to run the game, it wouldn't go full screen and the resolution became funky. So I had to end its process, however, if I click constantly after clicking the run game icon, it goes into fullscreen and works as expected.

I'm a bit baffled as to why the clicking makes it work.

My system:

16 GB Memory

Intel® Pentium(R) CPU G3220 @ 3.00GHz × 2  

NVIDIA GeForce GTX 960 using 361.42 driver

The error:

fixme:msvcrt:MSVCRT__set_abort_behavior _WRITE_CALL_REPORTFAULT unhandled
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded
fixme:heap:RtlCompactHeap (0xc20000, 0x0) stub
fixme:win:EnumDisplayDevicesW ((null),0,0x33ca08,0x00000000), stub!
fixme:d3d:query_init Unhandled query type 0x4.
fixme:d3d9:Direct3DShaderValidatorCreate9 stub

ODE Message 3: LCP internal error, s <= 0 

^ A bunch of those during gameplay ( I think ), though that seems to be unrelated to the start up issue.

I assume I'm missing some libs? 

booman Woensdag 1 Juni\ 2016 om 23:35
booman

Are you using Mint?
Are you using the virtual desktop?


† Booman †
Mint 19.3 64-bit | Nvidia 430 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
usr.drc Donderdag 2 Juni\ 2016 om 5:37
usr.drcAnonymous

Ubuntu 16.04 and no. I read somewhere to not use the virtual desktop option.

booman Donderdag 2 Juni\ 2016 om 17:11
booman

Ok, I was asking becase I've recently had problems with the virtual desktop in Mint.  When I set the game to match my desktop resolution and go full-screen, the game is invisible but still running.  That sounds like your symptoms as well.

Try enabling the virtual desktop and set it to the same resolution as your Linux Desktop.

As for libraries... do you have the 32-bit libraries installed?

You can always update to Nvidia 364 drivers too

It may not hurt to add more Direct X libraries as well.  You shouldn't have to if the game runs fine already.


† Booman †
Mint 19.3 64-bit | Nvidia 430 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
usr.drc Vrijdag 3 Juni\ 2016 om 16:55
usr.drcAnonymous

Which 32 bit libraries?

I tried the virtual desktop, however it won't go full screen.

booman Vrijdag 3 Juni\ 2016 om 17:23
booman

Ubuntu no longer gives you a single package to install 32-bit libraries.  They are needed for any program or game that is 32-bit only.  That is 90% of games.

Try this:

sudo dpkg --add-architecture i386

Then:

sudo apt-get update

Then:

sudo apt-get install libasound2:i386 libasound2-plugins:i386 libfontconfig1:i386 lib32nss-mdns libgnutls26:i386 libxslt1.1:i386 libxcursor1:i386 libxcomposite1:i386 libosmesa6:i386 libopenal1:i386 libmpg123-0:i386 libldap-2.4-2:i386 liblcms2-2:i386 libgstreamer0.10-0:i386 libgstreamer-plugins-base0.10-0:i386 libgsm1:i386 libxinerama1:i386 libxi6:i386 libv4l-0:i386 libsane:i386 libudev1:i386 libxml2:i386 libcups2:i386 libxrandr2:i386 libice6:i386 libsm6:i386

Restart to be safe and now you should have 32-bit libraries installed.  It will help with most games in PlayOnLinux and native to Linux


† Booman †
Mint 19.3 64-bit | Nvidia 430 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
usr.drc Zondag 5 Juni\ 2016 om 0:12
usr.drcAnonymous

So far installing the 32-bit libraries seems to have worked.

Thanks for the assistance.

booman Maandag 6 Juni\ 2016 om 5:02
booman

What resolution are you running the game at?


† Booman †
Mint 19.3 64-bit | Nvidia 430 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained