Het forum

Far Cry 3

Installing on Uplay

Auteur Antwoorden
pgarraud Woensdag 8 Juni\ 2016 om 0:11
pgarraudAnonymous

I'm trying to install the Uplay version Far Cry 3. It installs fine but when I run it, it crashes. From what I can find, the WINE version needs to be set to Windows 7. The problem is that doing this causes Uplay to crash saying it detected an unrecoverable error.

booman Woensdag 8 Juni\ 2016 om 23:19
booman

At what point does Far Cry 3 crash?

I haven't tried Uplay in a long time, but when I was playing Assassin's Creed Brotherhood and Revelations, I had to install Uplay and it ran fine.  It was kinda buggy when launching and patching, but it launched my games just fine.  I always used the Windows 7 setting for Windows version.

I'll give it a try again...


† Booman †
Mint 19.3 64-bit | Nvidia 430 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
booman Woensdag 8 Juni\ 2016 om 23:32
booman

Same problem here.  I'm using Wine 1.9.10-staging and with Windows set to Windows XP, Uplay launches just fine. if I change it to Windows 7 then it never launches.  Far Cry 3 is supposed to be Windows XP compatible, so I'm not sure why you need to change it to Windows 7?


† Booman †
Mint 19.3 64-bit | Nvidia 430 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
pgarraud Donderdag 9 Juni\ 2016 om 5:35
pgarraudAnonymous

 

At what point does Far Cry 3 crash?

I haven't tried Uplay in a long time, but when I was playing Assassin's Creed Brotherhood and Revelations, I had to install Uplay and it ran fine.  It was kinda buggy when launching and patching, but it launched my games just fine.  I always used the Windows 7 setting for Windows version.

I'll give it a try again...

 

booman Donderdag 9 Juni\ 2016 om 19:11
booman

Are you using a 32-bit virtual drive?

This is kind of a "catch 33" because setting Wine to Windows 7 allows you to play Far Cry 3, but Uplay crashes, setting to Windows XP allows Uplay to work but Far Cry crashes.

There is a post on WineHQ's about disabling fullscreen to avoid crashing... you could try that, but unfortunately you will have to do it through config files since the game doesn't launch.


† Booman †
Mint 19.3 64-bit | Nvidia 430 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
pgarraud Vrijdag 10 Juni\ 2016 om 2:39
pgarraudAnonymous

I'm using 32-bit WINE.

booman Vrijdag 10 Juni\ 2016 om 17:55
booman

Did you try disabling fullscreen?  I don't think this is your problem, but you never know...

What are your system specs?

  • Distro
  • video card
  • drivers
  • version of PlayOnLinux

† Booman †
Mint 19.3 64-bit | Nvidia 430 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
pgarraud Zaterdag 11 Juni\ 2016 om 4:10
pgarraudAnonymous

SparkyLinux

Nvidia GTX 760

Nvidia Proprietary 361

4.2.10

 

Also, do you know how to disable fullscreen using the config files?

booman Maandag 13 Juni\ 2016 om 19:05
booman

Good, sounds like you have your system up-to-date for gaming.  Is SparkyLinux based on another distro?

You may have to look through the Far Cry 3 game folder and find a config.  Sometimes you can manually set the resolution for a game in a config file.

Looks like Far cry creates an .xml file in your Documents.  Look for a Far Cry 3 folder or a My Games folder.
Make a copy of it on your Desktop first... 

Open the .xml file and search for :

Fullscreen="1"

Change it to

Fullscreen="0"

Save it and try launching again

 

Found this

I copied the ini in this link below. Then, I changed the settings to direct3d9, 
lowered all shadow values I could find to 512, vsync=1, buffered frames to 5. 
I loaded up the game and was getting 120 fps in the menu, whereas it was like 30 before, 
which was horrible. Game was running at 15-45 fps before, now a solid 60 fps.

http://forums.guru3d.com/showpost.php?p=4467353&postcount=1318

 

Aangepast door booman


† Booman †
Mint 19.3 64-bit | Nvidia 430 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
pgarraud Dinsdag 14 Juni\ 2016 om 0:42
pgarraudAnonymous

When I go to the Far Cry 3 folder in my documents, there is no config file. 

 

Also, SparkyLinux is based on Debian Testing.

booman Dinsdag 14 Juni\ 2016 om 0:52
booman

Dang, I was afraid of that.  Until the game actually launches it won't create the xml file in your Documents.  You can try looking in the game files for another config, but sometimes games don't have one.  At least not one you can edit.

Do you even have a "My Games" folder?

 

Apparently Uplay has an overlay as well.  Try going to the settings and disabling that too.
http://steamcommunity.com/app/220240/discussions/0/846938351104818302/

These clients are getting so annoying... launch Steam, launch game, launch Uplay.... lame!

Aangepast door booman


† Booman †
Mint 19.3 64-bit | Nvidia 430 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
pgarraud Dinsdag 14 Juni\ 2016 om 5:10
pgarraudAnonymous

I disabled the overlay and the game still crashes. Also, I do have a My Games folder, but no config file.

booman Dinsdag 14 Juni\ 2016 om 17:48
booman

Dang... worth a try You have "My Games" folder but no Far Cry 3 folder right?

All I can suggest at this point is to try Ubuntu or Mint.  They are both based on Debian, so I wouldn't think the result would be different.


† Booman †
Mint 19.3 64-bit | Nvidia 430 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Je bent hier: Index > PlayOnLinux > Far Cry 3