Het forum

"Refreshing PlayOnLinux" forever

Auteur Antwoorden
Psy-Q Dinsdag 14 Februari 2017 om 18:30
Psy-Q

Running on Debian 9.0 (stretch, currently in testing) I used to be able to start PlayOnLinux just fine. I wanted to use it again yesterday after a dist-upgrade,  but now the main PlayOnLinux window shows an empty progress bar in the lower right and the status bar reads "Refreshing PlayOnLinux". This goes on forever as far as I can tell, I've let it run for hours.

Starting any games or programs doesn't work (the "Run" button can be pressed, but nothing happens). Pressing "configure" does bring up the configuration dialog, but I can't create any new virtual drives.

I tried moving the ~/.PlayOnLinux directory out of the way and starting fresh, but the same symptoms there. What could I try next?

Psy-Q Woensdag 15 Februari 2017 om 19:48
Psy-Q

Solved it: It turns out the "netcat" package in Debian 9 now is a metapackage and pulls in both "netcat-openbsd" and "netcat-traditional". But PlayOnLinux doesn't work when "netcat-openbsd" is set as the system's netcat.

You can either use:

update-alternatives --config netcat

To set it to netcat-traditional or you can remove netcat-openbsd:

apt-get remove netcat-openbsd
rook2pawn Maandag 13 Maart 2017 om 14:00
rook2pawnAnonymous

Thanks! Had the exact same issue using stretch/SID. I went with the remove netcat-openbsd, works wonderfully now. Kudos!

playonmacer Woensdag 18 April 2018 om 14:39
playonmacerAnonymous

Hm Play on Mac seems to have stopped working with a similar issue. Maybe that's related since mac is based on BSD and comes with netcat.

m93a Donderdag 6 Juni\ 2019 om 15:18
m93aAnonymous

Hello, I'm on Ubuntu and I my POL also keeps loading forever (relevant AskUbuntu thread). The package netcat-openbsd is required by Ubuntu itself, but I also have netcat-traditional, which is required by POL. What should I do?

hirameki Woensdag 27 November 2019 om 18:26
hiramekiAnonymous

It may occured by message mistake like URL below.

https://qiita.com/kouki111x1/items/2cbd93089efa221b1bf5

He said this bug caused by a blank {0<blank>} not {0}, it fails to display message and stop process to get list, and nothing change forever.
You can fix this problem by editing pol.mo (in this case) file using msgunfmt/msgfmt command.(Linked in the blog)

I confirmed this problem and fix with editing pol.mo file.

Change language setting to English may solve this problem. I think English message file not have this problem.

P.S> I registered this site today for reporting this.

Aangepast door hirameki

mikestanley464 Woensdag 2 September 2020 om 11:01
mikestanley464Anonymous

To install Guild Wars 2 using PlayOnLinux, download, install and launch PlayOnLinux and follow the first run wizard. Then, wait for the message "Refreshing PlayOnLinux" to go away from the bottom pane of the PlayOnLinux window. Once it is finished refreshing, click the "Install" button at the top of the window Bluestacks Omegle.red

Aangepast door mikestanley464

mikestanley464 Zaterdag 12 September 2020 om 20:45
mikestanley464Anonymous

To install Guild Wars 2 using PlayOnLinux, download, install and launch PlayOnLinux and follow the first run wizard. Then, wait for the message "Refreshing PlayOnLinux" to go away from the bottom pane of the PlayOnLinux window. Once it is finished refreshing, click the "Install" button at the top of the window 

Aangepast door mikestanley464

sofiawood Zaterdag 3 October 2020 om 18:34
sofiawoodAnonymous

ok,
I will be use it at my own risk...