Het forum

POL hangs forever installing mono

Linux Mint 19.3, POL 4.2.12, AMD A10-5800K, R9 Nano, 8gb ram

Auteur Antwoorden
data-angel Dinsdag 6 October 2020 om 22:03
data-angelAnonymous

POL hangs when installing mono on a new prefix, i have to quit out of it.

I tried reinstalling it, and did find out it was missing 'libudev.so.0' which i managed to fix but that does not stop this issue so there must be more to it i guess. Could someone please help me figure this out?

Distro: Linux Mint 19.3
POL: 4.2.12
CPU: AMD A10-5800K

GPU: R9 Nano

RAM: 8gb

Debugger

> PlayOnLinux Version
  4.2.12
> uname -a
  Linux LNXDesktop-BloodNet 5.4.0-48-generic #52~18.04.1-Ubuntu SMP Thu Sep 10 12:50:22 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux
> lsb_release -a
  
> wine --version
  wine-2.4 (Staging)
> POL_WINEVERSION
  2.4-staging
> WINEPREFIX
  /home/data-angel/.PlayOnLinux//wineprefix/v2
> Distribution
  Linux Mint 19.3 Tricia
> glxinfo \| grep rendering
  direct rendering: Yes
> glxinfo \| grep renderer
      GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer, 
    GLX_MESA_query_renderer, GLX_MESA_swap_control, GLX_OML_swap_method, 
Extended renderer info (GLX_MESA_query_renderer):
OpenGL renderer string: AMD Radeon (TM) R9 Fury Series (FIJI, DRM 3.35.0, 5.4.0-48-generic, LLVM 10.0.0)
> OpenGL libs (Direct rendering testing)
  check_dd_x86 missing, test skipped
  check_dd_amd64 missing, test skipped

----------------------------------------------

POL until i have to force it to close

Looking for python... 2.7.17 - wxversion(s): 3.0-gtk3
selected
[main] Message: PlayOnLinux (4.2.12) is starting
[clean_tmp] Message: Cleaning temp directory
[Check_OpenGL] Warning: check_dd_x86 missing, test skipped
[Check_OpenGL] Warning: check_dd_amd64 missing, test skipped
[POL_System_CheckFS] Message: Checking filesystem for /home/data-angel/.PlayOnLinux/
[main] Message: Filesystem is compatible
wget-log: Permission denied; disabling logging.
wget-log: Permission denied; disabling logging.
wget-log: Permission denied; disabling logging.
wget-log: Permission denied; disabling logging.
wget-log: Permission denied; disabling logging.
wget-log: Permission denied; disabling logging.
wget-log: Permission denied; disabling logging.
wget-log: Permission denied; disabling logging.
wget-log: Permission denied; disabling logging.
wget-log: Permission denied; disabling logging.
wget-log: Permission denied; disabling logging.
wget-log: Permission denied; disabling logging.
wget-log: Permission denied; disabling logging.
wget-log: Permission denied; disabling logging.
wget-log: Permission denied; disabling logging.
wget-log: Permission denied; disabling logging.
wget-log: Permission denied; disabling logging.
wget-log: Permission denied; disabling logging.
wget-log: Permission denied; disabling logging.
wget-log: Permission denied; disabling logging.
wget-log: Permission denied; disabling logging.
wget-log: Permission denied; disabling logging.
wget-log: Permission denied; disabling logging.
wget-log: Permission denied; disabling logging.
wget-log: Permission denied; disabling logging.
wget-log: Permission denied; disabling logging.
wget-log: Permission denied; disabling logging.
wget-log: Permission denied; disabling logging.
wget-log: Permission denied; disabling logging.
wget-log: Permission denied; disabling logging.
wget-log: Permission denied; disabling logging.
wget-log: Permission denied; disabling logging.
wget-log: Permission denied; disabling logging.
wget-log: Permission denied; disabling logging.
wget-log: Permission denied; disabling logging.
wget-log: Permission denied; disabling logging.
[update_check] Message: List is up to date
[install_plugins] Message: Checking plug-in: ScreenCap...
[install_plugins] Message: Checking plug-in: PlayOnLinux Vault...

(mainwindow.py:30876): Gtk-CRITICAL **: 16:30:38.214: gtk_box_gadget_distribute: assertion 'size >= 0' failed in GtkNotebook

(mainwindow.py:30876): Gtk-CRITICAL **: 16:30:38.214: gtk_box_gadget_distribute: assertion 'size >= 0' failed in GtkNotebook

(mainwindow.py:30876): Gtk-CRITICAL **: 16:30:38.214: gtk_box_gadget_distribute: assertion 'size >= 0' failed in GtkNotebook
[POL_SetupWindow_Init] Message: Creating new window for pid 31372

(mainwindow.py:30876): Gtk-CRITICAL **: 16:30:58.861: gtk_notebook_get_tab_label: assertion 'list != NULL' failed

(mainwindow.py:30876): Gtk-CRITICAL **: 16:30:58.868: gtk_notebook_get_tab_label: assertion 'list != NULL' failed

(mainwindow.py:30876): Gtk-CRITICAL **: 16:30:58.880: gtk_notebook_get_tab_label: assertion 'list != NULL' failed

(mainwindow.py:30876): Gtk-CRITICAL **: 16:30:58.883: gtk_notebook_get_tab_label: assertion 'list != NULL' failed

(mainwindow.py:30876): Gtk-CRITICAL **: 16:30:58.888: gtk_notebook_get_tab_label: assertion 'list != NULL' failed
[POL_SetupWindow_menu_num] Message: menu_num answer: 0
[POL_System_SetArch] Message: POL_ARCH set to x86
[POL_SetupWindow_menu] Message: menu answer: 2.4-staging
[POL_SetupWindow_textbox] Message: textbox answer: v2
[POL_Wine_SelectPrefix] Message: Selecting prefix: v2
[POL_Wine_PrefixCreate] Message: POL_WINEVERSION is already set to 2.4-staging. Using it
[POL_Wine_PrefixCreate] Message: Creating prefix (2.4-staging)...
[POL_Wine_PrefixCreate] Message: Using wine 2.4-staging
[POL_Wine_InstallVersion] Message: Installing wine version path: 2.4-staging, x86
[POL_Config_PrefixWrite] Message: Prefix config write: ARCH x86
[POL_Config_PrefixWrite] Message: Prefix config write: VERSION 2.4-staging
[POL_Wine] Message: Running wine-2.4-staging --version (Working directory : /usr/share/playonlinux/python)
[POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See http://www.playonlinux.com/fr/page-26-Winemenubuilder.html
[POL_Wine] Message: Wine return: 0
fixme:winediag:start_process Wine Staging 2.4 is a testing version containing experimental patches.
fixme:winediag:start_process Please mention your exact version when filing bug reports on winehq.org.
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
err:ole:marshal_object couldn't get IPSFactory buffer for interface {00000131-0000-0000-c000-000000000046}
err:ole:marshal_object couldn't get IPSFactory buffer for interface {6d5140c1-7436-11ce-8034-00aa006009fa}
err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, hres=0x80004002
err:ole:CoMarshalInterface Failed to marshal the interface {6d5140c1-7436-11ce-8034-00aa006009fa}, 80004002
err:ole:get_local_server_stream Failed: 80004002
err:ole:marshal_object couldn't get IPSFactory buffer for interface {00000131-0000-0000-c000-000000000046}
err:ole:marshal_object couldn't get IPSFactory buffer for interface {6d5140c1-7436-11ce-8034-00aa006009fa}
err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, hres=0x80004002
err:ole:CoMarshalInterface Failed to marshal the interface {6d5140c1-7436-11ce-8034-00aa006009fa}, 80004002
err:ole:get_local_server_stream Failed: 80004002
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
err:syslink:SYSLINK_SetFont Failed to create link font!
err:process:__wine_kernel_init boot event wait timed out
Wine cannot find the ncurses library (libncurses.so.5).
/home/data-angel/.PlayOnLinux//wine/linux-x86/2.4-staging/bin//wineserver
err:clipboard:convert_selection Timed out waiting for SelectionNotify event
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
err:mscoree:LoadLibraryShim error reading registry key for installroot
err:mscoree:LoadLibraryShim error reading registry key for installroot
err:mscoree:LoadLibraryShim error reading registry key for installroot
err:mscoree:LoadLibraryShim error reading registry key for installroot
err:winediag:schan_imp_init Failed to load libgnutls, secure connections will not be available.
err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
fixme:dwmapi:DwmIsCompositionEnabled 0x6d5d3018
fixme:iphlpapi:NotifyIpInterfaceChange (family 0, callback 0x6a0cb608, context 0xa48a20, init_notify 0, handle 0x127e7a4): stub
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
wine: configuration in '/home/data-angel/.PlayOnLinux//wineprefix/v2' has been updated.
Registered PID: 31143 (Missing)
Registered PID: 31372 (Present)
Registered PID: 31649 (Missing)
Registered PID: 31687 (Missing)

 

Dadu042 Donderdag 8 October 2020 om 11:35
Dadu042
Moderator

What is the game you try to run ?

Note:

  • POL 4.2.12 is quite old (2016 or 2017).
  • I recommend at least Wine 2.22
data-angel Donderdag 8 October 2020 om 16:26
data-angelAnonymous

 

What is the game you try to run ?

Note:

  • POL 4.2.12 is quite old (2016 or 2017).
  • I recommend at least Wine 2.22

 

 this happens when creating a prefix, not trying to run a game

 

I'm trying to set up a prefix for victoria 2 though, but whenever i make any kind of prefix, it hangs on installing mono

 

i didnt realise it was old tho lol so i should try installing a newer POL?

Dadu042 Donderdag 8 October 2020 om 18:30
Dadu042
Moderator

Maybe that a newer POL version (v4.3.4) may help.

data-angel Vrijdag 9 October 2020 om 1:25
data-angelAnonymous

Thank you! updating POL and changing wine version helped, but now i'm getting that /proc/sys/kernel/yama/ptrace_scope error even though i already set it to = 0 when trying to install dotnet30sp1, i'm not sure what to do from there?

Dadu042 Vrijdag 9 October 2020 om 13:23
Dadu042
Moderator

The answer is in the wiki.

data-angel Vrijdag 9 October 2020 om 14:15
data-angelAnonymous

where? searching ptrace or ptrace_scope doesn't return anything

Dadu042 Zaterdag 10 October 2020 om 10:25
Dadu042
Moderator

True, I've read too fast your question. Sorry I don't know more.

data-angel Zaterdag 10 October 2020 om 13:03
data-angelAnonymous

Ok thanks for your help regardless, i'll mark this as solved and make another post if I can't work it out