Je bent hier

Het forum

Far Cry 2

Auteur Antwoorden
Jump to the page: 1 - 2
GNU_Raziel Zaterdag 29 November 2008 om 22:31

is your n,vidia driver up-to-date ? (game tested with driver 177.82)
Oni-BR- Vrijdag 26 December 2008 om 2:03

I have the same problem, my vga is a Geforce 9600GT with a Nvidia Driver 177.82, running under a Ubuntu 8.10 X64...
Silencer Woensdag 11 Maart 2009 om 14:12

I just Registered, just to post this:

I'm a Windows guy, checking out Linux. This POL, is THE thing, that Linux Needs.

First Test: Far Cry 2

I'm having the same ***'Your Video Card drivers are too old.'*** message.

(I used SimplyMEPIS's (8.0) X-Window manager to install the fglrx, (or whatever.) No problems.) (On March 11, 2009)

I Installed Wine, Added the Debian repository specified on the Debian download page, (using the Synaptic Package Manager,) Downloaded the .deb package, installed missing POL dependencies (python-wxgtk2.8 / imagemagick / cabextract,) installed the downloaded .deb.

Installed Far Cry 2 1.0, replaced the original farcry2.exe ,with a working (in Windows) no-cd crack, (to avoid copy protection issues.) Launched the game, allowed it to auto-update. Re-copied the working (in Windows, (patched and un-patched)) no-cd crack.

All set-up, Re-launch: The game flies through the auto-update window, comes up as a black square in the middle of the screen, (like maybe it's running at 800x600 on a 1024x768 desktop, come to think of it,) and then shows the ***'Your Video Card drivers are too old.'*** message, at which point I click OK, and the game exits.

I easily installed and assigned the 1.1.8 Wine. Same deal.

I was about to troubleshoot it further (I'm Brand-New to Linux) until I saw this open issue/thread.

(Maybe it's a typo? Is there something like a 1.18? Whatever...)

I'm going to try a second game, from the list...

***Please fix this issue, it isn't resolved, (in this thread anyway...)***

Windows Game Functionality, is *the* most crucial step, for Linux to rule the Desktop.

I'll be checking/posting back. One of you Linux guys, please fix this! :O)

Oh Ya: Um... In case it helps: Sapphire ATi Radeon 4850 1GB / Some 5x00 dual-core AMD (64-bit) / Asus board / Kingston RAM, etc... Using 32-bit Linux at this time. Thank-you!

Aangepast door Silencer

Silencer Zondag 15 Maart 2009 om 8:38

I'm going to (slowly) try doing this:
mykro76 Zondag 20 September 2009 om 4:13

Been a while since the last post so I thought I'd report my successful experience with this script.

PlayOnLinux 3.6
System Wine: 1.1.26
Distribution : Ubuntu 9.04 32bit
system: i7-920
graphic card : Nvidia GTX260 OC (896MB)
graphic card drivers : Nvidia binary v180

- In Playonlinux I choose "Far Cry 2" and it first installs a couple of directx utilities, then it runs the installer from dvd. During install I choose "custom option" and unselect "Punkbuster".

- In Playonlinux, I install Wine 1.1.8, and associate "Far Cry 2" with it. Wine 1.1.29 is the newest available in POL, but will not work (see later).

- NOTE: If I just click "Run" in POL now, I will get a dialog for the SecureROM online release date check. The progress bar will go to 30% and stop. If I click "Cancel" and confirm "Yes", then nothing more will appear, on screen or in terminal. The game does not launch at all.

- I replace the 34MB FarCry2.exe with a No-CD version that is only 34.4KB.

- Click on "Run" in POL. The game launches! There is no longer a SecureROM dialog. Instead, I now get the message "Your video card drivers are too old. Please update them." This does not seem to harm anything - I can click OK to proceed.

- Far Cry 2 plays the short intro videos. Before the menu appears I suggest you move the cursor to the edge of the screen.

- WINE GLITCH: After the menu loads, there are two cursors visible: the original Ubuntu cursor is now frozen, but the Far Cry 2 cursor works. The frozen cursor remains throughout the game.

- Far Cry 2 reaches the main menu.

- I look at the graphics options and confirm that the script has set a "Custom" detail level, with everything on Low and Geometry on High.

- NOTE: Do NOT change any options at this point. Try the default configuration first.

- I start a New Game.

- The usual loading screens with a spinning progress icon are displayed as it loads the game world.

- WINE BUG: This is where Wine 1.1.29 fails for me. What happens is that after the game world is loaded, it does not appear. The loading screen remains visible, and the subtitles of the taxi driver's conversation start appearing at the bottom. The game world is never displayed, but it is obviously working in real time. I can press ESC to pause the "game" and access the journal, but when I press ESC again, the continuing subtitles appear over the top of the journal.

- Under Wine 1.1.8 it works. The game world is displayed, the taxi ride cut-scene begins.

- I press ~ for console, and type 'showFps 1'

- In the taxi ride cut-scene I'm getting 15-25fps as I look around, 60-70fps if I look up at the sky or down into the taxi.

- WINE GLITCH: Every person's face is flickering like there's an invisible candle in front of them.

- During the Jackal cut-scene I'm getting 17fps.

- The game starts. I'm getting about 25fps on average.

- I play through the tutorial until after fixing the car. This is where the game proper begins.

- I press ESC and choose Save Game. Now I can quit and start changing resolutions.

- NOTE: Do NOT change resolutions within Far Cry 2. This will cause it to crash.

- Back In Playonlinux, I select "Configure this application", and then "Use configurator for Far Cry 2". The default resolution was 1024x768 which worked but I want widescreen. 1280x768 does NOT work for me - the game does not launch at all! 1440x900 is the highest available widescreen resolution, so I select this and it works fine.

- I run the game again. Average fps under Ubuntu is about 20fps and it varies from 15 to 25fps.

- Under Windows, with everything maxed out at 1920x1080, I was getting at least 45fps.

- By the way, you can copy your "My Games/Far Cry 2/Saved Games" folder from Windows to Linux and back, and they work! Just don't copy your GamerProfile.xml file!

I can definitely recommend using the PlayonLinux Far Cry 2 script, it was able to take care of a lot of the known problems that have been reported in this forum and in the Wine database. You are never going to achieve anywhere near your rig's capacity under Wine, but if you have quad core and a decent video card Far Cry 2 should be playable. For me, it's certainly good enough for grinding through the diamond briefcases, safe houses, weapons upgrades etc, and it means I only have to reboot into Windows when I want to play the story missions while enjoying the maximum experience.

Aangepast door mykro76

Je bent hier: Index > > Far Cry 2