Het forum

Installing Game from Multiple CDs

Asus eeePC Easy Peasy Wine PlayOnLinux Baldur's Gate II

Auteur Antwoorden
Plextor Zondag 22 Maart 2009 om 14:07


I'm trying to install Baldur's Gate II from CDs 1-4 onto my eeePC 900 running EasyPeasy 1.0 (Ubuntu) using Wine & PlayOnLinux.

The install runs perfectly until the first CD is finished, and then the installer asks for the second CD.

Ubuntu, however, doesn't allow me to eject the CD because it says the CD is still in use.

Once I eject the CD manually (hardware eject) and enter the second CD I have the following issue:

1) Ubutu recognizes the CD
2) the game installer also recognizes the CD (browse menu allows me to browse to the CD)

however once I click 'ok' in the installer it tells me that disk 2 could not be found.

Could someone please help me with this issue? I guess it's quite common, but I couldn't find it anywhere else on this forum.

NSLW Zondag 22 Maart 2009 om 16:00

Do you install BG2 with help of POL script or as unsupported application?
Plextor Zondag 22 Maart 2009 om 16:29

With the help of POL script
Plextor Zondag 22 Maart 2009 om 16:31


I've successfully completed installation by unplugging my CD-Rom drive, ejecting the CD and inserting the new CD and attaching the CD-Rom drive again and mounting it with

wine eject [-u] [-a] [-h] [x:]...
-a Eject all the CD drives we find
-h Display this help message
-u Unmount only, don't eject the CD
x: Eject drive x:

Install has successfully completed.
Plextor Zondag 22 Maart 2009 om 16:32

Change Issue: Running Baldur's Gate 2

After having successfully installed baldur's gate 2 I've tried to run it from within PlayOnLinux and also via the desktop shortcut - both methods have failed to activate.

No window at all opens once I double click on the links (within POL or within the desktop).

Can you suggest any alternative way to run the executable?

Plextor Zondag 22 Maart 2009 om 18:29

Fixed this as well by running BG 2 SOA via Wine directly.
enr23 Dinsdag 28 April 2009 om 13:31

Hi guys,

Firstly I wish to commend you for your interesting project. I am especially astounded at your young ages ... vous êtaits tres habiles de vous cerveau! Pardon my poor French ...

Anyway the problem I have is related to this post. Firstly, the backgound:

OpenSuSe 11.1
PlayOnLinux 3.4

I have successfully installed and run several programs (Safari, Pharaoh, Pretorians, Photoshop, AOE, The Fallen, etc) but all of the above have just 1 CD. Whenever I try to install any 2 CD games everything stops at the 2nd CD promp. For example, with Spellforce (installing as an unsupported application), as with other multi-CD programs, what happens is this:

1. First CD in, installation proceeds smoothly until it asks for the 2nd CD. Wine thinks this is the "D:" drive.
2. I eject the 1st CD (wine eject) and insert the 2nd CD. SuSe mounts it on /media/SF_CD1, like this first one. Playonlinux doesn't recognise this drive. It beeps and refuses to recognise the new CD in D:
3. I eject everything, restart everything, except this time under "Wine configuration --> Drives" I add a drive called Q: and point it to /media/SF_CD2 (which I had created earlier).
4. Once we get to the bit where it asks for the second CD, I manually mount the second CD onto /media/SF_CD2 and type "Q:" into the box, but it beeps and does nothing.

I have tried different variants of this but nothing seems to want Playonlinux (or Wine) understand that the second CD is mounted and ready to go ... could you please indicate to me how do I achieve this?
Merci beaucoup a tous.

NSLW Dinsdag 28 April 2009 om 15:03

I've got two advices:

1) copy both cd's to single directory and then start installation


2) add drive e.g
D: which points at /media/SF_CD1
F: which points at /media/SF_CD2

then set both drives to CD-ROM type under "Show Advanced" in winecfg (Drives tab)

Remember to run winecfg through / inside PlayOnLinux.
enr23 Woensdag 29 April 2009 om 12:26

Hi there again,

Well I have tried your options; For the first one, although it did install completely, when I tried to run it, it didn't work, with two messages: 1: "Incompatible system configuration", and 2: "Please insert your original CD into your CD/DVD drive".

So then I uninstalled everything, and created a new one with CD1 (D:) pointing to /media/SF_CD1 and CD2 (E:) to the copied folder /home/enrico1/.PlayOnLinux/wineprefix/Spellforce_CDs/SF_CD2. Both were set as "CD-ROM" drives within winecfg. Again, if found both and installed the game but, when it came to playing it, it gave me the same messages, even if the original CD1 was still in the drive.

What else can I try?
NSLW Woensdag 29 April 2009 om 13:17

As i understand you did what i wrote in second advice and you've got now your spellforce installed and becoming message about no cd. Result is as i've expected so no problem.

So the case is now slicky and i cannot tell you directly how to do it to work correctly but if you are smart and aren't afraid of illegal stuff then you will be running your spellforce.

The case is following:

Spellforce CD is copy protected (SecuROM v4 or SecuROM v5) and neither Wine nor POL support copy protected CD's so your game will always be showing this message because of lack of this support.

However illegal copies of Spellforce do have got cracked execs which enables user to run this game if he substitutes legal exe with cracked which can be done in main directory of the game. It's illegal because this user hasn't paid for this game!

You probably have got original copy of Spellforce and haven't got cracked executable but there are many of them distributed on the internet.

"Incompatible system configuration"

Quote from enr23

If then you get only this message then you should:
-patch your game to 1.52 version

then do as i described:
here about latest Wine
here about OffscreenRenderingMode and VideoMemorySize


Quote from enr23

I'm not a French :)

Aangepast door NSLW

enr23 Donderdag 30 April 2009 om 10:40

Nothing wrong about being French :)

I had a look at some online sites but they all appear to be Warez or similar ... and I've heard they can be loaded with unwanted presents. Plus ... I wonder whether my ISP is watching my downloads ....

Anyway, I have almost given up on getting this game to work. I'd like to try with Command & Conquer - Tiberina Sun. This should work, since there are other similar packages there in the repository under games. But this is also a 2 CD install ... I wonder ....

And yes, I do have the original CDs ...

Will let you know if it works.
enr23 Donderdag 30 April 2009 om 11:29

No, can't install that either. The error message is:

"The program GAME.EXE has encountered a serious problem and needs to close. We are sorry for the inconvenience. This may be caused by a problem in the program or a deficiency in Wine. You may want to check http://appdb.winehq.org/ for tips about running this application".

Well, the site has it that others have installed it fine ... so I'm in a muddle. Hmmm ...
NSLW Donderdag 30 April 2009 om 11:35

I had a look at some online sites but they all appear to be Warez or similar ... and I've heard they can be loaded with unwanted presents.

Quote from enr23

Check your private messages if you still want to run Spellfoce.

I'd like to try with Command & Conquer - Tiberina Sun

Quote from enr23

You will probably encounter the same message about no cd.
enr23 Donderdag 30 April 2009 om 13:01

Update - still can't get SpellForce: The order of Dawn to work, but C&Q: Tiberian Sun is working well now after downloading the patch from ftp://ftp.westwood.com/pub/tiberiansun/updates/. Also, installing the online components is a must. I have no problem saving to, and loading from, saved games.

However, I can only run at 800 x 600 resolution ... eyes tend to water after 5 mins of it. I followed the advice given at http://appdb.winehq.org for creating AppDefaults-->game.exe-->Direct3D keys with its values, but it made no difference. Still, it worls ...